Sony STR-DE875 Receiver Logo

Related Topics:

Question about Sony STR-DE875 Receiver

1 Answer

Sound turns off for Sony STR-DE875 amp

Hi, I have a Sony STR DE875 and the front channels are both not wroking at all. Any suggestions

Posted by adeel choudhry on

  • adeel choudhry Sep 01, 2007

    Hi,
    I here the first click and also my center channel and surround is working fine, only the front channel isnt

    Please let me know

    Thanks a lot

    Regards,

    A. Choudhry

×

Ad

1 Answer

Tinu Patel

  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

If you do not here a click as soon as the power is turned on, (note you must be in a very quite environment no noise absolutely to hear this) then the amplifier has blown output transistors which are pushing DC current to the speakers.

Posted on Sep 01, 2007

  • Tinu Patel Sep 02, 2007

    Have you by any chance removed the pre-amp jumpers for the front? Also by mistake it is possible to turn off the front speakers by remote through speaker selection by setting the front speakers to none. Some amps have the ability choose different size speakers for the front such as small with a subwoofer and also large without a subwoofer. Try looking this up in your manual if not try downloading the manual. If this doesn't work I can look for the manual and suggest.

×

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

Remote work properly

Make sure the batterys are good if so open the remote and check the led that send the signal it may be unsoldered
0helpful
1answer

Problem with SONY STR-DA555ES home stereo receiver popping & going into protector mode

You may have the speakers incorrectly connected or the speakers you are using have an impedence that is too low for the amp to support.
0helpful
1answer

Str-de875. Remote is suddenly not making the amp work. the remote still turns tv on/off

does the light blink more than once when you select the 'contol the reciever now' button? I assume you push a button to switch which device the remote will control, and then push another button to astually have the device do something
0helpful
1answer

Sony STR-DE875 receiver has no sound from right channel front or back. Checked for loose connections & blew out dust, no change

Hy all. I bought a receiver at last week. But the front speakers not working. The rele is jumping just.

i repaired them ! the rele colour is blue. Three percent . left first -Center, between -Surround, between(right Hand)-Front.
I moved the front channel's rele(right hand) .Katt -it sad. Working, volume is back. Rele specification is (colour Blue) Deg Greatings-Ranger of Hungary.10_26_2012_6_50_16_am.jpg
0helpful
1answer

Volume really low, even when turned right up

So the speakers and the individual amp channels work so that lets out the obvious big hardware items.

This is starting to sound like an obscure setting was set or changed by mistake.

It would be nice to figure out what that is/was in case it happens again but you may eventually have to resort to resetting the receiver to factory defaults and start over by holding the1/0 button for 5 seconds.
0helpful
1answer

I want STR-DE875 REMOTE CONTROL (sandal colour)

There is one one Ebay. Search for RM-PP505
0helpful
1answer

Quiet front R channel on Sony

Does problem persist when you connect other speaker to front right channel? (i.e. when you connect your FL speaker to FR and vice versa)?
0helpful
1answer

Sony str-de875 amp. one speaker louder than the rest

hi. i have a sony amplifier. i plug the speakers in like normal. i turn it on and the right side speeker works fine. but you half to crank it up all the way just to barely hear the left speeker. we switched speakers and its still the same effect. we think its the amp itself. we tried our balance settings. it was fine. but right now its just playing one speaker louder then the left one. can anyone help me?
0helpful
1answer

Sony Receiver has little sound on radio stations

have you adjusted your sound settings while in listening to the radio mode?
Not finding what you are looking for?

765 views

Ask a Question

Usually answered in minutes!

Top Sony Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5720 Answers

The Knight
The Knight

Level 3 Expert

76835 Answers

 Francisco Mauricio...
Francisco Mauricio...

Level 3 Expert

1551 Answers

Are you a Sony Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...