Ideazon PW1USE1-B3 Keyboard Logo

Question about Ideazon PW1USE1-B3 Keyboard

1 Answer

World of warcraft zboard installation

I just bought the wow zboard and base today, when i went to install it i got an error thisis what it said fatal error: setup failed -u-0 can't install kernel drivers i am runnin a high end computer, not sure what it is my brother built it for me about a month ago. it is also running windows vista which is what i think the problem is.

Posted by pukegreedy on

  • 1 more comment 
  • pukegreedy Aug 28, 2007

    thanks for the help, what i ended up doing was lookin up more stuff and i read that some fo the first zboard installation cds were not working so i went to the download page and downloaded the install program from there and BINGO it worked

  • Anonymous Dec 25, 2007

    It says I have a fatal error and that I need a KERNEL DRIVER or something

  • buddha_007 Dec 11, 2008

    when i try to install it does not work and every link for the drivers are down this is ****



×

Ad

1 Answer

Anonymous

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 42 Answers

Hi I feel that you may be right what i would sagest is going the windows vista compatibility section and check that the hardware you have is on there compatible list if it is not you may have to go to the web site that your hardware uses and see if they have a patch for windows vaster i am sorry that i cannot be of more help Paddy

Posted on Aug 26, 2007

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1helpful
1answer

Zboard button malfunction

re-install your driver for your z board and make sure the wow keyset is fitted corectly.
2helpful
1answer

Zboard

I had the same problems as you and found this answer on blizzard forums.



First, the disc that comes with your ZBoard is now too old to use. The drivers on the disc were made by Ideazon before Steelseries took over, whereas the WotLK keyset was made afterwards. Steelseries seem to have completely reworked the drivers in the interim.

How to Fix
Step 1. Uninstall your ZBoard.
Step 2. Go to http://www.steelseries.com/downloads/#keyboards and DL the Z Engine.
Step 3. Make sure your ZBoard is plugged in with the standard keyset.
Step 4. Install the new Z Engine.
Step 5. Switch to your WotLK keyset.
Step 6. Run WoW.

I used this solution last night with some success.
Most of the gamer keys now work but some still don't work correctly such as, all the chat buttons default to say.
Hope this helps
1helpful
3answers

ZBoard setup for WoW keyset not working.

go to

www.steelseries.com/downloads

select the USB zboard keyboard and download the relevant patch/software

I have done this, and my WoW ZBoard and all the special functions buttons work

The problem is, ideazon was bought out by steelseries, but this information was no included when you bought the board.

1helpful
1answer

Problem installing Zboard

return the item there are no mac drivers
3helpful
1answer

WOTLK Keyset not enabling

http://www.steelseries.com/downloads/#keyboards.

click usb zboard update. open file when downloaded. run the installation and you're set.
1helpful
1answer

Cannot use my world of warcraft keyboard say's to get download. it still doesn't work i want to play wow plz. help

Uninstall the current zengine. Then reboot and go to http://www.steelseries.com/downloads/#keyboards
Download the new drivers for your keyboard. The light probably wont work but but the keys should. Good Luck
1helpful
2answers

Ideazon World of Warcraft on Zboard

Uninstall the zengine reboot then go to http://www.steelseries.com/downloads/#keyboards
Then download the newest version. The light probably wont work work but the keys should. Good luck
Not finding what you are looking for?

3,852 views

Ask a Question

Usually answered in minutes!

Top Ideazon Computers & Internet Experts

Ekse

Level 3 Expert

13435 Answers

Brad Brown

Level 3 Expert

19008 Answers

Cindy Wells

Level 3 Expert

6450 Answers

Are you an Ideazon Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...