Hoover U5753-900 WindTunnel Bagless Upright Vacuum Logo

Related Topics:

Question about Hoover U5753-900 WindTunnel Bagless Upright Vacuum

1 Answer

Burning smell When i start up my vaccuum it gives off a burning smell, it still picks up & operates like it should just leaves the house smelling like ive had a fire. Any advice on how to fix will be greatly appreciated.

Posted by Tone-D on

  • 3 more comments 
  • cfelabom Mar 03, 2008

    Hoover U8146-900, same problem, but my unit has no belts. What else could it be? There are two motors, one for suction, one to turn agitators. Would replacing either or both of these motors fix the problem?

  • sadrawalker Dec 06, 2008

    Mine also smells like a fire except it wont' stay running. It tries to turn on/run for a few seconds (while stinking) and then it stops. I think it may be a motor but I cannot find where the motor is or how to replace that.

  • Anonymous Dec 09, 2008

    i have the same problem. the belt was replaced a few months ago...i haven't had the vacuum for even a year. i've replaced the filter and it still smells. It picks up fine, but i'm scared it's gonna catch fire or something. the hoover website is undergoing maintenance so i guess i'll put in a call to customer service

  • ladybug49_us Jan 03, 2009

    I have had my WindTunnel for 2.5years. It works fine, but now leaves a burning smell throughout the house.

  • Anonymous Feb 03, 2009

    Same problem - hot burning smell whenever we run it. I checked belt and it looks fine - but will try replacing it.

×

Ad

1 Answer

Anonymous

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 126 Answers

Replace the belt. It is probably stretched and is slipping. This will produce the smell your describing. These belts should be changed at least once a year.

Posted on Jan 12, 2008

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

My vacuum smells all the time like someone threw up. It stinks the whole house. It is not a burning rubber smell as the smell is there even if not using the power head.

Have u got dogs? if its smelling bad "we are what we eat" and so is the vacumn.try a carpet powder "shake and vac etc." Empty after each use
Apr 07, 2017 • Vacuums
1helpful
3answers

Burning smell

The response by Lynnette is in reference to the power nozzle....if you are having this issue with the main unit, then it could be the armature is starting to go bad. Have your Rainbow in front of you and give us a call. We can walk you through some steps to narrow it down.

www.rainvac.com
800-523-0510
0helpful
1answer
2helpful
1answer

My Oreck XL 9100HA started smoking (white smoke) when I vacuumed. There is a burning rubber smell. How do I check/change (if appropriate) the belt? I have no User manual, nor can I locate one on the Oreck...

It sounds like the belt has been damaged. You can get another belt from yoru local Oreck store. You can even take it in to the store to show them what happened. Purchase another belt and replace it. (It was very easy when I did this, so hopefully the belt is all you'll need too.)

Best of luck!
2helpful
1answer

Smells like the motor is burning. observing sparks. It the motor cooked and is it just time for a replacement?

If you're observing sparks, then yes, just get a new one. With the low prices of good vaccuums its not worth starting a fire with your vaccuum. If it just smells like the motor is burning, check the belt and make sure its rotating freely and if you have an attachment, make sure the brush on the vaccuum is not being stopped while using the attachment. However, if you are seeing sparks,,,, definately time to junk it
1helpful
1answer

Burning smell and not picking up dirt

You probably need to change the belt. Here is a link to the belt you need and to the manual:

Eureka 2961AVZ Belts

Eureka 2961AVZ Owner's Guide (3.4 KB download)
0helpful
2answers

Burning rubber smell when the vacuum is on.

it sounds like the belt may be burning like the roller bar is stuck maybe or the belt is stretched and is burning itself off
Not finding what you are looking for?

406 views

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Brad Brown

Level 3 Expert

19008 Answers

Mike

Level 3 Expert

4382 Answers

Thatvacguy.com

Level 3 Expert

1619 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...