Sony Xplod XM-554ZR Car Audio Amplifier Logo

Question about Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Rockford Fosgate P3002 Amp

I hooked up my amp to my subs the other day and i got a lil bit of sound, it just come out verry quitet when the deck is full out and no power at all, the light's go on the amp for power. how would i go about to fix my amp.

Posted by flashlight on

Ad

1 Answer

Anonymous

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 113 Answers

What are the color of the lights that stay on.red= protect/ green=on.if the amp has little sound it probably still working,check deck output volume(rca)

Posted on Aug 22, 2007

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

Does anybody know what watt this is. it's sosed to be a 2400 watt and why does it have 2 ports on each side to hook up speaker wire And what's the best way to run it with a 800 watt Rockford fosgate

dual voice coil subs hook up mono on amp, from amp - from right side + from left side of amp run to sub n then jumper wires from one side of sub to the other side goes negative jumps on positive and positive jumps on negative
0helpful
1answer

Rockford Fosgate P3002 stopped working

push down and up on your subs and see if they make a starching noise, if they do then they are blown. take a test light to the amp, on the power and the remote and see if it lights up. if it does then turn the amp down and with a small speaker plug it in to the speaker outs on the amp and see if it plays if not then your amp is bad.
1helpful
1answer

I recently hooked up a new kenwood deck put new front and back speakers in. I hooked up a 1200 watt hifonics amp about to plug in my 2 15 inch rockford fosgate speakers rfz1412 and they dont play. All the...

Ok, so I am assuming that the other speakers are working, and it's just the subs that are not, right? If this is the case, start from the source. Make sure the RCA cables are plugged in and not crimped anywhere. Then to the amp, Did you check the gain levels on your amp. That is the knob next to the RCA input on the amp. Also, check the wiring to the subs. Make sure all your + are goinig to +. Sometimes in the "heat" of a good install, you just lose track of those things. When in doubt. Undo all your wiring and start from scratch. Good luck.
0helpful
1answer

Why does my 6x9 amp drop or not let the sound play at all when my subs are on? it just started to happen? they worked together fine before. i turn the subs off and the 6x9 work? but when i turn the subs on...

You probably have too much hooked up for the size of your power supply which is presumably a small car battery. You either need to get:

A) New, better bigger battery.
B) Capacitor in series with battery.
C) Both of the above.
1helpful
3answers

How do I hook up one sub to my rockford fosgate p3001 amp

Hey i have looked over many rockford manuals,(i own a 300.1 my buddy owns a 325.1) and for there mono(.1) amps there hooked together on the inside so channel A+ and B + are cencted on the inside the amp. So you ither hook one 2ohm sub to channel A or you can hook 1 4ohm subs to channel A and 1 4ohm sub to channel B. There 2ohm stable so any lower will eventualy burn the amp out.
0helpful
1answer

I have a rockford fosgate 501bd amp the protect light comes on when my deck turns on even with no speakers connected

un hook the subs and let the amp sit there on if the protect light shuts off you wired your subs wrong if it doesnt go off tun it off then back on with no sub music all the way down then slowly turn the music up if the light is off then comes on you need new rcas
0helpful
1answer

Quick question, amp problem

make sure you ground wires arent shared, meaning run each ground wire from each amp to its own grounding point
0helpful
1answer

Not working

maybe you should use 4 awg wire
0helpful
1answer

Sub hook ups

There's a lot more factors involved than that.
  • Power capability of the subs
  • Type/size of the sub box
  • Allotted space in the vehicle for the sub box
  • Voice coil impedance of the subs versus the capability of the amp
  • Etc.
Not finding what you are looking for?

267 views

Ask a Question

Usually answered in minutes!

Top Sony Car Audio & Video Experts

 Francisco Mauricio...
Francisco Mauricio...

Level 3 Expert

1551 Answers

The Knight
The Knight

Level 3 Expert

76835 Answers

 Grubhead
Grubhead

Level 3 Expert

5720 Answers

Are you a Sony Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...