Question about Hifonics Brutus BX 1505D Car Audio Amplifier

1 Answer

How to reset my system?

Okay i have the red power light with no sound going through the amp i was told to reset my sysetem? how would i go about doing that? if it helps i have a 1996 monte carlo

Posted by Alex Haak on

Ad

1 Answer

Anonymous

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Expert
  • 113 Answers

Disconect all power cables then short between terminals G&P G&R .a little spark but ok.try after 10min.

Posted on Aug 22, 2007

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Unable to connect to internet. Only two lights show -- power & dsl. When I called for help I was told I needed a new ethernet cable. Bought that & installed. Same problem -- only two light lit...


In all there should be lan led, dsl led, power led and internet led,
So if dsl and power led is glowing and others not?? than check the lan cable and even check the lan card of ur pc is it enabled or drivers are properly installed and same way try to check the modem configuration??

Sep 08, 2010 | Siemens SpeedStream Modem (4100) (SS4100)

1 Answer

DO YOU FIX PS3s... I have tryed everything i can think of incloding different cables HD & normal,different TVs HD & normal Also holding down the power button and waiting for the beeps.But nothing...


  1. Make sure the HDMI cable is connected to the HDMI OUT port on the back of the PLAYSTATION 3 system. Connect the other end of the HDMI cable into the HDMI Input port of the TV or display monitor.
  2. While the PLAYSTATION 3 system is in standby mode (red light on the front of the system), hold down the touch-sensitive power button on the front of the system until the system goes into standby mode again . (So the light cycle would go from: red light --> green light --> then back to red light). This will ensure that you have held down the power button long enough to reset the Video Output Settings.
  3. Turn on the PLAYSTATION 3 system and once the system finishes powering up, the Video Output Settings will automatically reset to the standard resolution (or detect the current display output settings of your TV/monitor).

SAFE MODE

Have a look at this, it may help.

Jun 30, 2010 | Sony Playstation 3 (PS3) Console

2 Answers

Toshiba 46in DLP No Picture, but good sound.


Hi my name is Eric,
I hope I can help you with your issue ,
Sounds like a bad lamp assembly , search for one online by model# for between $100-$200
easy to install yourself
 
 
 
 
Hope this helps, if it has solved your issue please click accept
But if you have more questions please respond and I will reply asap
Thanks
Eric

I’m happy to help further over the phone at https://www.6ya.com/expert/eric_ab7c09ec01841771

Sep 09, 2009 | Toshiba 56HMX195 52" HDTV DLP Projection...

1 Answer

Computer wont boot. LCD are on. No sounds at all.


Yup. Please try to remove the battery and use ac power. Please try to turn it on and see if it is still the same. It is safe to put the battery back in even if the laptop is on. Hope this works. Thanks.

Sep 30, 2008 | HP Pavilion dv2000t Notebook

1 Answer

Red light on my amp?


Does the amp power up normally if you disconnect the speaker wires from the speaker terminals of the amp?

It's never a good thing to blindly short across a power source.

May 22, 2008 | Pioneer GM-5200T Car Audio Amplifier

1 Answer

Okay i have a problem hifonics brutus 1500 mono d class amp


well your amplifier is obviously going into protect mode,(i used to have this amp and it is awesome) anyway i would go through just to be sure and check all the power connections with a test light, remote wire, positive, and ground. and check the fuse to see if it is still good. you can buy a test light at wal-mart and any automotive store. if you stil have a problem then i would check to see if your running below 1 ohm on this amp. that would cause it to go into protect mode. if all this fails i would just go buy a new one.

Oct 07, 2007 | Hifonics Brutus BX 1505D Car Audio...

Not finding what you are looking for?
Hifonics Brutus BX 1505D Car Audio Amplifier Logo

Related Topics:

227 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hifonics Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

93 Answers

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1176 Answers

Marvin
Marvin

Level 3 Expert

85231 Answers

Are you a Hifonics Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...