Car Audio & Video Logo

Question about Blaupunkt Cancun CR63

1 Answer

Blaupunkt cancun cr63 car radio

Radio worked fine- then battery died (had nothing to do with radio). when i jumped the car- the radio went "haywire" the radio now comes in on a random station and instead of "am" "fm" mode it comes up with "vf" signal. i cannot hear the station that does come in. when i press the volume up/down the radio freezes. it also freezes when i get to the balance/fade selections. i reviewed the manual online but there is no trouble shooting. i have done nothing

Posted by country1370 on

  • country1370 Aug 18, 2007

    yes i forgot to mention that i had the cd mode coming up also. when you say fuse- do you mean in the car/van or the fuse somewhere in the radio? i am not to wise at these things,
    but i do love to try to figure them out. I also love music.
    if you give me hint on that fuse i will look into that too. hopefully with 2 of us working on it- we can fix them.

    Thank you :)

×

Ad

1 Answer

oldguy61

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I'm having the exact same symptoms and have had the same luck online. My guess is that the logic got fried during the "brown out" while trying to crank the engine on a very low battery. I thought I might find something about the "VF" and "SK" modes that it is getting into (pretty cool if I weren't missing my radio stations). I'm guessing they are European bands or something. Also getting into a CD changer mode - funny since this was a pretty low-end cassette tape model. My Cancun is 12 years old. What I'm going to try (when it stops raining) is to disconnect the battery leads for 15 minutes or so and then reconnect to see if that clears out the radio memory (if I could easily identify the correct fuse, that would make the process much easier but, alas, I can't). Let me know if you have tried anything else and I'll let you know if my attempt works.

Posted on Aug 18, 2007

  • oldguy61 Aug 20, 2007

    FIXED IT!!! Tried the fuse thing (#10 in the in-car fuse box) but it did not work.

    However, I disconnected both sides of the battery for about 45 minutes and then re-connected. The rational mind of the radio came back!! I had to re-program all of the stations, but at least now I can listen to AM and FM.

    I'll bet the same will work for you!

    good luck!

×

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

I have a 1999 V92C. Everything was fine,Ran fine ,started perfect ,everything. Had It on a battery tender/trickle charger That went bad.the Battery died so I Tried ,unsuccessfully ,to jump it with a...

Check fuses or breakers if applicable. Check for burned wiring that occurred when charger went bad. Test all wiring from battery to switch with test light. Be sure all ground wires are tight.
0helpful
1answer

Car wont start without it being jumped.....tachometer...radio, nothing works

Might need a new battery. Thats what it sounds like it could be something else. I have a 98 subaru and i had the same problem and went and got a new battery and it worked fine. try the new battery and if that works good if not sorry.
0helpful
1answer

My battery went flat, and I have charged it for a while now and it still does not want to switch on, what should I do? I have only had it for about a month and 2 weeks now

Disconnect from vehicle and connect again. If it does not work, it is dead. Jump starting dead vehicles can damage radios.
0helpful
1answer

Renault megane 2005 dynamique this morning i went to open the car the card doesnt work as well as the car wont open withh the spare card either i got into the car with the metal key and there is nothing...

Sounds like your battery died on you. Have it checked at an auto parts store for free, also if jump starting the car works but it dies after removing the jumper cables the alternator is bad. Check the battery first as it only takes one bad cell to kill it. Most batteries are only good for a few years, longer if you're lucky. A battery can die on you with no warning sometimes.
0helpful
1answer

Hi, i have a 1995 nissan altima , When I installed my new radio deck in my Nissan , it was working fine for an hour until I turned off the car. Once I turned the car back on, none of my gauges moved, my...

flat battery isnt a good sign
no driving power =engine check light on
battery terminals tight
got 12 volt everywhere its supposed to be

was old radio linked to security or immobilizer
recheck radio wiring

1995 96 Nissan Altima Car Stereo Wire Colors
0helpful
1answer

2006 Jetta 2.5 battery died, jumped car, radio won't turn on

Take it in to have a charge system check done on it, Your alternator is probally shot,
0helpful
1answer

Started up this morning fine went and did not start at all later.

remove and, clean your battery cable clamps then retighten and, test.
If your battery is too discharged "jump" it using jumper cables and, another car.
0helpful
1answer

Is it my battery?

well this is what you should try ,,jump the car get it running
then when its warmed up take the positive lead of the battery
if the car stops the alternator is gone (thats what charges the battery) if the car runs its fine

and if u have put another new battery in it and the alternator is fine look for any broken wires earths or positives that could be making it drain so quick
and make sure your battery levels are full
hope this helps
Not finding what you are looking for?

431 views

Ask a Question

Usually answered in minutes!

Top Blaupunkt Car Audio & Video Experts

Marvin
Marvin

Level 3 Expert

85240 Answers

 Francisco Mauricio...
Francisco Mauricio...

Level 3 Expert

1551 Answers

Morne Olivier
Morne Olivier

Level 2 Expert

265 Answers

Are you a Blaupunkt Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...