Creative Labs Nomad MuVo2 FM MP3 Player Logo

Question about Creative Labs Nomad MuVo2 FM MP3 Player

6 Answers

MuVo2 FM 5.0GB (creative labs)

My MuVo2 won't turn on. Tried connecting to computer to download update and computer does not recognize. Do you think you have a solution? P.S. When I plug the DC cord and plug it in the lights go on but that's all it does

Posted by Genny Delannoy on

  • 2 more comments 
  • MAISH Nov 14, 2007

    WHEN I PLUG IT ON POWER,IT STARTS ITS ON. BUT THATS ALL.AND CANT DETECT THE USB.WHAT DO I DO NEXT

  • Genny Delannoy Jun 24, 2008

    My computer not connecting to MuVo2FM. I tried all the above to no avail. Any other solution......HELP!



    Genny G

  • Anonymous Jul 09, 2008

    WHEN SWITCHED ON IT SAYS FIRMWARE ERROR

  • muem_omega Jul 10, 2008

    i have the same pbm mention above


×

Ad

6 Answers

Anonymous

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Play off

Posted on Sep 02, 2011

Ad

duraivk

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Welcome Back:

    Visited the website for 2 consecutive days.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 6 Answers

Hi This could happen when the partition where the firmware resides got corrupted.
Get the latest firmware from Creative site. Remove the battery. holding the navigator key insert the charger power. You may be able to start the unit in Service mode Format the drive.  upload the latest firmware downloaded and ready. Let the device restart.
Cross your fingers. Your Muvo would be up and running!!  
Regards Durai V K

Posted on Jun 03, 2008

  • duraivk Jun 24, 2008

    Posting 3 & Hyd dude (4)

    Please repeat the steps 2 to 3 times and you will be able to format the hard drive. Once formatted system will detect it. Use Hp USB drive format utilty to format the hard drive and flash the firmware.

    On top of all, please let me know step by step how you have done it and your observations.



    Thanks

    Durai V K

×

Ad

Anonymous

Vikas durai i tried it but dat doesnt work... still the issue persist..
wot to do? help!!!

Posted on Jun 19, 2008

Anonymous

Hai i am from hyderabad i have some problem with
MuVo2 FM 5.0GBproblem is when i started it.It blinking on the screen like loding.... and after some time it is strucked

Posted on May 03, 2008

Anonymous

You may need to flash the firmware to the unit. if you need any help write to [email protected]

Posted on Aug 22, 2007

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

Ho wto restore frimeware

here is the Creative website support page where you can download the firmware and install it.
http://support.creative.com/Products/product_list.aspx?catID=213&CatName=MP3+Players#

Good Luck
0helpful
1answer

MuVo2 FM 5 GB MP3 Player

Before Anything Can you just narrate me what you did step by step and the observations?
Immediate Solution:

You may repeat the step twice or thrice to format. Once you format system will detect it.


If you are in India you can reach me on 09448832502
Thanks
0helpful
2answers

Reset

how do i reset my muvo2 Fm mp3 player
NEEED HELPP
0helpful
1answer

Disconnection snowball

My creeative muvo2 is not indicated in my computer i think i did not remove it properly i tried many time the coomputer is not accepting my mp3 what do i do
0helpful
1answer

Stuck in recovery mode and i don't know what to do

I recently had a similar problem, and nothing I did helped; what I eventually did sounds pretty simple and possibly won't help ( I have a feeling that it might have been a USB port issue, more than anything). I have added the description of my problem below my 'solution'.

I disconnected the player from my PC, restarted the PC, disconnected & reconnected the battery from the Muvo2, turned the player on (just to check if it was reading the music) then turned the player off. Then (with the Muvo2 powered off) I reconnected the player to the USB cable; the darn thing was recognised immediately and was working fine...

My problem:
The player was working fine, Windows (XP Pro) recognised the device as a Muvo2 & I could transfer files no problem; I clicked on 'Safely remove hardware' and removed the player. However, when I now try to reconnect the payer Windows gives me an error message, that one of my USB devices failed to connect and that it doesn't recognise the device. It suggests reconnecting, which does nothing...

The Muvo2 screen displays the 'connected to computer' image. If I disconnect using the 'Safely remove hardware' and unplug the cable, the player display says I need to connect to my PC and run scandisk. I can't get the computer to recognise the device, so I can't run scandisk. Removing and reinserting the player's battery got rid of the 'Scandisk' message & the player worked again, but it's still not connecting to the PC.
11helpful
5answers

Firmware problem

i have a muvo2 fm and reloaded the firmware off the creative website..
Not finding what you are looking for?

1,216 views

Ask a Question

Usually answered in minutes!

Top Creative Labs Audio Players & Recorders Experts

Ekse

Level 3 Expert

13435 Answers

Marvin
Marvin

Level 3 Expert

85240 Answers

Brad Brown

Level 3 Expert

19035 Answers

Are you a Creative Labs Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...