Kirby G4 Bagged Upright Vacuum Logo

Question about Kirby G4 Bagged Upright Vacuum

1 Answer

When attachment hose is on, it's extremely loud

When the attachment hose is on, it's extremely loud and smells like something is burning. It does not make this sound when the main head is on though. Any ideas as to what it could be?

Posted by snibbets on

Ad

1 Answer

Anonymous

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

That only happens to me if I leave the vacuum on the carpet and don't raise the head before 30 seconds...it is the rubber belt hanging on the metal thing that it sits on. Since the belt is not used with the hose attachment, I cannot imagine what is going on. Therefore, I've been no help at all! Just to let you know it happens to others - just slightly differently.

Posted on Aug 08, 2007

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1helpful
1answer

Kirby made a loud clunk then got real loud

sounds like a motor bearing might be bad
0helpful
1answer
0helpful
1answer

Hoover Dimension has no suction and it smells of something burning

pets in house? check all hose passages for "hairball" clog...and check the drivebelt that spins the brush...(some have an electric motor to spin the brush, thus no belt)
0helpful
1answer

No suction on my Hoover Dimension

If you smell something burning unplug until problem is found and fixed, suspect if no suction hose is blocked and if brush wheel it or the belt may be causing the smell, a bad or failing motor is less likely but possible.
Nov 02, 2012 • Vacuums
0helpful
1answer

Electrolux cylinder vacuum No suction and loud noise and smell of buring rubber

rollers are probably stuck the belt is burning check for restrictions in you hoses as well as in the vacuum as well if nothing else works a repairman
Jul 13, 2012 • Vacuums
0helpful
1answer

Kirby G4 running very loud and smells hot.

were you put the belt on see if any thing is rubbing against shaft.it may have been the belt,replace the belt and clean out the bab and also the floor brush.
0helpful
2answers

My Eureka capture bagless vacuum has just started making a loud siren like sound. It is deafening. what is the problem?

does it smell like burning rubber if not check beater brush it sounds like something may be jammed in it or near where it goes up past beater bar into the vacumn inlet if you do have a burning smell the motor shaft is spinning and thinning the belt and may also be making that sound as shaft spins on loose belt
0helpful
1answer

Extremely loud and smells like rubber burning

the loud will be the line is clog up and need to unclog the line, rubber burning will be the belt, which is worn or the brush is jam not allowing the brush to spin freely. check and clean the line and inspect th belt which run from the motor to the brush
0helpful
2answers

Eureka 5197 self propelled bagless upright

Did you check the brush roll when you changed the belt? The smell of rubber would inducate a belt slipping. So if the brush roll (part #61308-2)isn't turning, the belt would get hot and would be slipping. If the motor sounds real loud, then you could have a bad motor(part #60775-4).
Not finding what you are looking for?

199 views

Ask a Question

Usually answered in minutes!

Top Kirby Vacuums Experts

David Shaub

Level 3 Expert

2991 Answers

Paul Bade

Level 3 Expert

1699 Answers

Susan Jamieson

Level 1 Expert

6 Answers

Are you a Kirby Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...