Question about Proficient S12 Subwoofer

Open Question

Proficient sub stopped working

Does not switch auto on or off when i turn it off light does not go to red no sound

Posted by mojo_n_pburg on

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a Honda CRV 2005. Tail light remain on when I switch off engine


the brake lights and rear lights will be on different circuits, the left and right sides should also be on different circuits. They should not stay on, and certainly not al together simultaneously. You need the services of a proficient auto electrician, not a mechanic though.
Good Luck

May 28, 2015 | 2005 Honda CR-V

1 Answer

How do you change a Turn Signal switch in a 1997 Chevy Lumina


Brake lights nothing to do with the stalk swiches, they will be on different circuits. If the wipers and indicators are on different stalks I would say that you should have your vehicle checked by a proficient auto electrician rather than attempt a repair yourself.

May 27, 2015 | 1997 Chevrolet Lumina

1 Answer

My subwoofer will not wake up, regardless of whether I flip the switch from Auto to On or not. Suggestions?


The sub settings for testing should be: Crossover frequency - Max; Volume - Mid; Phase - Normal.

As a quick test, unplug the sub cab from the amplifier/receiver end. Switch on the sub and turn the volume down all the way. Briefly put your finger across to short the RCA/phono tip and ring. The sub should make a buzzing sound. You now know that the sub is working and the cable appears to be okay or not.

If you've got power then that's a good thing. It could be something simple as a broken solder joint or bulging capacitor.

Aug 05, 2014 | Harman Kardon HKTS 14 System

1 Answer

Red light


You have not got your subs wired up poperly, End it fried the ouputs on the amp, Live end learn (Dude)

Nov 10, 2012 | Nitro BMW-482 Car Audio Amplifier

1 Answer

Power light on but no sound form proficient s12 subwoofer


The power supply is working but it is possible that there is no supply to the SUB WOOFER amplifier. It is important to remove and open the unit to probe and confirm.
It can be failure of the inline fusible due to a faulty output driver.
Finally check the subwoofer using a AA cell.

Oct 16, 2011 | Proficient S12 Subwoofer

2 Answers

2 12" subs + 600W amp. Turn on, goes boom once, then red light


Is your gain all the way up? If it done this before, sounds like your over working the amp. Make sure your subs ohm load is capable with the amp load to. If they are 1 ohm and your amp is only 2 ohm stable, it would beat for a lil bit then go into protection mode to. Check your wires too.

May 13, 2010 | Insignia 600W Bridgeable Amplifier with...

2 Answers

Red light is on and subs won't play all the wires are connected correctly it all of a sudden just stopped working one day idk y


sounds like the amp is in protection mode. try disconnecting the subs and see it the light changes to green. if it does then the subs are your problem. if the light was allways red while it was working then the subs may be disconnected inside the box or have gone bad. try using a diffrent speaker and connect to the amp.

Feb 06, 2010 | Audiovox Car Audio & Video

1 Answer

Amp turns off


Sounds like you're overloading the amp's ability to drive the speakers. Turn the gain down on the amp and see if you can take your volume higher. If you have an independent subwoofer output control on the headunit, check its setting and reduce it if necessary. Also, if you're wired in parallel, rewire the subs in series to increase the load on the amp.

Jul 21, 2008 | Car Audio & Video

2 Answers

Subwoofer doesn't turn on


I felt supid this morning.
I bought a high end cable for my subwoofer.... and it did not work but a regular RCA Cable did. When I went to put the cable back in the package I saw an arrow pointing one way, I turn the cable and it works great.

Dec 12, 2007 | Kenwood VR-405 Receiver

1 Answer

Sub thumps repeatedly


since it still thumps i suspect the speaker is ok, but i suspect you have an electronic problem in the amp. since it is a powered sup & has the ability to auto turn on it has electronic circuits inside, take it to a service center for an estimate

Oct 01, 2006 | Paradigm PS1000 Speaker

Not finding what you are looking for?
Proficient S12 Subwoofer Logo

Related Topics:

102 people viewed this question

Ask a Question

Usually answered in minutes!

Top Proficient Audio Players & Recorders Experts

Muntejaya Ginting
Muntejaya Ginting

Level 3 Expert

10422 Answers

 Grubhead
Grubhead

Level 3 Expert

5700 Answers

The Knight
The Knight

Level 3 Expert

76466 Answers

Are you a Proficient Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...