Question about NAD T751 Receiver

1 Answer

Right surround channel not working in some modes

I have had this receiver for years and had no issues, but it recently developed a strange problem. In test mode, the right surround channel produces no sound. Nor does it produce sound on inputs video 1, 2 and 3. However, when running on Ext 5.1 from a DVD player, all channels work perfectly. Since it works fine on Ext 5.1 the issue is not with the speaker cabling. And since it is broken in 'test' mode, it is not a problem with the source leads. Something must be going wrong within the receiver. Is there some way to reset the software or some other trick that might put it right?

Posted by on

  • Andrew Sellars Oct 31, 2007

    Yes - the problem was as you said. That grey harness had somehow got stuck up against the casing and a connection was lost - just moving it around to give it some space fixed the problem and all is fine now.  Many thanks! 

×

Ad

1 Answer

I had the same problem with the right channel.    It turned out to be a broken wire inside the receiver; it can be found connecting from the main PCB to the card for the 5.1 board.    After repairing the broken wire, it has worked fine.   

 

The harness connects the 5.1 low level signals to the board which are then redistributed to the amplifier section.     It is a bundle of wires in gray casing and with red, black and white wires (with shielding).

 

Find the offending wire, repair or replace and it should be fixed.

 

Hope this helps

Posted on Oct 27, 2007

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why is it intermittently losing channels...front speakers and or rear surround?


How to troubleshoot low sound or no audio from the rear ...

https://us.en.kb.sony.com/.../how-to-troubleshoot-low-sound-or-no-audi...
Aug 15, 2015 - Verify that the rear surround speakers are properly connected to the ...For Dolby® ProLogic surround sound, the center-channel mode must be set to ... the center or rear surround speakers for the Home Theatre (HT) system.

Why Are My Speakers Producing Static? - Electronic House ...

www.electronichouse.com/.../home-audio/why-are-my-speakers-produci...
Here are 3 reasons that speakers produce static and solutions you can try. ... If they are your dedicated front L/R channels speakers in a 5.1 or 7.1 system, you more ...Since you have no problem with your existing rear speakers, if they begin to distort on... Home Theater Subwoofer Puts Boom in This Room · Soundbase vs ...

How to Check if your Speakers are Wired Correctly ' Richard ...

www.richardfarrar.com > Podcasting
Mar 25, 2009 - Attaching speakers to your Hi-Fi system usually only requires a few cables. ..... Is this test applicable for a home theater setup with 5 speakers? ... frontstereo speakers, but to do a similar test on your rear surround speakers would ... Yes, switching polarity on one channel of the amp output to your speakers ...

Pioneer VSX-816 speaker drop out - AVS Forum ' Home Theater ...

www.avsforum.com/.../1068233-pioneer-vsx-816-speaker-drop-out.htm...

Sep 20, 2008 - 30 posts - ‎24 authors
The right front speaker sound drops out intermittently as of about 6 months ago. ...mode and back to Auto Surround would bring the center channel back. ... the push pin that holds several grey wires in place, and pull the wires loose. 9. ..... Is it possible that the cold joints are elsewhere in the system, but that ... Yamaha RX-V663: Intermittent/No Audio in Front ...
4 posts
Jan 23, 2014
Sony Receiver going in to Protect Mode
16 posts
Jan 12, 2012
The Official Sony STR-DH820 Thread
30 posts
Aug 29, 2011
Denon AVR-1910 - No more sound.
30 posts
Feb 15, 2011
More results from www.avsforum.com

Dec 12, 2015 | Audio Players & Recorders

1 Answer

My pioneer av receiver vsx1020 produces same sound in front and back speakers


Try changing surround modes. You might be in 5 channel stereo mode.

Mar 14, 2013 | Audio Players & Recorders

1 Answer

Sony TA-AV521 I have had this stereo system with surround sound for years. Recently I am finding that the surround sound mode is not working right. There is a lot of fading in and out whether it is on...


CD's and FM radio are created in 2 stereo channels. To listen to them in Surround, artificial processing has to take place in your receiver, so artifacts and fading are quite common when you do this. When you turn the surround off, your stereo is processing the information properly and it will sound right.

Mar 02, 2011 | Audio Players & Recorders

1 Answer

TX-SR603X Left channel Front & Surround not working in all modes. Issue follows the receiver when switching speakers. Mono only produces sound from the right side.


Sounds like the left channel front etc, transistors or whatever powers it have failed. They will be on a heat sink, you just need to identify them and replace them.

Nov 28, 2009 | Audio Players & Recorders

1 Answer

Onkyo TX-DS 595 receiver surround channel unrealiable


How you power off the amp won't hurt it generally. I used to fix ONKYO amps under warranty, and I can tell you now, it will be full of dry solder joints. Take you unit to your local repairer, and they will resolder all the offending PCB's inside. This type of repair will fix 99% of strange audio noises and cutting in and out etc. for ONKYO recievers. Otherwise this is quite a good product.

Oct 27, 2009 | Onkyo TX-DS595 Receiver

1 Answer

5.1 Surround sound not working


Maybe the surround processor is having a bad day... My kenwood would do similar and a reset was necessary to correct. Have you tried resetting the system? On my Sony STR DE 597 this is accomplished by powering off. Then while holding the 2 channel button down (front face plate) power on. A reset message is displayed. Your model may be similar but check your manual or download the PDF of the manual from Sony's support website. Hope this helps

Sep 05, 2009 | Sony STR-DE685 Receiver

2 Answers

When i go to surround mode right front channel drops out


check for connection, might be the front right speaker was connected to right rear soround out, check recording if dolby pro logic or DTS system

Aug 31, 2009 | Denon AVR-3600

1 Answer

Surround speakers are not working


Yes. Make sure your speakers are first properly connected, then enabled to operate on the setup menu. Then run either a test tone for all channels or media recorded in surround sound or run in 4 channel stereo to test.
Not all media will produce surround effects 100% of the time.

Jun 18, 2009 | Denon AVR-3300 Receiver

1 Answer

Left from speaker not working- Yamaha HTR-5940-6.1 channel


Redbird,

What do you have in the "multi channel input" jacks on the rear of the receiver? Those inputs Right, Left, Center, Surround R+L, and Sub are used when selecting 6 channel mode. They bypass the receivers surround processor board.

John W

Jan 10, 2009 | Yamaha HTR-5940 Receiver

1 Answer

No sound from left rear surround speaker


i think it would probably be somthing inside the channel???

Jan 01, 2008 | Aiwa NSX-DS55 CD Shelf System

Not finding what you are looking for?

Open Questions:

NAD T751 Receiver Logo

Related Topics:

393 people viewed this question

Ask a Question

Usually answered in minutes!

Top NAD Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5699 Answers

The Knight
The Knight

Level 3 Expert

76237 Answers

cheekygr1n

Level 1 Expert

3 Answers

Are you a NAD Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...