Technics SUV500 2-Channel Amplifier Logo

Related Topics:

Question about Technics SUV500 2-Channel Amplifier

2 Answers

Technics SA GX500 - suddenly muted I've had this for a long time and it's a great unit. Of course, I lost the remote along the way. While playing with the EQ, the "muting" suddenly came on and I can't figure out how to turn it off. Any ideas?

Posted by Brandon Finch on

  • garandgar
    garandgar Aug 26, 2013

    Hold the PHono button down for a while and muting should turn off

×

Ad

2 Answers

Anonymous

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

HAVE YOU TRIED DISCONNECTING FROM MAINS FOR AWHILE

Posted on Aug 11, 2007

Ad

Andre Baumann

  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

  • Contributor
  • 1 Answer

I have and it doesn't work

Posted on Dec 16, 2014

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

I've got a technics stereo tuner/amplifier SA-EH780 I lost the remote and it is stuck on standby how can I get it off standby

New remote for around £12.
https://www.ebay.co.uk/itm/NEW-RM-Series-Replacement-HiFi-Remote-Control-for-Technics-SA-EH780-SAEH780-/291862138581
0helpful
1answer

Technics sa gx500

I suppose you did not forget to engage either 'A' or 'B' speaker selectors?
0helpful
1answer
0helpful
1answer

Sa gx500 technics cooling fan dead

pull out the fan inside before you buy a new one check first the voltage line of fan usually it reads 6vdc to 12vdc after you verify there was a exising voltage ouput then the time you buy a replacement and confirm that the fan is dead .
1helpful
2answers

I have an old Technics SA-GX300 receiver that works fine except that the screen indicates that muting is on (still produces volume but at much lower levels). I lost the remote to the receiver. Is there...

Reliance on the remote instead of walking across the room to touch the unit will not solve anything. On many receivers, Muting is cancelled if the volume knob is turned to a louder level. Try that.

There's a used original remote for $12 delivered on eBay right now.

http://cgi.ebay.com/Technics-RAK-SA301P-Audio-Remote-Tuner-TV-VCR-CD-/230644267386?pt=LH_DefaultDomain_0&hash=item35b378397a
4helpful
1answer

My Technics SA-GX100 Reciever worked for a minute, but when i set it up with all the speakers and attachments, it says "muting". i dont have a remote, so how do i UNMUTE it?

According to my Technics SA-R210 manual to UNMUTE without the remote....do the following......PRESS BOTH THE VOL UP & DOWN CONTROLS & THE LOUDNESS SWITCH ON THE UNIT AT THE SAME TIME......Not sure it will work for your model but that is what it shows for The Technics SA-R210 model, so it should be pretty much the same
0helpful
1answer

Technics SA-GX500

It looks like overheating problem. Dust fills heatsreader of amplifier.
Not finding what you are looking for?

1,422 views

Ask a Question

Usually answered in minutes!

Top Technics Audio Players & Recorders Experts

 Francisco Mauricio...
Francisco Mauricio...

Level 3 Expert

1551 Answers

Morne Olivier
Morne Olivier

Level 2 Expert

265 Answers

The Knight
The Knight

Level 3 Expert

76843 Answers

Are you a Technics Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...