Question about Kicker KX120.2 Car Audio Amplifier

1 Answer

Kicker kx120.2 protection light

Well i had the system working for about 30 seconds then it just stopped working. the protection light comes on when i turn the car on. what could be the problem?

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 84 Answers

Make sure that your ground connection is secure. Make sure there aren't any blown fuses.

Posted on Jul 18, 2007

Ad

1 Suggested Answer

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Reset change oil light on a 2001 Saturn l300


I don't know the year of the vehicle so I'll give you 2 possible ways to reset it.

2004-2005

Turn the ignition to run (one position before starting engine).
Immediately after Step 1 press and release the gas pedal 3 times within 5 seconds. If the Change Engine Oil light is flashing, the system is reset. The light will flash for up to 30 seconds or until the ignition is turned off. If the light comes on again and stays on for 30 seconds at the next engine start, it did not reset. You will need to reset the system again.
Turn the ignition off and then start the engine to verify the indicator has been reset.





Turn the key to run, but don't start the car. Open up the underhood fuse box (move the coolant line out of the clips for easier access). In the fuse box is a button labeled "OIL-R". Hold it down for five seconds. The "change oil soon" light should flash for about 30 seconds or so. That means it's reset.

...


Sep 09, 2016 | Saturn L300 Cars & Trucks

2 Answers

Holden rodeo 2003, wont rev over 3000rpm


run a scanner on the system to determine codes to diagnos problem

Apr 13, 2014 | 2003 Isuzu Rodeo

2 Answers

Car starts fine then battery light comes on, after a minute or so the abs light comes on and lose all dash function......any help would be great


check your battery connections for corrosion, also see if the terminal wires to the battery are loose.

Dec 30, 2013 | 2002 Toyota Avalon

1 Answer

Reset passlock code


Is your Impala a 2000, 2001, or 2002? This seems to be a common problem in those model years...much like its predecessor the GM VATS (Vehicle Anti-Theft System). While the VATS had a permanent (albeit unapproved) solution, no suck workaround appears to be available for the Passlock system. Some websites offer a correction "module" that looks to be a hit-or-miss solution. I did find the following procedure on a forum, and it seems to be reliable. Here goes:
If your car has been sitting while you were at work or home or in the store, and you are coming out to leave, follow steps 1-6.

If you just had the SECURITY SYSTEM lock you out of the ignition system, you will have to wait the 10 minutes for it to reset and allow the ignition control module to interact with the system. Once the 10 minutes have passed from the ACTIVE SECURITY STATUS, follow steps 1-6. Do not try to shortcut this as it wont work.

If it is raining, you can close your door, just not all the way. Close it all the way and open the door latch without pushing the door open. This will keep you dry.

+++++STEPS+++++ 1.) OPEN YOUR DRIVERS DOOR AND SIT DOWN. 2.) PLACE KEY IN IGNITION, WAIT FOR CHIME. (3 seconds is what I usually wait) 3.) TURN IGNITION 1 CLICK RIGHT (TO THE ACC POSITION) AND STOP! Do not continue to ON and START yet. WAIT ATLEAST 5 SECONDS 4.) AFTER 5 seconds has passed, TURN KEY TO ON and STOP, DO NOT CONTINUE TO START YET! 5.) WAIT AND WATCH. With your drivers door open, here is what you will see and hear = Your notification will signal DOOR ADJAR, then the BATTERY light, then the SECURITY light, during which you will hear the chime sound as if you just started the car. 6.) AFTER YOU SEE THE SECURITY light switch back to DOOR ADJAR or Battery, and after the CHIME has stopped, you can turn the key to start and voila!

It has worked every time for me and 5 of my friends. This whole process takes about 20-30 seconds, but it sure as hell beats 30 minutes, as GM refuses to compensate my time lost to their vehicle\'s design flaws.

RECAP: 1.) Open driver door, sit down 2.) Insert key in ignition, wait for chime 3.) Once chime starts wait 3 seconds 4.) Turn key to ACC position WAIT atleast 5 seconds 5.) After 5 seconds turn key to the ON postion and wait for the security light to switch back to Battery or DOOR adjar, and the chime to stop (Do not try to START if the chime is still sounding) 6.) Once chime stops and Security light has passed, You may now complete the turn to START and it will start.

Note: This is not a permanent workaround, but it will buy you some time, I can almost guarantee it will work for most if not all people, almost all the time.



Oct 11, 2013 | Chevrolet Impala Cars & Trucks

1 Answer

Heater stopped working. Blower comes on for about 30 seconds then turns off


On the passenger side of the dash thereis a fuse block. Find the HVAC blower fuse. Start the car, turn on the blower, and check for power at that fuse. If power disappears when the blower stops than you have a bad ignition switch.

I’m happy to assist further over the phone at https://www.6ya.com/expert/jeremy_d728a59f986299fa

Dec 13, 2012 | 2000 Chevrolet Malibu

1 Answer

I'm the original owner of this projector with not many hours on the lamp. About 1 year ago it became difficult to turn the projector on. Eventually I would get it turned on by multiple attempts and...


Hi Ron.

Re:"a clicking sound that continues for 20-30 seconds than stops as the projector "gives up" trying to turn on"

The clicking sound and the projector not responding is not indication of a particulare issue or fault, but just the generic protect mode that kicks in whenever a fault is detected.
The condition is called protect mode or protection.
The clickin noise is a safety switch that keeps turning off the unit until the projector shuts down completely.

When the problem is the lamp the unit does not go into protect mode, but usually there is a well defined diagnostic condition (eg. a lamp light on). I do not think that the problem is the lamp.
Most common failure is the PSU (power supply), with in second place convergence issue. Other faults, like the lamp power board or main digital board failure are still possible.

As first trubleshooting, try leaving the projector off and disconnected for one hour, that will probably not help, but is a necessary step to ensure that there is a fault.

If that doesn't work, then the choice is between calling manufacturer and taking the projector to a local technician.

Jul 26, 2010 | Televison & Video

1 Answer

Legacy LA770 worked for 2 10" subs but not for 1 12" sub


if the protect light is still on with all speakers disconected then you have overloaded the internal ic and blown it beyound its ability to reset

sorry

Jun 25, 2010 | Legacy Audio LA770 Car Audio Amplifier

1 Answer

Pilot light is lit fires up for 30 seconds then shuts down.


do you have a CO detectors? If so try resetting them

Feb 22, 2010 | Heating & Cooling

1 Answer

Green power light comes on, the turns right back off. No picture. Please help


I'm not sure what TV model you have. But, thing I can tell you is the most common problem.
Most of the time with flat panel TVs, the power supply for the screen fails. And the TV normally turns itself off to protect other parts in the TV from being damaged. Basically " Protection Mode".

You can try leaving the TV unplugged for 30 minutes so the TV can reset itself; then try again turning it on. If it doesn't work after that, it's time for the TV repair shop.

May 21, 2009 | Sanyo Televison & Video

1 Answer

WHITMAN


Check your cold start sensor. You also might have a tranny issue (let's pray this isn't the case)

Jun 20, 2008 | 1993 Acura Legend

Not finding what you are looking for?
Kicker KX120.2 Car Audio Amplifier Logo

Related Topics:

150 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kicker Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

93 Answers

Marvin
Marvin

Level 3 Expert

85222 Answers

Dalynn Turner

Level 2 Expert

346 Answers

Are you a Kicker Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...