Mitsubishi VS-45605 50" Rear Projection Television Logo

Related Topics:

Question about Mitsubishi VS-45605 50" Rear Projection Television

1 Answer

No Picture Sound OK

Got a 96 Mitsubishi Rear Projection and I noticed over the past month or so it took it a little longer for the picture to pop up on the screen. Today when I was watching it the picture all of a sudden gone off but I could still hear the sound. I did what anybody else did and tapped it on the side and it popped back up and then went back off. So before I go and tear this thing apart can anybody give me some help as to what caused this and how can I fix it and is it gonna cost me an arm and a leg? Thanks!!

Posted by Adam Richardson on

Ad

1 Answer

Anonymous

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 150 Answers

Sounds like maybe some bad solder connections in the deflection area, If I remember these monsters correctly they are hard to dissassemble with lots of wires, the culprit is probably a solder crack around the horizontal section or the power supply for the horizontal. Might require a technician for service, if you attempt yourself, use lots of masking tape to label your wires.

Posted on Jul 08, 2007

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
2answers

Sound is O.K. no picture?

mitsubishi vs4561c projection tv no picture screen is blue sound is ok
0helpful
1answer

PIcture Flickering

you may have a convergence problem. need to replace the stk 392-040 2 eq..
0helpful
1answer

WS-65907 picture problem

Try resoldering the convergence ICs mitsubishi has been known to be a little stingy on the convergence IC solder in the past.
0helpful
1answer

I have a 50 inch hitachi ultravision that has no picture or sound but power light is on

Probably a 'cold or detatched' solder joint on a component on that perticular circuit board you are 'wedging' with a plastic rod.
0helpful
1answer

67" rear projection Mitsubishi....

Sounds like a cold solder joint, turn the main pcb over and see if you find any cracked solder or where the solder looks like it got hot.
0helpful
1answer

Lines on tv

Set starts, horizontal and vertical deflection work, HT ok, crt heaters ok, but no sound or picture
I turned the G2 voltage up and noticed a white screen with flyback lines, frame ok. I detected two badly soldered double diode rectifiers in the secondary part of the power supply ! I checked all other joints, and everything was ok !! success
White horizontal line (no vertical deflection)
Check / replace R548, R549
Sound but no picture except for a couple of horizontal colour lines
Replaced the frame chip TDA8356, set now ok
0helpful
1answer
Not finding what you are looking for?

39 views

Ask a Question

Usually answered in minutes!

Top Mitsubishi Televison & Video Experts

The Knight
The Knight

Level 3 Expert

76843 Answers

Ekse

Level 3 Expert

13435 Answers

Cindy Wells

Level 3 Expert

6472 Answers

Are you a Mitsubishi Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...