Question about NEC MobilePro 900c Pocket PC

1 Answer

NEC MobilePro 900c - Loose power connection issues

Hello. I have several MobilePro 900c's that have a loose connection where the AC power connect to the unit itself. As you can imagine this is causing the unit not to charge properly if at all. Typically I can "wingle" the power cord and the unit will start charging, but as soon as I set it down the connection "breaks" and it will stop charging. I have take one of them apart but it appears the power connection on the acutal unit is one piece attached to the motherboard. It is the inside part of the connection that is "bad" and seems to have worn over time and is no longer a tight fit. My question is, does anyone know of a way to correct this myself or can someone point me in the right direction of a honest and reasonably priced repair Tech that will be able to fix this for me. Any advice would be greatly appreciate. Thanks in advance.

Posted by on

  • Lance Oberlin Jun 27, 2007

    FYI - I have 6 of these units that have this problem. Thanks.

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,314 Answers

This is not something you will want to undertake yourself unless you are extremely handy with a soldering / desoldering iron and are comfortable doing this on multilevel boards. The place I use for this type of repair is: Computek Inc 3710 W. Chestnut Expressway Springfield, Mo 65802 417-863-8119 PH# 417-863-9151 Fax# [email protected] E-Mail

Posted on Jun 27, 2007

Ad

1 Suggested Answer

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

NEC Mobilepro 900c will not connect w/computer


Are you using the NEC Mobilepro 900c drivers? I'm sure the drivers are different. YOu can find the XP drivers here: http://hpcmonex.net/nec900/files/soft/nec/activesyncusb.zip In addition, you should make sure that you have Activesync 3.8 or older. You can find it here: http://www.hpcfactor.com/ftp-root/software/microsoft/activesync/activesync-38/MSASYNC.EXE

Dec 25, 2007 | NEC MobilePro 900c Pocket PC

1 Answer

Mobilepro 900c won't sync


I'm having the same problem. Sorry man. I'll let you know if I find something out!
Zach

Nov 23, 2007 | NEC MobilePro 900 Handheld

2 Answers

NEC MobilePro 900c softeare


maybe is because processor ou version of windows ce

Aug 22, 2007 | NEC MobilePro 900c Pocket PC

2 Answers

WINDOWS CE PROBLEMS


Perhaps the programs you are trying to install are designed to run on your desktop PC and use activesync to transfer to the PDA..?

Aug 19, 2007 | NEC MobilePro 900c Pocket PC

2 Answers

Device not detected


download the usb drivers

Jul 29, 2007 | NEC MobilePro 900c Pocket PC

1 Answer

Nec Mobilepro 900c


right clik my computer,go to properties,click on properties,click on hardware devices you will see the list of all the hardware components installed on your computer,check to see if your network adapter is installed,if not installed you will see a yellow balloon attached to the adapter icon,then try and install the device.if the device is installedbut you can't browse,i think that has to do with you internet configuration.try using the a unique computer name and the correct workgroup name,good luck.

Feb 27, 2007 | NEC MobilePro 900c Pocket PC

1 Answer

Connection problems


Attach the AC power cord or adjust the power saving mode so the unit does not go into "standby" mode. This is caused by the unit going into "standby" mode when data is being transferred.

Sep 15, 2005 | NEC MobilePro 770

1 Answer

Why do I get the error: "filesys.exe has performed an illegal operation"?


This problem may occur if the user allows the batteries to discharge to a state where the MobilePro must shut itself down. This state may cause the system storage memory to become unstable requiring a "hard" reset after the system has been fully charged again. Failure to perform the hard reset may result in data loss at a later time. The user manual states that if you receive a message indicating that the batteries are low, immediately connect the AC adapter to the device. The solution is to perform a "hard" reset after fully charging the internal batteries, and then install the service packs, software updates and user software.

Sep 14, 2005 | NEC MobilePro 900c Pocket PC

Not finding what you are looking for?

Open Questions:

0 Answers

I WAS TRYING TO INSTALL JLIME ON MY MOBILEPRO 900, EVERYTHING WAS DONE AS PER THE DOCUMENTATION AS PER THE WEBSITE. AFTER ALL THE STRESS OF PARITIONING THE FLASH CARD.. I GOT THE FOLLOWING ERROR.. "ROOT=/DEV/HDA2" NOT found kernel Panic VFS cannot mount I dont understand a bit of this error.. i ahve tried all the zImage files on the website.. but still I am getting the same error. I used the Henchman.tar--------( All the versions avaliable on website" Haret.exe as kernel Bootloader file which read as below # boot a kernel with HaRET # # have the kernel zImage and the Haret executable in the same dir as this file # this file if named 'startup.txt' will automatically launch the kernel when you start Haret # # 'set MTYPE 659' is for the NEC MobilePro900c # # in CMDLINE change 'root=' to point to the location of your root filesystem # eg 'root=/dev/hda1' is the first partition on your CF card # and 'root=/dev/hda2' is the second partition # set KERNEL zImage-2.6.23mp900c set MTYPE 659 set CMDLINE "console=tty0 console=ttyS0,115200n8 root=/dev/hda2" bootlinux i have tried mentioning "hda1" , "sda1","sdb1","sdb2" I believe its not the problem with the Henchman file or is it??? I have the following partitions sdb1 as boot flag which is fat-1GB sdb2 which is of ext2-2GB sdb3 as SWAP-1GB i loaded the boot files in the Fat ie the Haret.exe Zimage and startup.txt file in fat system Please help me out in removing this error and getting Jlime installed in My Nec Mobilepro 900.. I used a transend 4GB flash drive

Jul 16, 2011 | NEC MobilePro 900c Pocket PC

NEC MobilePro 900c Pocket PC Logo

Related Topics:

557 people viewed this question

Ask a Question

Usually answered in minutes!

Top NEC Computers & Internet Experts

Ekse

Level 3 Expert

13434 Answers

Thomas F. Schneider

Level 3 Expert

2715 Answers

Alun Cox

Level 3 Expert

2679 Answers

Are you a NEC Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...