Sceptre NagaIII X30SV 30 in. HD-Ready LCD Television Logo

Question about Sceptre NagaIII X30SV 30 in. HD-Ready LCD Television

2 Answers

Screen goes blank after a second

I have a Sceptre Naga III X30SV. When i turn it on the screen goes blue for a split second then turns off, the audio works fine, has anyone found a solution for this?

Posted by Ryan Brown on

Ad

2 Answers

Jimmy Lam

  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 17 Answers

Resolder the transformer on the inverter.

Posted on Sep 22, 2011

Ad

Anonymous

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 8 Answers

This is an easy fix! You have a bad "power inverter chipset" To fix this issue you will have to search google for a power inverter for this particular model of lcd. It's basically just the chip that the power cable plugs into on the lcd. More than likely it's going to be cheaper for you just to buy another t.v... Sorry. I know these T.Vs like the back of my hand. I've seen this issue with hundreds of LCDs because I work for a company that fixes them. FYI - It is not your backlight because if that is broken the monitor would not even flash. It is not your VGA because if that was busted you would not see any video.

Posted on Jun 29, 2007

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

Where can I get a Audio/Video cable and Power Cord for my Sceptre 30' LCD TV-X30SV-NAGA III?

They should be fairly generic and most major electronics stores should have them.

On the internet in North America look at MCM or Suburban Electronics as both carry a lot of these items.
0helpful
1answer

I have a sceptre x20g naga III screen goes blank

if you have the warranty, return it and get a new one free. ok
0helpful
2answers

Sceptre X37sv-Naga powers on no picture

Do you get sound? If you do, then the problem will be in the backlight inverter board. You should have 24vdc presents on the main power supply which supplys the power to the inverter board. Please verify that is the case.
0helpful
1answer
0helpful
1answer

Sceptre naga blue screen when tv on then turns blank, sound on

i have a secptre t v turns on for a sec and screen is blue then goes to blank screen can anyone help
1helpful
1answer

I have a 32 inch sceptre naga. when i turn on a tv, the blue screen appears for less than a second and then goes blank. the sound is still on. what could be the problem

mine does the same thing, before... it would come on when i turned it on & off. But now it blue screens then blank black. Blue means if it stays blue & i turn on my computer it will show all the computer stuff, i have not used TV yet.. But if you can get it to stay blue you can change things with the cc control, or swap..
If you find how to keep it blue let me know please..
5helpful
3answers

X20G-Naga III screen goes blank after 1-2 secs

FIXED!
Device : Spectra X20WG-Naga
Problem : monitor comes on then flickers then goes off
solution: Replace Capacitor C101 (150uf, 35V) and Fets U101 and U102 (4511GM)
Comments: This is a common problem with this monitor.


I’m happy to help further over the phone at https://www.6ya.com/expert/paul_0af9b1d5c0eb4fc3

0helpful
1answer

Where can I get inverter for X30SV-Naga III

when you turn it on there is a saying in the right hand corner saying tv off
0helpful
1answer

X20G-Naga III screen goes blank after 1-2 secs

most common lcd monitor break down, check all electrolytic capacitors for leakage and loose board solder specially on the ccfl inverter section.
0helpful
1answer

X30SV-NAGA III

So here is the scoop, sceptre told me to fill out an RMA request, fax it in with CC# and it would cost 250.00 as long as it was not the display. Upon approval of the RMA they asked for an additional 80.00 return shipping fee to be added on to the 250.00. Plus it would cost me 35.00 to ship it from Missouri to City of Industry, CA. So as you can tell it would cost me 365.00 just to send it.
Not finding what you are looking for?

430 views

Ask a Question

Usually answered in minutes!

Top Sceptre Televison & Video Experts

The Knight
The Knight

Level 3 Expert

76843 Answers

Cindy Wells

Level 3 Expert

6474 Answers

Ekse

Level 3 Expert

13435 Answers

Are you a Sceptre Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...