RCA RT2500 System Logo

Related Topics:

Question about RCA RT2500 System

1 Answer

No sound tried to reset test/setup. how do you readd speakers. I do not have the manual to it Thanks, Daryl

Posted by Daryl Dagneault on

Ad

1 Answer

Anonymous

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 3,130 Answers

You can find the user guide you need for your unit Here: http://www.thomsonnetwork.com/EN/Public/InstructionBook/IBSearchResults?querytext=RT2500*&brands=RCA%2cGE%2cPROSCAN%2cRECOTON%2cSPIKEMASTER%2cAR%2cJENSEN%2cAMBICO%2cADVENT%2cUNBRANDED&doctypes=IB&categories=ACCESSORIES%2cAUDIO%2cCOMMUNICATION%2cDTVS%2cDVD%2cMULTIMEDIA%2cCOLOR_TV%2cVIDEO&firstdocnum=1

Posted on Jun 25, 2007

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer
0helpful
1answer

We have had this system for more than 6months. We turned it on the other day to discover no sound output. Nothing through blueray, iPod, cd or even TV. We have 2 x hdmi cables and 1 x optical cable. Any...

It can be either problem with the receiver itself, cables or your speakers. You can try different combinations to narrow down the issue.
1) Also the radio does not work?

2) Try to run the Test tone to the speakers (Setup / Speaker setup / Manual setup / Test tone). If you hear the tone, then the issue is configuration problem with your inputs.

3) If possible, try to connect headphones to the receiver. If that works, it can be issue with cables/speakers or their setup.

4) Try to run the Automatic Speaker setup with YPAO microphone. It will eventually fail, but will provide you error code, which you can lookup in the manual for different reasons.

5) Try disconnecting all the cables and reconnecting them again, possible trying left speaker with right cable and right speaker with left cable.
0helpful
1answer

Yamaha RX-V365 Receiver when I hook up my center channel it is not audible at all. The R and L speakers work fine when they were located in the FRONT A and FRONT B terminals, but when I moved everything to...

With what signal did you try? Maybe your signal source (DVD/TV or radio) didn't contain any sounds for the center channel.
Go to the Setup menu, Speaker setup / Manual setup and find there item called "Test tone". It will output a test tone to each speaker individually (you will see on LCD which speaker is being tested at each moment). If you will hear a sound from the center now, there is no issue and center is working fine, just your source didn't contain any sound for the center.

If it doesn't work, then either you have faulty cable, faulty speaker or faulty center output of the receiver.
- Try connecting the center speaker to different output of receiver (this will test if speaker is OK).
- Try connecting working LEFT speaker to left output with CENTER cable (this will test if cable is OK).
- Try connecting working LEFT speaker with working cable to the CENTER output (this will test the output of receiver if OK - but use the Test Tone from Setup).
0helpful
1answer

When I start a voice call, nobody can hear me. Why? what shall I setup please? Thanks

Hi there , have you got a microphone connected and setup properly..if so then try see if you have correct drivers for sound card installed...
Try your microphone on a different PC aswell to test if its not faulty
Thanks
0helpful
2answers

7.1 speaker setup: no sound coming from right front/surr speakers

Solution to having no sound coming from certain speakers in a 7.1 speaker setup for TX-SR606 receiver when playing a DVD.

Review the cable setup for the DVD player since it was identified as the source of the problem. Best to unplug and plug in the cables to ensure they contact the back of the receiver's RCA jacks. Redo the microphone setup for Audyssey 2EQ calibration. A good chance that it is the cable that may have caused the malfunction and loss of sound from the speakers. The cables can come loose during setup and not plugged all the way to the back of the RCA jacks or a defective cable causing signal loss.
10helpful
4answers

Windows 7 Audio Quadraphonic Not functioning well

Sounds like you are getting quad sound in the test process that checks them, yet when in windows media player or winamp (or whatever) your rear speakers aren't producing sound: Try setting your sound drivers to do something like "speaker fill" then you are set. I'm under the belief that stereo sounds aren't being matrixed into all 4 speakers.
0helpful
1answer

I have a RX-V461 AV Receiver for my Samsung HDTV.

Hi,
I don't have manual here, but try to go to Setup menu / Speaker setup / Manual Setup / Config and check if rear speakers are NOT set to None.
0helpful
1answer

No sound/test tone front front right channel

1-make a reset to your system.2-repeat your speaker setup.3-confirm that you assign your sysem for 5 chanell surround system.-4-change the cables between left and right front speakers if the trouble go to left channel you will have a problem in receiver itself-if the problem exict you will have a problem in speaker itself(cable or speaker)
4helpful
1answer

Rear speakers do not connect

Hi

Hi

Check out Dell WL6000 Setup and Quick Reference Guide - https://support.dell.com/support/edocs/acc/P121646/multlang/srg/DAO/srg_dao.pdf

Try re-synchronize the wireless link. If there is still no audio form the rear speaker, check if speaker mode in your computer is set to 5.1 channels. Click Start Control Panel Sounds and Audio Devices. Under Speaker Setting, click Advanced and select 5.1 surround sound speakers.
NOTE: The rear speaker will not have audio output if the source audio does not have surround sound.

Mike
2helpful
2answers

Subwoofer volume and sound

i had the same problem when i tried to adjust speaker output levels, distance and equalizer manually without using audessy setup..so i reset everything to factory setting (0s)..and then ran 
audessy setup..reduce volume on your subwoofer to slightly above minimum(behind the subwoofer) before running the setup..once audessy setup is completed successfully..i started changing setup
manually..changed speaker config for front speaker to small (it is set as large by audessy setup), this should automatically adjust center and other speaker configuration (if not make sure to set them to small as well), then set the cross over frequency to 120..increase the volume on your subwoofer and now you should hear it fire..if this does not help..try playing some rock music with all channel streo mode..if your subwoofer does not fire even for this..then take the system back for exchange..
Not finding what you are looking for?

179 views

Ask a Question

Usually answered in minutes!

Top RCA Audio Players & Recorders Experts

The Knight
The Knight

Level 3 Expert

76843 Answers

Ekse

Level 3 Expert

13435 Answers

Cindy Wells

Level 3 Expert

6473 Answers

Are you a RCA Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...