Question about Raymarine C80 GPS Receiver

1 Answer

Fish finder not receiving data screen says no data source available Checked connections in back of unit & tried cleaning transducer

Posted by on

  • Anonymous Mar 25, 2014

    the unit itself

×

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Governor:

    An expert whose answer got voted for 20 times.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 16 Answers

You have either the DSM250 or DSM300 digital depth sounder module installed. The C80 is not seeing it.

There is an LED status light on the DSM. For starters, it should be lit either red, yellow or green to confirm it is actually powered on. We are hoping for a green light.

Double-check the cable between DSM and C80 for tightness. Also double-check the DSM's power cable for tightness.

The DSM's are sensitive to voltage level onboard. Make sure the DSM's connections to the circuit breaker panel or battery are tight and clean. Double check with a multimeter the there is 12V DC available to the DSM.

Let me know what you find.

Posted on Dec 28, 2007

Ad

1 Suggested Answer

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Gps problem


If the new harness / parts are listed for use with this model GPS, it should work - unless you have miswired something. Double-check your work. Make sure all connections are made up tight. Pay particular attention to the ground wire. Relying on the boat to pass ground it not reliable. Look for damaged or cut cable from power source and transducer. You may wish to troubleshoot with a meter or a test light to be sure power is available at the GPS. Good luck!

May 29, 2013 | Humminbird 1198C SI Side Imaging High...

1 Answer

Hello, our Raymarine ST40 depth sounder on our trailer sailer has stopped working only shows 0.00 depth on the display screen. However the metres symbol now flashes on/off. I have checked the cable...


now there is a chance that the transducer is bad ,, but I would check the battery voltage and make sure you have a soild 12 volts to the unit. also in my many years of working with and installing these units on boats I have see the needle pins ( where the plug inserts in the back of the display unit ) bend and/or break off completely. look in the plug area of the display unit and make sure all pins are intact. one more place to look for the problem is in the plug itself, take the plug apart and inspect the wire connection and make sure they are all good. if after all the above has been checked then I would assume that it is the transducer itself.
if you have anymore questions with this problem, please feel free to write back and ask,

c...

Jan 30, 2011 | Raymarine St40 Depth Display E22038

1 Answer

I turn my power source on and my screen flashes like it's not reading anything from my transducer but the transducer is new.


Has this unit worked in the past, or are the transducer and the unit itself new? Is this a Lowrance LMS-240 as indicated before your question?

Please let me know and I can help you out here.

Thanks, just reply here,
Tim

Oct 31, 2010 | Lowrance LMS-240 GPS Receiver

1 Answer

Water temp is not working can that be fixed?


Double check you have a good connection from the transducer data cable to the back of the display unit and that the pins are not corroded or anything similar. If the temp has never worked at all, it may be because the transducer you are using doesnt have a temperature sensor onboard and you will need to get one that does have this feature. If it did work previously and you checked the pins/connection (as per above) then the transducer is faulty or has developed a fault. There is no real easy fix and it will most likely be far cheaper just to buy a new transducer than to have the current one repaired by Eagle. I think new trasnducers are about $60-$70.

Mar 30, 2010 | Eagle Fishmark 320 Portable Fishfinder

1 Answer

When powering up[on land] it says transducer not connected,checked cable and connections.It use to work maybe went bad? Humminbird Matrix 10


Disconnect cable from back of unit clean the pin connections on the unit and on the cable. If rusty clean with Corrosion X are WD
IF it doesnt work replace cable Jim OMC Retired Mech

Jul 05, 2009 | Humminbird Matrix 12 Fishing System

1 Answer

Denon AVR 2106 clicking noise


I like when a user is observant and curious. That will help immensely in resolving this problem.

What source(s) are always involved with the problem?

You imply it is observable with output video to the TV - "only when there is movement on my tv screen and it stops in still screen". That sounds like a digital pathway problem of some sort as any data errors would eventually escalate to something audible or visible to you once the hardware and correction algorhythms are exhausted. The clicking inside the receiver could be its efforts to resynchronize with a bad data stream. Hence, I'd like you to isolate the ins and outs that fail all the time and find the probable single source of the problem.

Try this: put a digital source on and select/deselect it for listening or viewing. Does it make the click in that brief time it's 'thinking' before you hear the source? That would be the 'normal' sound. My Pioneer does it once per source switch. Repeated clicking would mean it's struggling.

I'm betting you have an optical or hdmi cable that's flaky or not in tight and straight. Or, if only one extternal source is involved we follow that back.

Apr 29, 2009 | Denon AVR-2106 Receiver

2 Answers

Garmin Fishfinder 160 will not display bottom contours and does not display depth continuously.


Change your setting from saltwater to fresh water even if you fish in sea water,your transducer is a 00/200KHZ and not a 50/200KHZ.
Good luck
Willem

Mar 01, 2009 | Garmin Fishfinder 160 GPS Receiver

1 Answer

Depth Sounder does not display depth


I will see if I can get mine off the hull for testing. Still have found no procedure. Thinking about just replacing the sounder with another unit.

Jul 05, 2008 | Garmin 185 Sounder GPS Receiver

1 Answer

Transducer not connected


my 947 c says transducer not connected

Jun 14, 2008 | Humminbird 947C GPS Receiver

Not finding what you are looking for?
Raymarine C80 GPS Receiver Logo

478 people viewed this question

Ask a Question

Usually answered in minutes!

Top Raymarine GPS Experts

The Knight
The Knight

Level 3 Expert

76204 Answers

Ekse

Level 3 Expert

13434 Answers

Mike

Level 3 Expert

4367 Answers

Are you a Raymarine GPS Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...