Jl Audio 500/1 Car Audio Amplifier Logo

Related Topics:

Question about Jl Audio 500/1 Car Audio Amplifier

1 Answer

Blowing fuses I have the JL AUDIO 500/1 amp running a JL 10w7 speaker. I am running 4 gauge from battery to fuse box and 8 gauge wire from fuse box to amp. After about 10-25min. of playing the bass loud I blow the 80amp fuse at the battery. I can replace it and be fine for a few days, and then it blows again. HELP???

Posted by Julius Cannon on

Ad

1 Answer

Anonymous

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 3,130 Answers

You will need to have the amp bench tested at full load to see if there is a pending problem. It will need to see with speaker loading resistors, how much current the amp is drawing and at different frequencies. if the amp checks out with the proper current, at the rated output, have the speaker checked out. Good Luck

Posted on Jun 15, 2007

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

I have a jx jl 500/l, amp will not power down unless underhood fuse is removed

check your fuse on the battery and check the fuse on the amp or it might b loose connection of power line and the remote wire(the blue wire
0helpful
1answer

Hello, I've Got the JL Audio 500/1 and I am running two 15" Kicker Comps. in a sealed box and bridged to my 500/1 and for some reason all of a sudden the amp now powers off then on none...

If your sure the unit is getting the correct power, check the ground cable, make sure it is connected to a clean surface. (remove any paint where the ground is connected.) Double check your wiring. Make sure all of your connections are good. Do not forget the fuse holder, check it too.
0helpful
1answer

Can you run a 8 gauge power wire to a jl audio 1000/1 amp and not have problems even though jl reccommends 4 gauge power wire?

Hi, if you're going to run a smaller wire, you also need to use a smaller fuse. A 50 amp fuse is needed for 8 gage wire. The fuse is there to keep the wire insulation from melting, which is what will happen if you run too much power thru the wire. If you don't plan to turn the amp up too high, this may work fine, but I would test it first with a 50 amp fuse before installing. You will need all of the speakers hooked up and the gain set to max to test the power draw. See the following link on wire sizing for more info: http://www.bcae1.com/wire.htm
0helpful
1answer

I have a jl audio slash 500/1 series amp, and it keeps blowing the fuse. am i using the right one? which one should i be using?

if its the fuse in the fuse link then you should be using the a 50A fuse thats if on your amp there is fuses that total 60A when you add it up and if it still blows then you might have a short in the power wire between the battery and the 50A fuse
0helpful
1answer

JL Amp isn't powering subs and speakers

just go through ur connections man one by one ull find the prob soon.....check teminals on battery...power line to amp ....all fuses within prob area and obviously make sure u have a good ground.....really impotant.....ground is the most neglected thing people do from my experience bein a audio tech oh and if that isnt it check ur subs....stick a 9v batt on the back pos n neg of each sub n c if they pop in r out this will determine if ur subz r blown
0helpful
1answer

JL Amp isn't powering subs and speakers

silly as it sounds, you may want to check your EQ settings on your headunit. Things like sub volume, SLA, loudness and balance. When they replaced your battery, those old settings were lost.
0helpful
1answer

My Jl Audio 500/1, power light comes on but no power to subs

maybe it dont have enough to push it ,,did you try it before you buy it?
0helpful
1answer

What to do

well i don't know your budget, but if that's not really and issue, right now at best buy, alpine type E, 10" subs, peak is 750w and rms is 250w, each is 129.99. Alpine type R, 10" subs, peak is 1500w and rms is 500w, each is 199.99. These are the best subs i found at best buy. You could sell your current subwoofers and purchase those, and you'd save space and still get the lows you want. Goodluck
1helpful
2answers

Jl audio 1000/1 low voltage -keeps shutting off at high volume

You should definitely upgrade the power wire to the sub amp to 4 gauge -absolutely your choking your amp its starving for current-poor thing is starving !!!!!!!
0helpful
2answers

Jl 1000/1 popping fuse

well you need to check to see if nt no shottage with the amp and also check if the fuse is not to low amp 20,,,, 25 if not put the amp in a separet 12 volt battery
Not finding what you are looking for?

382 views

Ask a Question

Usually answered in minutes!

Top Jl Audio Car Audio & Video Experts

Morne Olivier
Morne Olivier

Level 2 Expert

265 Answers

Mike

Level 3 Expert

4383 Answers

Joseph Hoffmann

Level 3 Expert

1756 Answers

Are you a Jl Audio Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...