Question about Jl Audio E1200 Car Audio Amplifier

1 Answer

Car amp's stopped working. Putting out a heart beat sound through subs but no bass.

Hey all, I have a JL Audio e1200 amp powering my two 12" subs. Recently when driving, the amp cut out at high volume. I turned the system off and let it cool down for 10 mins. When I turned the system back on, a heart beat sound immediately started coming from the subs, but no music bass was being made. It is a constant beat, even when the head unit is changing between inputs, or the volume is right down.. All the wiring is intact, I did a continuity check. When on, all the speaker outputs for the subs have earthed out.. Does anyone know where I can get a circuit diagram for it from?

Posted by Mick McCue on

  • Anonymous Oct 27, 2008

    I have the same problem, but I was wondering if it could be a blown fuse. If so, where are the fuses located on the amp?

×

Ad

1 Answer

Anonymous

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 113 Answers

Could be low current ,disconnect all power including ground for 20min N.B most amps will seem to be shorted at output but this is normal due to damping ratio.

Posted on Aug 09, 2007

  • Anonymous Aug 09, 2007

    hit me up for more info dude

×

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

When i turn my volume up to a certain point the power light on my amp will blink off and on and the subs will cut off...what could be some possible solutions? is the amp not suppose to be tuned up? it...

Sounds like you are showing too low of an impedance load to the amp. The E1200 is only stable as low as 2 ohms. If your subs are wired to show lower than a 2 ohm load then the amp will go into protection mode as the volume or gains are turned up
0helpful
1answer

Subs stop producing sound when stero volume is turned up

make sure your wiring is correct.. negative to negative positive to positive.
0helpful
1answer

Wire three 10" jl subs to jl e1200

what is the impedance of your woofers it will be a number with an Omega symbol. Looks like a horseshoe next to your woofer . Like this JL Audio 10W1v3 8ohm. Please, Please tell me you bought 8 ohm woofers JR?? Because if not, it ain't gunna happen.. If you did buy 8 ohm woofers than wire them in parrellel which means all the +'s together and all the -'s together giving you a final impedance of 2 ohms and your amp will think your a car audio GOD... But if not be ready to smell plastic burning where your amp used to be.... let me know i can walk you thru the wiring but let me know what you have. ok. mark
1helpful
3answers

Adjusting wattage on kenwood kac 9103 class D mono amp

That amplifier is 900W x 1 @ 2ohms.
If your subs are 4ohm SVC wired Parallel, resulting in a 2 ohm load, each sub will only see 1/2 of the rated power. (450W ea.)
Your gain (sensitivity) setting should be between 75% and 85% to max. You will be fine.
0helpful
1answer

Problem when hooking two 12 inch subs to one amp

the amp is no where near strong enough that sound you hear is called hard clipping and it will destroy your subs in minutes. depending on what model JL subs you have I can sell you a better amp.
0helpful
1answer

If my jl amp e1200 is on green, but no power is going to the sub

your audio wires from the head unit have been pinched or discontected or the head unit is not putting out a signal
0helpful
2answers

Will a jl amp e1200 kick a jl woofer 12w3v2 loud

yes a 1200 watt amp will do the trick.. the problem would be in the box the 12w3v2 sub needs a good size box and you should have one made for your car. and yes you will get the bass you want
0helpful
2answers

JL 300/2 v2 Power Light Blinks, No sound out of Sub. Works in friends Car HELP

Are you sure you don't have any shorted wiring or defective speakers?


0helpful
1answer

Only works for RADIO!!!

You're using the wrong control lead. There should be an amp control lead. You're using the power antenna lead.
Not finding what you are looking for?
Jl Audio E1200 Car Audio Amplifier Logo

647 views

Ask a Question

Usually answered in minutes!

Top Jl Audio Car Audio & Video Experts

Morne Olivier
Morne Olivier

Level 2 Expert

264 Answers

Mike

Level 3 Expert

4377 Answers

 Francisco Mauricio...
Francisco Mauricio...

Level 3 Expert

1551 Answers

Are you a Jl Audio Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...