Question about Mach Speed P4MBMS Motherboard

2 Answers

P4MBMS Motherboard Problem

Hi, I hope some can help me, I just installed a new Mach Speed MoBo and I can not get to the Bios, all I get is a black screen. I'm trying to install win Xp Pro and having no luck. I've switched mem. sticks, tried the on board video and checked the processor several times. Using an Intel P4 3.2 processor, (2) DDR 512 sticks and an Nvidia 5500 256MB card, 400 watt supply and a creative sound card (Audigy). Please Help! Tony

Posted by Anonymous on

  • Anonymous Jun 04, 2007

    24 Seven,
    Tried reseting jumper, no go. Also did an out of case MoBo start, still no go. Screen is still black, can not get to the Bios. What next? Tony

  • nonoks Mar 29, 2008

    the power is ok, but i cant get into the bios, all black scree.....



2 Answers


  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that got 5 achievements.


    An expert whose answer got voted for 20 times.


    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 125 Answers

Try to solve th eproblem by process of ellimination. On another PC or working mother board, chaeck the video card and memory modules. Unless you are sure that the memory and video card is OK, trying them all together with an untested motherboard will difficult. If you are sure that the Video and memory is OK and still the motherboard will not start, we can narrow down the problem to the mo bo, CPU and Power supply. If the board switches on (LED lights and CPU fan starts) we can rule out th epower supply and we are sure that the problem is in the motherboard / CPU. if this is the case, return the board for replacement. If it eill not power on ( no LED lights and the CPU fan will not start), then it might be that the power switch is not connected properly to the motherboard or the Power supply is defective.

Posted on Jun 06, 2007


Marty marty

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 883 Answers

Look for the reset jumper on the board and then reset it then try again

Posted on Jun 03, 2007

  • Marty marty Jun 05, 2007

    try another keyboard? and re-check power supply connection to MOBO.



Add Your Answer


Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

Acer AAHD3

Download the device drivers from the Acer WEB site. Make sure you select the model of your motherboard/laptop the drivers you that require that matches the Windows version that is installed on your laptop. Use this link to get to the Acer support: -

Jan 06, 2013 | Mach Speed Matrix P4MBMS Motherboard

1 Answer

I am looking for manual for p4mbms rev 1.0 motherboard

here's the link:

Nov 13, 2011 | Mach Speed Matrix P4MBMS Motherboard

1 Answer

Does a core duo processor fit into a P4MBMS

Hi, you can download a manual here:

CPU Support: Fully Support Intel LGA 775 Pentium 4 CPU Up to 3.6Ghz

There could be a bios issue when supporting a dual core cpu.
You should read the manual carefully before you continue.

Good luck.

Sep 15, 2011 | Mach Speed Matrix P4MBMS Motherboard

1 Answer

Hello, Trying to update this motherboard, now cpu celeron 3.20G 533ghz and would like to update to pentium 4 3.6G 800ghz that the user's manual says is doable. The problem is the motherboard will not...

Always remember that when you add new hardware like a processor or faster memory you have to clear the CMOS to reset the BIOS to defaults so it will recognize the new hardware. Sometimes you have to do this with hard drives particularly SATA drives.

On the motherboard, near the motherboard battery look for a small coloured plastic jumper. If your motherboard has one it will be marked as CLR_CMOS. Just move the jumper to the other position and press the on/off button. That will clear the CMOS.

If you don't have a CMOS jumper then remove the power cord from the back of the computer and take out the BIOS battery for half an hour or so. Replace the battery and plug in power. Turn the computer on and hopefully the the computer will boot and you will see a splash/post screen. If you do remember to set the correct date and time in the BIOS utility.

If your still not getting a post screen go back and check the processor is compatible with the motherboard. Check that the processor is locked in the socket properly and also check to make sure your system memory is seated properly.

Post back if need anymore advice.


Sep 29, 2009 | Mach Speed P4MBMS Motherboard

2 Answers

I have formatted my needs to download the compaq 7500 motherboard drivers

Nov 28, 2008 | Mach Speed P4MBMS Motherboard

3 Answers

Compaq 7500 motherboard drivers

Click the following link and type your Service tag no. in the box and search.

try here


Mar 22, 2008 | Mach Speed P4MBMS Motherboard

1 Answer

System Freeze

sc122870, try this first disconnect the hard drive cable and then try getting into bios, also try disconnecting both cables to the cdrw and to the hard drive and try to get into the bios. Sometimes if the pin assignments on the 2 drives are wrong, bios will freeze. If it does the same problem with the 2 drives unhooked then it might be your mobo.

Aug 19, 2006 | Mach Speed P4MBMS Motherboard

Not finding what you are looking for?
Mach Speed P4MBMS Motherboard Logo

188 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mach Speed Computers & Internet Experts

Lee Hodgson
Lee Hodgson

Level 3 Expert

4810 Answers

Muntejaya Ginting
Muntejaya Ginting

Level 3 Expert

10422 Answers


Level 3 Expert

85239 Answers

Are you a Mach Speed Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides