Eclipse Premium 34230 Car Audio Amplifier Logo

Related Topics:

Question about Eclipse Premium 34230 Car Audio Amplifier

1 Answer

Information on the Eclipse Premium 34230 Car Audio Amp

I recently just bought the Eclipse Premium 34230 Car Audio Amplifier from a friend but I can't find out online how much this amp is worth or Peak power.

Posted by Craig Struhs on

×

Ad

1 Answer

Anonymous

Specs: 370x2 [email protected] 4 ohm STEREO (the AMP DOES NOT BRIDGE) CLASS A/B (also do not run it 2 ohms unless you like smoke) 0.004% THD @ 4 ohm 105db S/N @ 4 ohm weighted 200 damping factor 11.85" (width) x 2.05" (height) x18.50" (length) 16lbs Worth somewhere is the 200.00 range if it is in really good condition

Posted on Jun 06, 2007

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

Model 34230 powers up then one second later green power light slowly fades off. What can it be?

if ur fuse is not blown it might bee to wires touchin of grounding out it will put it into protector mode
0helpful
1answer

How do i know what to turn the knobs to on my amps?

The gain should not be more then 3/4 and the other levels are all on your music preference and hearing taste...
1helpful
1answer

Volume button wont work only to lower volume works

Are you talking about the Amp working in lower volumes or the cd player? If it is the amp do you have the speakers bridged.
0helpful
1answer

Problem

you need to get a bigger ground wire and the cut in and out will stop the cutting in and out is the protection mode starting if it cant hold the thump a capacitor 2farad will hold the bass
hope this helped
0helpful
1answer

CD Playerr not working properly.

hi, have you tried to clean the lens of the unit?


chris
0helpful
1answer

Help my fuse is blow!

If the amp blows fuses only AFTER you send remote turn-on voltage to the amp, the amp probably has blown output transistors. To eliminate other possible causes, read through the following page.

Amp Troubleshooting

Let me know if you have any other questions.
0helpful
1answer

Car Radio

hello. you can find what your manual at this linkhttp://www.eclipse-web.com/us-index.html.!!! hope this help's you. let me know "GOOD LUCK"
0helpful
1answer

Amp turns on and off

loose power connections. check your terminals.
0helpful
1answer

Reset

You need to conform that you have a good ground and 12v on the remote & B+ terminals.

With your multimeter set to DC volts, the black meter lead on the ground terminal of the amp and the head unit on (so the amp will have remote voltage applied), touch the red lead alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts, you need to check the wiring feeding whichever line is too low.

.
0helpful
1answer

Eclipse 34230 no base

If the woofer isn't moving significantly, try the following settings:

gain at highest (most sensitive) setting

crossover at highest frequency

subsonic filter at the lowest frequency

If those do nothing and you have a dual voice coil woofer, you may have one coil reversed. If you disconnect one voice coil and the woofer moves significantly more, check the polarity of all speaker wire connections.

Here's a brochure for the amp:

http://cartoys.com/cartoy/pdfs/eclipse_amp_manual.pdf

 

You're correct. this amp cannot be bridged to produce more power. It's minimum safe load is 4 ohms per channel. It's essentially two bridged amps in one chassis.

Not finding what you are looking for?

677 views

Ask a Question

Usually answered in minutes!

Top Eclipse Car Audio & Video Experts

The Knight
The Knight

Level 3 Expert

76835 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8991 Answers

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1192 Answers

Are you an Eclipse Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...