Question about Alpine MRD-M301 Car Audio Amplifier

1 Answer

Correct settings I would like to find the correct settings for MRD-M301 to match 15' type R sub, to get the best sound from it.

Posted by shane base on

Ad

1 Answer

Anonymous

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 883 Answers

I am not familiar with your amp, but any amplifier performs best when the output stage effective resistance exactly matches the load resistance. So, read your 15" subs and find out number of ohms, then set the amp to that number. according to your amp's specs: if you have 2 ohm speakers, you can draw 350 watts from your amp. so purchase 2 ohm speakers

Posted on Jun 01, 2007

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

Mrd-m301

here is the link to your amp, should have all the specs and troubleshooting guide you need.

http://www.retrevo.com/support/Alpine-MRD-M301-Car-Amplifiers-manual/id/23261dj598/t/2/
0helpful
1answer

HOW MUCH

Hello diana_soto55,

The MRD-M301 is a discontinued model but originally sold for around $250-300. A more powerful current model is the MRP-M500 that sells for around $200 and under at discounted online stores.

Hope this helps.
0helpful
1answer

How much

http://www.shopping.com/xPO-Alpine-Alpine-MRD-M301-150W-x-1-Car-Amp-Mono-Subwoofer-Amps
0helpful
2answers

Setting for...

HI DUDE .. U CAN ONLY SINGLE PC OF JL SUB BY BRIDGE MODE ... COZ UR MTX AMP HAVE 300WATTS RMS ....
0helpful
2answers

Alpine MRD-M301

you could have a bad ground or the power wire could have a short i would start there
0helpful
2answers

Alpine MRD M301 just flashes

disconnect all inputs and outputs then restart it if problem persists you have a internal solder bridge youll need to have it repaired by authorized repair shop or buy a new amp at wholesale from this site:
www.godspeedaudioheaven.com
0helpful
1answer

Help!!!!

I would say any decent pair of 12" or 15" (single 4 ohm voice coil) subs that can handle at least 500W rms would work. The rest is going to be based on cost, type of box, type of music, etc.
0helpful
1answer

Powers up but no signal

Check your gain pots as well as audio pre outs on amp. sometimes pre outs will get loose and be unable to make a connection.
1helpful
3answers

Amp problem

Make sure the amplifier setting "disable" is off then turn off remote power and turn back on.
Not finding what you are looking for?
Alpine MRD-M301 Car Audio Amplifier Logo

Related Topics:

259 views

Ask a Question

Usually answered in minutes!

Top Alpine Car Audio & Video Experts

 Francisco Mauricio...
Francisco Mauricio...

Level 3 Expert

1551 Answers

The Knight
The Knight

Level 3 Expert

76823 Answers

Ivgsoft Ivgsoft

Level 2 Expert

157 Answers

Are you an Alpine Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...