Question about Gigabyte ATI RADEON X550 , (256 MB) PCI Express Graphic Card

1 Answer

No any video signal from the video card

I bought a new video card (GIGABYTE ATI RADEON X550). It's well plugged in and the cooler is working too but when plug the monitor in no signal message appears on the screen. I checked all the connections and everything is OK. My motherboard is nVidia nForce M2N4-SLI. Is it possible that this motherboard is not compatable with that video card?

Posted by Spas Kakarchev on

Ad

1 Answer

Chad Brooks

  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 11 Answers

When you power on your computer do you hear any system beeps from the PC speaker? When the computer is turned on it will run through a system check and one of the things it checks for is the presence of a working video card. One beep typically means everything checked out ok and your graphics card is working and it will continue to boot. If you are getting past that initial test I would next look at the monitor and see if it can handle the signal that is being sent to it. Are you not getting any of the boot up text display?

Posted on May 31, 2007

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

Windows 7 driver

For what? If it is for the graphics card you state in the title, then try the makers website. Or even the AMD website (AMD owns ATI)
0helpful
1answer

I need a driver coz my graphics are slow. i hav amd 5500 dual core, 2 gig ram, 64x2, on a gigabyte motherboard. dont no model number of the card.

Try downloading this from AMD (which now owns ATI):

http://support.amd.com/us/gpudownload/windows/Legacy/Pages/radeonaiw_vista32.aspx?type=2.4.1&product=2.4.1.3.20%E2%8C%A9=English

There's a download link near the bottom of the page. Hope that helps!
0helpful
1answer

After i install a driver for this device my computer loads but only to the point where i should see my desktop and it says no signal i go in safe mode i unninstall the ati drivers and restart and it works...

Hi!

Try to "clean" your PCI Express PC slot, it may be dusted - just disconnect your graphic card, then blow to PCI Ex slot and insert card back.
Also try to download latest drivers from here and install it after your PCI Ex de-dusted:
http://support.amd.com/us/gpudownload/windows/Legacy/Pages/radeonaiw_xp.aspx?type=2.4.1&product=2.4.1.3.13&lang=English
(for Windows XP)

and http://support.amd.com/us/gpudownload/windows/Legacy/Pages/radeonaiw_vista32.aspx?type=2.4.1&product=2.4.1.3.13&lang=English
(for Windows 7)

Good luck!
0helpful
2answers

Viewsonic vp912b lcd display will not work.no DVI

Yes you can but there should be an option in the monitor settings for DVI... Maybe if you go into safe mode and attempt adjusting settings for the ati for the dvi output, from what I hear that monitor is nice with the DVI option would be aa shame to lose that.
3helpful
2answers

Driver

I have a Sapphire X550 512 MB HM Pci-Express Card. But i lost my driver CD. So i want its driver for windows XP-SP2. So how can i find this driver.
0helpful
2answers

ATI 256MB Radeon X550 Graphics card

r u using dvi or vga? does the monitor support dvi?
1helpful
2answers

ATI Radeon

i suggest you to replace your graphic card..the memory from your card is damaged
Not finding what you are looking for?
Gigabyte ATI RADEON X550 , (256 MB) PCI Express Graphic Card Logo

Related Topics:

316 views

Ask a Question

Usually answered in minutes!

Top Gigabyte Computers & Internet Experts

Ekse

Level 3 Expert

13435 Answers

Chris May
Chris May

Level 2 Expert

153 Answers

Michael Thomas
Michael Thomas

Level 3 Expert

3056 Answers

Are you a Gigabyte Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...