Toshiba 43H70 43" Rear Projection Television Logo

Related Topics:

Question about Toshiba 43H70 43" Rear Projection Television

1 Answer

Toshiba 43h70 set will turn on then picture will fade out, menu works and audio is fine. Can someone help me?

Posted by Joel Heinz on

Ad

1 Answer

Anonymous

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 375 Answers

How old is this unit look on thr rear panel for mfg. date,possoble clod solder connections in deflection circuit and power supply if unit is more than 3yrs old.

Posted on Sep 12, 2007

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

I have sound, but no picture. It just blinks, with a faded back ground

Try to unplug set and or a box if used from power for a while, plug both back and see if a reboot that will happen helps or not.
1helpful
1answer

I can't find the settings in my toshiba 43VJ22P menu to adjust my convergance, please help!

you need to press must on the remote and whilst holding mute, pess menu on the left hand side of the tv. that will let you in to service mode. im sure if you press 7 in service mode it will let you in to the convergence menu.
0helpful
1answer

Toshiba 43H70 Picture Problem

Convergence amp ic bad
http://home.earthlink.net/~oleg.filippov/ConvergenceFix.htm
http://cmpalmer.blogspot.com/2006/11/fixing-my-own-tv-part-ii.html
Sony Convergence
http://www.techlore.com/blog/entry/19694/Sony-Convergence-Repair-My-Sony-TV-has-a-distorted-picture-/
http://www.techlore.com/article/19631/Sony-Convergence-Procedure/
0helpful
1answer

SONY KP51WS500 bought Feb. 2003 from Circut City

possible clod solder connection in the scan b+ voltages,contact sony and get them to check their dealer store locations in your area and have them send a message to the dealer describing your fault to them also.
0helpful
2answers

Wavy lines

This TV uses small voltage regulators. On each side of the regulators is the input voltage and the regulated output voltage on the other side. There are capacitors used for stabilization on the input and output. Change these capacitors.
0helpful
1answer

No audio after adjusting service mode settings

Check the audio menu to see what the factory defaults are. It could be that the audio processor is in a mode which turns off the internal speakers. Usually this is accessable from the customer menus. Most models have several choices for the audio processor and without checking I have no idea what the factory setting would be. I would not think that they would ship a unit that way but stranger things have happened. It certainly can't hurt to see where it is set. Certainly if you have sound through an external amp the sound circuits are working up to the built in amplifier. I suppose the internal amplifier could have a problem but it would be 1 in a million that it happened just as you were doing adjustments in the service mode. I think that it would have to be a configuration issue if it worked before. Good luck.
Not finding what you are looking for?

56 views

Ask a Question

Usually answered in minutes!

Top Toshiba Televison & Video Experts

The Knight
The Knight

Level 3 Expert

76851 Answers

Jaime Hernandez

Level 3 Expert

2351 Answers

Cindy Wells

Level 3 Expert

6556 Answers

Are you a Toshiba Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...