Question about Wharfedale PowerCube PC-10 Subwoofer

1 Answer

Subwoofer hi, i have a subwoofer and it always blows the time fuses after a few times of using the subbie! any help will be greatly appreciated thanks Theo

Posted by theo chrysikos on

  • theo chrysikos May 25, 2007

    i havent tried this! but i have 2 subbies with the settings the same and only one keeps doing the problem?

    thanks

×

Ad

1 Answer

Anonymous

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 883 Answers

Do the fuses blow no matter what volume you are sending?

Posted on May 25, 2007

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

Fuel injector fuse blows randomly/only when it is started. its a 94 bonneville and i wonder what could be the solution ?

CHECK FOR THE CONTINUITY OF THE WIRES FROM TERMINAL TO TERMINAL AND FROM TERMINAL TO THE GROUND.
0helpful
1answer

94 chev lumina van fuel pump fuse blows

check wiring to the fuel pump connector(from kick panel back),and inside the connector for melted plastic/shorted terminals.too much load from a bad fuel pump can heat the small connectors up alot.
0helpful
1answer

Polk sub DSW2000 fuse blows each time you switch it on.... How do i fix it or any circuit drawings or service help....Thanks for all replies

Sounds like your fuse is rated too low, try a heavier fuse or search Retrevo Manuals.com and you may find a manual.
0helpful
1answer

New subwoofer blows fuses

you have some wires touching causing it to ground.check wiring
0helpful
1answer

1996 Mitsubishi Eclipse GSX tail light/dash light/gauge light fuse keeps blowing. I've replaced the fuse a few times only with the 15 type fuse as stated on the fuse-box. It blows every time i hit a...

Hi,
Looks like the park light harness got a short circuit.
Check the wire harness leading to the tail light. One of the power wire( usually red wire ) is stripped off the rubber insulation and touches the metal body ground. Check also the tail light connection and bulbs base contact points..
When you found the wire insulate it by using any plastic electrical tape.
Thanks for asking FixYa!
1helpful
2answers
0helpful
1answer

Clicking noise from sub when in standby mode

Disconnect the input. Does it stop? If yes...

It sounds like it's sensing a signal at its turn-on threshold. Figure out why there's signal present when it shouldn't be there.

Exactly how is it connected to the source? LFE-only or full-range signal?
0helpful
1answer

Jandy Aqualink RSO301 keeps blowing fuse

Great discovery! You're welcome.

Could you please take a few and rate my assistance.

thanks...

Charlie
0helpful
1answer

PSW 10 Not working

Your 2A 250v slow-blow fuse is blown, located under the back pannel. Mine just did the same thing. Problem is the problem with my PSW10 goes beyond the fuse. I have contacted Polk tech support to help me trouble shoot.
0helpful
2answers

Six (6) blinks on the Timer/Standby led

6 blinks means lamp thermal fuse blowing, replace thermal fuse.

See here
Not finding what you are looking for?
Wharfedale PowerCube PC-10 Subwoofer Logo

Related Topics:

282 views

Ask a Question

Usually answered in minutes!

Top Wharfedale Audio Players & Recorders Experts

The Knight
The Knight

Level 3 Expert

76749 Answers

Joaquim Martins

Level 3 Expert

1128 Answers

 Grubhead
Grubhead

Level 3 Expert

5720 Answers

Are you a Wharfedale Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...