Question about Samson SX1200 Amplifier

1 Answer

My speakers stopped working

I have 250W Generic Subs with 2 tweeter and one trumpet in two separate cases i have a Samson SX1200 amp.. I was playing my music and after an hour in one of my subs stopped working i went to check it and i could only hear a dissorted music from one tweeter, after 15 min the second one did exactly the same. I have them both connected to the Samson SX1200 on separate channels in Stereo mode. As im new at this im trying to figure out what went wrong. Please Help!!!!

Posted by draco627 on

Ad

1 Answer

Rommel Cana

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 5,807 Answers

Heating of the power transistor

can be one of the causes.

you may have to take out the complimentary pairs to check.

The pair may take out the drivers and some components along with it.


These may take some time, (troubleshooting)

But have a tech to guide you, if you need to DIY.

Good luck, let us know what you find or needs further assistance.

Posted on Oct 05, 2012

  • draco627
    draco627 Oct 12, 2012

    Still trying to find a Tech... Thanks

×

Ad

3 Related Answers

petraman7

Scott Frye

  • 1175 Answers

SOURCE: One channel of my Samson SX 1800 does not work. It

That section of the amp overheated and failed .
You're looking at replacing 8 transistors and a couple components on the protect circuit

Posted on Oct 05, 2010

Ad
Ironfist109

Iron

  • 3018 Answers

SOURCE: one side of the amp

Either the channel on your radio is not working. Or the AV cord you are using is not working on one side (reverse the cord and plug it in the opposite you are using now. If it still only works on the one side your cord is good.) Or the final transistor for the channel on that amp might have blown. You could also have a cold soldier joint on or otherwise faulty jack plug. Let me know if this helps you find the issue.

Posted on Mar 07, 2011

dunnbiker

David Dunn

  • 8546 Answers

SOURCE: my samson servo 200 has

Register and download the manual for free at retrevo.com

http://www.retrevo.com/support/Samson-Servo-300-Amps-manual/id/19175dj683/t/2/

Bridged Mode maybe?

Posted on Apr 03, 2011

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Has 2 positives and negatives do I hook up to same terminals or seperate


The extra terminals might be there so you can bi-amp the speakers. (Drive the woofers and tweeters with separate amps). This also allows you to use only the woofers in the units as subs with different high frequency units; as in a home theatre system.



If you need further help, I’m available over the phone at https://www.6ya.com/expert/david_29ad5d1dd86564b0

May 25, 2016 | Digital Audio Audio Players & Recorders

1 Answer

Samson SX1200 - Protect light on. No blown output transistors.


Have you checked the power supply section? Also look out for any IC's in the amp stages. They can go causing that kind of fault.

Oct 11, 2014 | Samson SX1200 Amplifier

1 Answer

How do you connect the Samson sx1200 with other amps?


What are the other amps and what do you meed by connect. More information is needed if you want help.

Jun 16, 2014 | Samson SX1200 Amplifier

1 Answer

Mackie SRM 450, the main speaker has stopped working but the tweeter is OK, there is nothing coming from the speaker at all, no hiss, or clicks.


It could be 2 things:

*Blown Speaker or,
*Fried power amp output stage of woofer, since this speaker operates as a bi-amplified system it has separate amps for woofer/tweeter...

Aug 17, 2011 | Mackie SRM-450 System

1 Answer

One side of the amp works but the other side doesnt drow signal of a samson sx1200


Either the channel on your radio is not working. Or the AV cord you are using is not working on one side (reverse the cord and plug it in the opposite you are using now. If it still only works on the one side your cord is good.) Or the final transistor for the channel on that amp might have blown. You could also have a cold soldier joint on or otherwise faulty jack plug. Let me know if this helps you find the issue.

Mar 07, 2011 | Samson SX1200 Amplifier

1 Answer

Hi, i have been suggested first a Samson servo 600, then a sx1200 is there a difference between the 2? is one better than the other?


the servo series is geared more towards studio applications and/or installs, while the sx series are geared for live pa applications. the servo 600 is 300 watts per channel @ 4 ohm, and the sx1200 is 450 watts per channel at 4 ohms. the sx amp can also be bridged over to mono mode, where it puts out, i think, 1100 watts mono.

the only variable i havent been able to cover is sound quality, and im not seeing those listings in the specs on the samson website

Jan 12, 2011 | Samson SX1200 Amplifier

1 Answer

I Have a Gem Sound EVA3955 amp an TR-150 subs sub stop wroking


Yes and Yes. If bypassing that noise filter, has no effect your subs could have blown.

Jan 05, 2010 | Car Audio & Video

1 Answer

Right channel stop working


cheak your speaker wire and speaker at right channel.

Jan 17, 2008 | Samson SX1200 Amplifier

Not finding what you are looking for?
Samson SX1200 Amplifier Logo

107 people viewed this question

Ask a Question

Usually answered in minutes!

Top Samson Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5700 Answers

The Knight
The Knight

Level 3 Expert

76466 Answers

ray gallant

Level 3 Expert

71004 Answers

Are you a Samson Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...