Hifonics BX1500D Car Audio Amplifier Logo

Related Topics:

Question about Hifonics BX1500D Car Audio Amplifier

1 Answer

Hifonics 1605 Amp worked for 2 years and about a month ago she stopped working. I opened her up and about 10 of the voltage regulators are out I can solder fine. Everything comes on accept the power light, instead the protect light comes on. I need to know if anyone can provide the type of voltage regulators this amp uses. +5v, +12v, or adjustable. Or the schematics would be a tremendous help I could not find them anywhere online. Also is the power supply out I am not sure. Thanks So much

Posted by Chris Johnson on

Ad

1 Answer

Anonymous

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Have you checked Radio Shack? they have a lot of cicuit board stuff for soldering

Posted on May 18, 2007

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

Why rear windows on 2001 chevy tracker won't work ?

Would seem your into the inner doors & have a partial
grasp on things

Now you fix all door windows one shot

#1 Test all switches,ohm meter unplugged or volt meter with power
#2 Test all motors with battery voltage direct -- DC motor will run either direction-- can't hook up wrong
#3 Window Regulators -you know about them (Unless they are broken-you said they are tight)
#4 Do you have good ground side wiring & battery voltage at all
switches & motors
#5 Last resort--unhook the cables & work on freeing up the
glass & window guides etc then you will have found out if the
regulators are the issue
0helpful
2answers

99 aurora, change alt 2 months ago now its over charging 16.7

That's fine this happens i have gotten from 30 minutes to a week out of rebuilt alternators up to 10 years 2 months ago you should have warranty on it contact supplier.
0helpful
1answer

Hi, I have a 1994 dodge ram 2500 cummins turbo, on my way home my speedometer and tachometer stopped working and my volt meter was reading low 10 volts or so with my lights on, two months ago my cruse...

alternator drive belt broken
alternator not charging , voltage regulator failure , battery terminals loose , ground wire loose
have the battery load tested
0helpful
1answer

Subwoofer popping noise

i had an amp do that a few years ago i did everything it turned out that it was the cdplayer. then agin myfriend had the problem and it was his altonator he had to get a ground loop isolator they are cheap
0helpful
1answer

HiFonics txi4008 not working, partially lighting up

Sounds like your amp has some power supply compents shorted out. Maybe some of the power mosfets are shorted and your only getting a little bit of power. That why only the H is lighting and as far as the green light, it don't take much for it to turn on. If it was major it would go into protect mode but it is'nt. I repair amps for a living and I'm the cheapest you'll find. But if you know about electronics and think you can take a crack at it, check it out. Becareful you could do more damage. Let me know if your interested. [email protected]

Btw, I’m available to help over the phone in case u need at https://www.6ya.com/expert/mark_b53a7494531bf96d

0helpful
1answer

I am ordering 2 pioneer TSW307D4 or D2 is a 2400 watts amp good?

ok theres a amp called slugger they came out about 7-10 years ago its small but very very powerfull i was picking up my 2 15 inch l7 kickers i drove from my house to vegas with no problem about 4 and a half hrs and didnt turn off ,on the other hand i had my fosgate wich i love t1000 wich turned off on me a couple times
0helpful
1answer

Problem with my amp

then use it as a paperweight...seriously, you prolly blew the jensen speaker, you prolly damaged the amp
0helpful
1answer

Hifonics 1605d stopped working

the red light blinking because your amplifaier its dead look for the alimentation cabel end replace the calibration protector
0helpful
1answer

My amp turns on then off while it slowly blows the fuse out

If I were a guessing man, I'd guess that you had your amp hooked up in a bridged configuration. And also that you connected your two speakers in parallel (plus to plus and minus to minus). And if I were to further guess, I'd guess that you have a blown amp now because of what I mentioned above. Sounds like you need to spend some quality time with your favorite electronic repair shop. Good luck.
Not finding what you are looking for?

123 views

Ask a Question

Usually answered in minutes!

Top Hifonics Car Audio & Video Experts

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1192 Answers

Jaime Hernandez

Level 3 Expert

2343 Answers

Marvin
Marvin

Level 3 Expert

85240 Answers

Are you a Hifonics Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...