Samsung Maxima Zoom 70GL 35mm Point and Shoot Camera Logo

Related Topics:

Question about Samsung Maxima Zoom 70GL 35mm Point and Shoot Camera

Open Question

Samsung maxima 70GL

When I try to load a new roll of film I get "E" flashing on the little screen and then it shuts off. I have used this camera hundreds of times with no problem, but now can't get it to do a thing.

Posted by patty laughlin on

Ad

2 Related Answers

Anonymous

  • 188 Answers

SOURCE: No picture

it seems that the flex ribbion cable from the camera body to the lense assembly is damaged. A good repairer can replace it.

Posted on Oct 28, 2006

Ad

Anonymous

  • 3 Answers

SOURCE: samsung S630 junk

I am Judy Malone in Tenn and I had my camera all in box and ready to mail back to place listed on camera box. I had worked on camera for last few days and to no avail. I got the notice via email today and the usual steps that I've read before.
To take batteries out, insert again. And to hold the ON button to keep camera powered. Then press Center button OK and press RIGHT 3 times to Setup2...
Well, I could not get my camera to co-operate past the Press Right 3 times to setup 2. Only the usual screen with a few of the icons showing my battery had power. It would not do anything past this.
Well, I got mad...(smile) and figured something had to be wrong as it kept showing a 32 for picts and I knew I had taken 414 at least on my Lexar 512 MB (SD).
I thought something must not be aleigned properly..some pins inside or somthing, so I GENTLE tapped the camera against my kitchen table... First one side, then the other..and GUESS WHAT. My camera came to life and has been working fine since. I HOPE this is a permanent fix...as I love the camera and have said so.
So, for what it's worth...try this if everything else seems to fail...but please do it gently. And start from the beginning.
Take batteries out, then reinsert...and GOOD LUCK.
I will post again...and let you know if this continues to work.
I am amazed.
judy in Tenn

Posted on Feb 19, 2008

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

Maxima zoom 77I camera . Loading new film & the view finder display is flashing an E. And a pic of the film roll. Trying to load new film. Also the zoom mechanism won't work, nor will it take a pic. ?

With all the problems this camera has and the cheap price of cameras its time to consider an upgrade to a new camera. It will cost more to repair than to replace it.
Ive just seen several like this on ebay under $10 or you could join the 21st century and get a digital camera.
Jul 31, 2018 • Photography
0helpful
1answer

Fuji Instax Mini 25 can't do anything!

hi,

most likely it's the motherboard spoil. bring it to nearest repair center to get it fix. mini 25 repair cost $55 to $65 SGD.

RT
0helpful
1answer

I may have loaded film roll that has already been taken?

Usually when you finish exposing a roll of film, you rewind it until you are sure it is all wound into the cassette. There is a change in the sound as the end of the roll leaves the camera. An exposed roll would have no film sticking out of the cassette. A new unexposed roll will have a bit of film sticking out of the cassette to pull across the ack to the take up roll.
0helpful
1answer

Film does not load automatically as before camera has flashing 3 on display

I think it aint a 3 but a E as if an error :) try feeding the film deeper.
0helpful
1answer
0helpful
1answer

Camera goes into Shut Down Mode & Flashes the Letter H

Hey sonax,
This H error message means either the film is loaded incorrectly, or there is an internal malfunction in the camera. To determine if the film is loaded incorrectly you should take the film and the batteries out of the camera then reinstall the batteries and try taking a picture without film in the camera. If the camera allows it then the film was loaded incorrectly and I would refer to the camera manual for directions on how to load the film correctly. If the H error message persists then there is most likely an internal malfunction and I would have the camera looked at by an authorized service technician. I hope this helps!

Sincerely,
Allan
Go Ahead. Use Us.

0helpful
1answer

Fuji 35mm Camera (Model DL-400)

Dawn

remove the battery and check that it is good. replace battery and open back door, close the door and it should run the motor / transport. if so, load film up to the drive sprocket being sure film will catch on the sprocket.
or move the latch holding back cover, and open the door fully. check the pressure plate on the door, gently pull the plate up a little to increase pressure on the film. bring the holding lever out toward the latch and close the door to lock the lever back to position.
0helpful
3answers

Pentax

i think it means the film hasn't loaded properly. I had this and opened up the back and the film hadn't wound so it wasn't exposed. Anyway i just wound the film around a bit and shut the back and it turned on like normal. hope this helps. 
0helpful
1answer

Camera not working-please help

No promises but if you take a roll of film that is already light fogged etc. and load it into the camera. Let it wind as normal. Now we need to work quickly: Press the rewind button. While it is winding OPEN THE BACK. It won't rewind very long because very little film is out of the cartridge so be ready. This will fogged a bit of the film but it does seem to clear the error. You can still shoot the roll if you just skip the first few shots.
0helpful
1answer

No picture

it seems that the flex ribbion cable from the camera body to the lense assembly is damaged. A good repairer can replace it.
Not finding what you are looking for?

219 views

Ask a Question

Usually answered in minutes!

Top Samsung Cameras Experts

Cindy Wells

Level 3 Expert

6450 Answers

David Shaub

Level 3 Expert

2991 Answers

Paul Bade

Level 3 Expert

1699 Answers

Are you a Samsung Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...