Sony Cyber-shot DSC-W30 Digital Camera Logo

Related Topics:

Tamer Hossien Posted on Apr 06, 2007
Answered by a Fixya Expert

Trustworthy Expert Solutions

At Fixya.com, our trusted experts are meticulously vetted and possess extensive experience in their respective fields. Backed by a community of knowledgeable professionals, our platform ensures that the solutions provided are thoroughly researched and validated.

View Our Top Experts

Lens go in and out several times, then I got message to turn off

I have Sony DSC-W30 Camera, my lens was stuck-out, this was causing the message "Turn the power off then on again". After some trials, and after using your solution, I have succeeded in geting the lens back to its place. But ... After doing that, when I turn the camera on, the lens go in and out rapidly for 3 times, then I got the same message again "turn the power off then on again" !! is there any solution? I am seeking for your help.

  • 4 more comments 
  • Tamer Hossien Apr 06, 2007

    I have figured out the problem, I think the lens extension mechanism does not complete, when I "help" the mechanism by rotating the lens in the extendion direction, it goes steady, and the camera works but without zooming :(
    Any help??!!

  • sethtiger Nov 01, 2007

    Same problem at first the lens just seemed to be stuck but with some effort come out.  Now it will not come out or go back in and camera keeps saying turn off and on.  Can you reset the camera or can you have it repaired?  Is it worth it to have repaired?

  • BBRUINS Feb 25, 2008

    i've tried to clean my lens and i tried to reset but nothing worked, it is saying the whole time access and then it says Turn power off and on again. WHAT CAN I DO? PLEASE can some one help me

  • Slugger69 Mar 27, 2008

    why does the lens goes in and out a couple times before it closes, thanks Don

  • Loose yeah Feb 18, 2009

    I tried all of the above on my W30 and none of them tricks works.And now the lens is stuck in the camera and won't come out.

  • basem74 Mar 10, 2009

    Lens go in and out several times, then I got message to turn off" problem, and notify you when a new solution is offered.

×

6 Answers

Anonymous

Level 1:

An expert who has achieved level 1.

  • Contributor 1 Answer
  • Posted on Jan 19, 2009
Anonymous
Contributor
Level 1:

An expert who has achieved level 1.

Joined: Jan 19, 2009
Answers
1
Questions
0
Helped
4821
Points
3

I just rotated the lens and it started to work again. If I didn't see your post I would have been lost. Camera is working perfectly fine again. Thanks guys. Hope my info helps. I turned it very slightly and powered it on and off and it started to operate normally. I am guessing from just tossing it around in my pocket it caused the lens to get screwed up.

Anonymous

Level 1:

An expert who has achieved level 1.

Problem Solver:

An expert who has answered 5 questions.

  • Contributor 1 Answer
  • Posted on Oct 02, 2007
Anonymous
Contributor
Level 1:

An expert who has achieved level 1.

Problem Solver:

An expert who has answered 5 questions.

Joined: Dec 12, 2005
Answers
1
Questions
2
Helped
6073
Points
2

It is strongly forbidden to apply any force on the lens unit. All the shaking and banding can do more damage than the original problem is.

Ad

Anonymous

Level 1:

An expert who has achieved level 1.

  • Contributor 1 Answer
  • Posted on Aug 27, 2007
Anonymous
Contributor
Level 1:

An expert who has achieved level 1.

Joined: Aug 27, 2007
Answers
1
Questions
0
Helped
4821
Points
2

I have faced same message "Turn the power off then on again" today.I tried to on-off several times.finally I discovered that lens is so dirty.when I cleaned the lens it come alive :)

Anonymous

Level 1:

An expert who has achieved level 1.

  • Contributor 1 Answer
  • Posted on Jan 29, 2009
Anonymous
Contributor
Level 1:

An expert who has achieved level 1.

Joined: Jan 29, 2009
Answers
1
Questions
0
Helped
4821
Points
1

Thanks for all the solutions mentioned here, I tried the oil on the lens trick - no luck! Took the advice of hitting the camera hard in several places (which took a bit of doing as I am not prone to violence) BAM WHOOOSH and By Crickey the bloody thing came to life, Thank you!

A

Anonymous

I've been struggling with the same problem for like an hour today, and now i SOLVED it! i simply resetted my camera. then it works. it WORKS like nothing happened. lens are fine now.

Anonymous

Level 2:

An expert who has achieved level 2 by getting 100 points

MVP:

An expert that got 5 achievements.

Sergeant:

An expert that has over 500 points.

Champion:

An expert who has answered 200 questions.

  • Expert 326 Answers
  • Posted on Apr 08, 2007
Anonymous
Expert
Level 2:

An expert who has achieved level 2 by getting 100 points

MVP:

An expert that got 5 achievements.

Sergeant:

An expert that has over 500 points.

Champion:

An expert who has answered 200 questions.

Joined: Dec 20, 2006
Answers
326
Questions
1
Helped
150178
Points
632

Hello, the optical unit of the camera is a very sensitive unit. In order to overcome this problem you should replace the zoom motor unit pn:267364801 or lens unit (inclusive the zoom motor unit) pn:178836311 If you need more info please advice.

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3helpful
1answer

Sony DSC W30 digital camera, lens unit problem

Hi!
If you're sure you didn't damage the lens flat cable which connect to the motherboard, the focus of the lens unit you bought on ebay doesn't work. You can simply replace the back part (with focus) of the new lens unit with your old one. It requires soldering.

Tom
5helpful
1answer

Camera not switching on

I believe there is a lens error, usually that message appears when the lens are stuck or not working.
Turn the camera ON by pressing the "play" button (to see images only) and if the camera turns ON with no problem, then the problem lies on the lens.
you can send the camera for repair or buy a new lens set from ebay, they go for around 30 dollars, but you have to be familiarized with cameras and very careful in order to install the new lens.

hope this helps.
4helpful
1answer

Camera lens keeps opening and closing and message says " turn the power off and on again".

I followed the other people's suggestions with the compressed air and shaking the camera. I also, turned the lens a little to the left and the camera works perfectly. Thanks, again for everyones help.
0helpful
1answer

I have a Sony cyber-shot dsc-w30. When I turn it on the lens goes in and out, I get a message on the screen saying "access" then I get a message saying "turn power off and on again".

Sony maks good products and stand behind they product, but they do have a problem with the batteries , change the battery and i bet u will not have that problem
3helpful
2answers

I have a Sony Cybershot DSC-W30 camera. This morning, I took a picture of my daughter, and turned the camera off. Right when I was turning it off, she asked me if she could see the picture, so I quickly...

MY LENS IS ALSO STUCK OUT. I pressed on the lens by accident while it was on. Now it won't turn on and the lens is stuck out. I tried twisting it left as recommended by aplynn09 but didn't work. SOMEONE PLEASE HELP!!!
0helpful
1answer

Sony cyber-shot dsc-w30 digicam problem

The lens due to some problems is not intialising ...... most commonly it may be dust particles getting stuck in the lens barrel ...... or the barrel itself is damaged ...... get it repaired from a repairman ..... as opening a lens is a difficult procedure ...and you may end up messing up the whole thing ......
5helpful
2answers

Sony Cyber-Shot DSC-W30. The lens is in a "stuck" position

You have a bad lens, it prob. also says turn off and on again.
0helpful
3answers

Lens stuck

Knocking the camera sounds like it works but may create another problem. I have had this problem with p-100 , p-200 and now the w50, I have found a small drop, of wd40 placed on both sides ,two opposing sides,of the lens ring where it extends from the body will work also. Don't spray, its a bit too hard to control amount deposited. Use a toothpick or a stick to dip and then drop the oil.
0helpful
2answers

Getting access

Was your unit dropped, or maybe left with the lens protruding? Seems you have a problem with the lens assy(stucked), during start-up, it will initialize to check if all systems go, if not then it will display turn off and on again. thanks
Not finding what you are looking for?

4,831 views

Ask a Question

Usually answered in minutes!

Top Sony Cameras Experts

ZJ Limited
ZJ Limited

Level 3 Expert

17989 Answers

Cindy Wells

Level 3 Expert

6688 Answers

Brad Brown

Level 3 Expert

19187 Answers

Are you a Sony Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...