Sampo PME-42S6 42 in. HD-Ready Plasma Television Logo

Question about Sampo PME-42S6 42 in. HD-Ready Plasma Television

1 Answer

"No Signal" floating notice on Blue Screen - No other picture

I purchased the Sampo 42" plasma in 2002. Up until a month ago it worked fine. Then one day I was no longer able to get a picture or audio on the televison. However, I did have the cable channel audio coming through my amplifier. Since I get the blue screen with the "No Signal" notice, the plasma screen is working. I also tried switching out the tuners and checking all the connections into the television on a portable tv -- they worked on the portable. But I till do not have a signal on the Sampo. What is causing this problem, and will it be expensive to fix?

Posted by Karen Raines on

  • 4 more comments 
  • dahitmanz38 Nov 27, 2007

    I've noticed this problem from a couple different readers and I am experiencing the same issue. Basically, the TV will power on, but no picture just a blank/black screen. The power lights on the TV work. Yellow light for the TV being off and green when you turn it on. Another issue along this line is that I have to manually turn the power off from the button on the back. I don't believe it's a power issue but could be your "digital board" problem. Are there any recommendations from the experts here on the best approach to getting this repaired? Thanks in advance!

  • Anonymous Jan 04, 2008

    my screen flashes


    ill have a  pic for a few mins then it will come and go

  • Matt Voss Feb 28, 2008

    I also do not receive any signal on my SAMPO MPME-50X6(S) and wonder if it is worth to fix my TV or not

  • Matt Voss Feb 28, 2008

    I have a SAMPO MPME-50X6(S) plasma TV that I purchased on 2004. Recently the screen turn black and I do not receive any signal includint the blue "NO SIGNAL" on my TV.

  • mranderson38 Jul 10, 2008

    I am no longer getting any power on my Sampo 42 inch TV. My technician, ere in Toronto, Canada. advised that the power supply module in the tv is broken. He is unable to get this power supply here in Canada. Does anyone know where I can order this power supply from?

  • patcoci Nov 05, 2008

    yesterday we started to get no signal floating & no picture. what can we do? is it something we touched on the remote?

×

Ad

1 Answer

Anonymous

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,284 Answers

If all connections and the tuner have the same issue, you either have a power supply issue or a bad digital board.

Posted on Mar 29, 2007

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

Powers up but no picture don't have remote is there a way to navigate menu to check input selection

hook up a vcr and put in a tape and make sure there is a signal on the yellow video out jack.
use that as a signal to put a video signal into the 42 inch t.v.
0helpful
1answer

Distorted picture on Sampo 42" monitor

This can occur due to many reasons...the simplest of those is...
Damaged monitor signal cable...results in improper signal transmission
Also check if ths is a problem with the monitor or VGA card...Just connect it to another computer...If it works then its VGA card problem otherwise its a monitor problem.If you are good in electronics then the problem is
1)You have the typical convergence failure of the convergence correction IC's which need to be replaced

2)Cpacitors on the CRT are damaged and need to be replaced..

If you are not familiar with electronics pls dont attempt a repair as it is a high voltage device and the risk of electric shock wil be high.Just drop into a service center if this is the case
1helpful
1answer
0helpful
1answer

I have a LG Plasma Flat screen TV. I purchased it

With seeing the picture it will be hard fro me to tell what..I am going to guess according to the information you've provided.
It could a buffer or a signal board(s). This TV is only 4 Months old I would call LG and file a warranty claim. LG (800) 243-0000

Best of luck
N Sabre
1helpful
1answer

Hello experts I recently came into ownership of a Sampo pme42s6. it powers up fine and has audio, but none of the video inputs are allowing a picture. I plugged in an S-video and Analog VHS signal,...

i don't know how much the new one cost but it is fixable. Check the components around flyback transformer , check bad connections, check the flyback it self. It ask some expertise . If you can't ask help for your neighbor technician if he is good you will pay little money. but not less than $80
0helpful
2answers

Thompson Wysius 42

Don't know the answer to your problem but I found a lot of useful information here:

http://www.forums.hcsd.com.au/Blah.pl?m-1220089160/
0helpful
2answers

Snow

There is a fault in the main processor that is causing noise. The set will have to be serviced. The tech will probably try the main video processing board to start.

Jerry G.
0helpful
1answer
0helpful
1answer

Blue shading problem

2 months old? I'd call the dealer..it's under warentee. You have a problem that will not get better.
0helpful
1answer

Screen blanks out

A digitalizing picture is most likly a bad connection on a screen driver cable or the driver itself is intermittant or the power supply has an intermittant filter on the substain B+ line. hope this hellps.
Not finding what you are looking for?

390 views

Ask a Question

Usually answered in minutes!

Top Sampo Televison & Video Experts

The Knight
The Knight

Level 3 Expert

76849 Answers

Marvin
Marvin

Level 3 Expert

85240 Answers

ray gallant

Level 3 Expert

74163 Answers

Are you a Sampo Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...