Toshiba 43H70 43" Rear Projection Television Logo

Question about Toshiba 43H70 43" Rear Projection Television

1 Answer

Menu, volume and channel emblems will not show up

Recently while watching tv there was a loud pop and the screen went black and then turned back on. After this happend I noticed my menu would not pop up I couldnt see what channel I was on and the volume meter has dissapeared. The popping sound has happend 3 times seperatly and has not done it since.I want to get hd cable but I was told I have to change the tv from 480 to 1080 in the menu screen, which poses a problem since I cannot see it.The tv is a rear projection and hd capable. Ive had it for about 4 years. Any help would be greatly appreciated.

Posted by Mike Murtaugh on

Ad

1 Answer

Henry Thomas

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,074 Answers

Take your set to a tech the tv system control circuit might have damage, that circuit controls OSD,channel memory. it is an ic that controls that circuit along with other components.good luck.

Posted on Mar 26, 2007

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

The tv was giving as a gift in 2012. So I believe that I put the right model in. I was watching the tv and went to change the channel, when I noticed that the box with the channel number looked differ

Your symptoms point to the main board [the board with all the input connections], no simple fix, you must replace the board. Less likely the keypad is bad, just unplug the keypad and see if channel display stops popping up.
0helpful
1answer

Maxent tv repair

time to replace the Tv unfortunately
0helpful
1answer

Blue screen need to know how to scan channels to get input to come back up

Will need to know what tv you have, but you are right it is probably your input button. if you pushed it on your remote then there should be an input button on remote. otherwise you will have to go into the tv menu and setup it up there.
if you respond with model and make of tv, might get more info.
1helpful
1answer

Alba tv screen goes black after 5 seconds of switching it on. The sound remains however. The tv is approx 18months old.

This happened to me its probably too late for you but might help others. what i did to fix this is, I put the tv onto a radio channel (with no picture) and about 10 mins later i turned the volume down and realised the screen was still on as the volume bar showed up. so i guessed it the problem was to do with light so i went on the menu and went into features and turned the backlight onto minimum and the tv has been fine since. hope this helps!
0helpful
1answer

Was watching TV and the picture just went black (still had sound)

eithor the flyback just craped out or the tube went
try turning up the flyback failing that call a service tech and ask for a quote
quote cose 30-50 bucks
atleast you will know forsurre if it's worth fixing
0helpful
2answers

Vizio GV47L screen went black and is now unresponsive

Could be the power supply gone bad.
No easy solution I'm afraid.
1helpful
1answer

32 inch tv goes from normal sound during program to extreme loud

May be a defect but, if you notice the sound changes with different channels or movies or HD or Standard, look for a volume limiter control button in the menu setup under audio control. Sometimes the menu has a control that you can turn on to limit different volume levels during the shows origination.
0helpful
1answer

Tv screen has turned blue and I can't watch tv

i think by accident you have changed the input when you went to change the volume. look for a button labeled " input" or "video" select on the remote and scroll through the various choices. you should get your picture back.
0helpful
1answer

Pioneer SD-582HD5 - screen went black, no sound, Poor remote feed

The blue tube might be leaking coolant in the high voltage area, that is the cause of the POP. This repair might not be a DIY because of the lethal high voltage surrounding the CRTs tubes.
The slow response from the remote could be because the coolant has affected the main board where the IR signal are going to the remote sensor.
Let me know if you require further assistance.
0helpful
1answer

Whistle noise? POP? Black out

sounds like the lamp has shattered. check the lamp
Not finding what you are looking for?

80 views

Ask a Question

Usually answered in minutes!

Top Toshiba Televison & Video Experts

The Knight
The Knight

Level 3 Expert

76835 Answers

Cindy Wells

Level 3 Expert

6447 Answers

Ekse

Level 3 Expert

13435 Answers

Are you a Toshiba Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...