Question about Sony XM-2200GTX Car Audio Amplifier

1 Answer

Help!!!! Hi, I have recently connected sounds throughout my car. When my friend put in my Headunit, it blew me fuse in the car. My amp and sub were working fine. When we went to check the fuse and fix the problem we found that my friend had hooked my Earth behind the head unit to a wire. So we cut that wire and grounded it and then my lights were working fine. THen we noticed that my amp wasnt working. Everytime that the headunit turns on the light oin the amp goes from the green into protection mode. I was wonderiung what has happened. We tired my friends amp with the same set up and it worked fine.

Posted by Casey Bennett on

Ad

1 Answer

Anonymous

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 13 Answers

Check your ground wire! Relocate it to another place in the car and try to get a heavier ground wire aswell.

Posted on Aug 15, 2007

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

Why does the fuse blow Instantly?

Link for the service manual: http://elektrotanya.com/pioneer_vsx-305_405.pdf/download.html On page 50 of the manual (36 of the pdf) it says for the "Sub woofer pre-out jack (Not available on the VSX-305 model) If you want to boost the low frequencies, connect to a subwoofer power amplifier" Your model will not drive a sub-woofer with out another amp. His sub may be a powered sub?
0helpful
1answer

I just recently bought a brand new MTX magnum amp and dual 10" enclosed subs deal off of amazon. They arrived today, and with the help of a friend who is good with car audio systems, we set the whole

the best thing to do is get in touch with amazon,and see what they can do about it,if you try to fix the problem yourself it will invalidate the garantee!
0helpful
1answer

Visonik v4000xd car amp

there shouldnt be any fuses if it powers on check your rcas from the headunit and the amp if thats ok then chek the levle on the amp and the headunit there should be a sub or preamp setting to set the level
0helpful
1answer

I have a Pioneer 5400t amp hooked up to a 10" 400w sub of unknown brand. The system was working perfectly for about a week, then I noticed the sub wasnt working. I blew both 30a fuses on the amp. I...

Your best bet is to buy a cap. A capacitor is an external battery booster like device. It boost power to amp. The thicker the wire the better. Power and ground. Shorter thicker ground wire the better. Make sure it is not on a painted surface. Scrape down to metal surface!!!!
0helpful
1answer

Amp comes on but no sound to the subs and i think i checed all wires and even got new rcas

Hi mate

I know loads of ppl who have had the same problem.
Are you getting an output from ur headunit RCA's? Sometimes you need to turn the sub RCA's on via ur headunit. I would make sure im getting an output from the headunit first.
0helpful
1answer

Subs and amp dont work

His amp probably blew your fuse. Check that you have 12V at the power connections. If you don't, then find the fuse in your positive wiring to the amp. If you do have 12V to the amp, check your remote power up also has 12V between that and the negative line when your head unit is on. If it doesn't, then it's probably an internal fuse in your remote switch on line inside your head unit caused by a fault in your friends amp. This is normally accessible at the back of the head unit.
0helpful
1answer

I put the head unit in & blew the fuse. I need to know which fuse to change :)

if you take out the fuses one by one you'll be able to see if the fuse is blown. if there is no wire in between connecting the two pins that plug into the panel. fuse is blown.
0helpful
1answer

Amp works but no sound from sub

Some older Pioneer radios require you to connect the Subwoofer RCA to the rear output on the back of the radio and then you have to turn on the subwoofer in the menu on the radio. What model Pioneer radio is it? Also, make sure that the RCA plugged into the amp is on the input side, not the output side.
0helpful
1answer

Subs will go off the wall with bass, but not in tune with music.

hi, first disconnect the rca input, then switch on headunit and if the amp produces a constant bass thump it then means it has an internal fault. if the amp idles quietly then replace the rca cable, or try connecting the headunit lineout feed directly to the bass amp, in this way you cud find out if your fault is coming from the headunit or the equaliser. cheers
Not finding what you are looking for?
Sony XM-2200GTX Car Audio Amplifier Logo

Related Topics:

95 views

Ask a Question

Usually answered in minutes!

Top Sony Car Audio & Video Experts

 Francisco Mauricio...
Francisco Mauricio...

Level 3 Expert

1551 Answers

xxxxxx xxx

Level 3 Expert

5023 Answers

The Knight
The Knight

Level 3 Expert

76698 Answers

Are you a Sony Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...