Televison & Video Logo

Related Topics:

Question about Syntax Olevia 50" Rear Projection HDTV-Ready Television

1 Answer

I need to know where I can buy a replacement bulb for my olevia syntax LCT50hv tv

Posted by rickstaibii on

  • bcasford May 11, 2010

    how did you know you needed a bulb? was your power light on the front of the TV blinking? how did you know it wasnt a board like the inverter board? thanks..bcasford

×

Ad

1 Answer

Anonymous

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer
Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

My blue powerlight isnt working on my olevia tv it is 3years ol what could it be

If the tv is infact turning on eventhough the power light isnt, its the bulb for the powerlight itself
0helpful
1answer

LCT50HV black screen and blinking red/green lights

Replace your Bulb which is located on the side panel. U can do it yourself and save some money.
0helpful
2answers

TV LAMP

http://www.tvlampsforless.com/Olevia_LCT50HV_bulb_p/lct50hv.htm
0helpful
1answer

Olevia 50" rear projection problem

http://www.tvlampsforless.com/Olevia_LCT50HV_bulb_p/lct50hv.htm
0helpful
1answer

Olevia lct50hv

check your ballsit power supply, this is the part the light bulb goes into. Check light engine
0helpful
5answers

Need a replacement lamp for LCT50HV-tv syntax

Not looking good for your problem. I have not been able to find a supplier on the web or ebay. You might have to call the company and order it from them, but I bet it won't be cheap.

here is there contact page:
http://www.syntaxbrillian.com/company/locations.html

Product Support
Olevia Product Support
Call Toll Free: 1.866.9OLEVIA
or 1.866.965.3842

If this TV is less than 1 year old, you should still have the manufacturer warranty.

You should read the customer review at amazon:
http://tinyurl.com/34owj9
0helpful
1answer

Lamp

http://www.tvlampsforless.com/Olevia_LCT50HV_bulb_p/lct50hv.htm
0helpful
4answers

POWER PROBLEM

LCD tv goes black and has to be restarted
0helpful
2answers

Syntax lcos

The lamp is dead. Call syntax/olevia and pay em a 100 bucks for a new one.
Not finding what you are looking for?

Open Questions:

0answers

Whirlpool Side by Side American style Fridge Freezer too hot and too cold! I have model S20D FSS10-A/D Service number 8586 161 15000 Side By side FF - and after replacing many components on the rear board 13 years ago it has been running well. However.... with a new fault I am hoping that the symptoms may allow someone to point me in the right direction. Not having a circuit diagram has been a hindrance. Over last few years the front panel inside in the fridge in my model has been developing a display fault - it started with the LED display winking out briefly about twice a second. The mark/space of time for the 'winking out' changed slowly to 50% on 50% off twice a second to eventually become just flashing on briefly twice a second and finally off all the time. However, the default settings/functioning of the FF has been working fine so didn't need to use the panel. However, can't read any fault codes that might be there I don't think that the buttons are doing anything on the panel. It has 15v supply but I don't know what supply voltage from the rear PCB should be. Then... A few weeks ago the house RCD tripped once and the fridge bulb had blown ********* stain on bulb interior and Relay RL3 was chattering randomly - I took the board out and noticed a fried circuit track where it looped thinly either side of component hole that was unused. I soldered in a bridge over the gap. Restarted the FF. From then the freezer cools to -32c and warms up to -2c and down to -32 etc.. The fridge varies in temp but does go as low as 0c and high as +9c. Alongside this, when the compressor is not running we can heard a ticking noise and identified that the compressor fan was turning slowly about ?100 rpm There's no ice build up, the freezer to fridge air louvres are opening and closing when you switch the FF on, and do seem to open and close at different times. The evapourator fan seems fine as does the compressor fan, the bottom of the fridge is dust free and the rear panels are all on to allow proper cooling of the condensor motor. I pulled the board again, checked all the capacitors I have a slightly different board to many and all the capacitors I had used from one brand have failed again. I took all the caps out and measured them. C6, C16 should have been 0.68uF and were in the order of a few nF C14, 26, 27,28 should have been 0.1uF and were 0,.6nF, 2nF, 10nF and 38nF respectively. All other film and electrolytic capacitors were within tolerance. I replaced all the faulty caps thinking that I had found the display problem because you had told me in the past that C6 and C16 relate to the front panel and the cooling issues and fan issues but NONE had been cured :- I checked the continuity to the front panel of all connectiions and they're fine. Also checked the 2 electrolytics on the front board. So I am at a bit of a loss. I have checked the zener diodes in situ and all have about 6v forward voltage drop I cannot find a replacement board due to different connectors on my unit - so unless I can fix we will have to fork out for a new FF :-

See all Syntax Olevia 50" Rear Projection HDTV-Ready Questions

217 views

Ask a Question

Usually answered in minutes!

Top Syntax Televison & Video Experts

Jaime Hernandez

Level 3 Expert

2351 Answers

Kolbrun...

Level 3 Expert

1222 Answers

ray gallant

Level 3 Expert

74163 Answers

Are you a Syntax Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...