Question about MTX JackHammer JH600 Car Audio Amplifier

Open Question

Car amp thumping bass and flashing lightning bolt

I just bought a new mtx jh600 amp and about after an hour my buddy decided to max the bass and the sub woofer just started thumping and the flashing orange lightning bolt started up on the amp. i know its not the subs that blew becuase we hooked up a new sub woofer to it and the same thing happened it would only thump and no music would come out. i unplugged the subwoofer and turned the car back on and all the speakers would play fine but the lightning bolt on the amp is still flashing

Posted by wrw13wang on

Ad

1 Related Answer

Anonymous

  • 5 Answers

SOURCE: mtx jh600 feed back in subs light on amp the bolt is blinking

check that the ground wire is bolted tightly to the chassis of the vehicle.

Posted on Aug 10, 2009

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

My mtx jh600 has 60 volts at output.Why?

any dc voltage at amp output is a sign this is blown. the problem is on the output transistors and can only be fixed by a technician
0helpful
1answer

Getting a blue light but no bass from sub woofers, hook up correctly.

check ur rca jacks make sure there connected also on stereo make sure subwoofer setting is on and turned up,bass,fader etc...
0helpful
1answer

Mtxjh1200 , the light with the lightning bolt blinks and subs make a thumping sound like a heartbeat

ur rca wires or its the holder itself if the subs do it when the rca wirtes are off the oits the bord inside the amp
0helpful
1answer

What does the ligtening bolt symbol mean that flashes orange on an mtx rfl 600d amplifier

orange lightning bolt on rfl600d is a short circuit..i learned this with mine when subs caught fire in my trunk...loose terminals, or incorrect wiring for dvc was cause of it on mine.
1helpful
1answer

It wont turn on, it give me a flashing light on the flash sign..

please run a thicker power and ground if u have already check ur fuse on the power make sure its a big enough amp fuse for the amp
0helpful
1answer

Mtx jh600 feed back in subs light on amp the bolt is blinking

check that the ground wire is bolted tightly to the chassis of the vehicle.
0helpful
1answer

Subs will go off the wall with bass, but not in tune with music.

hi, first disconnect the rca input, then switch on headunit and if the amp produces a constant bass thump it then means it has an internal fault. if the amp idles quietly then replace the rca cable, or try connecting the headunit lineout feed directly to the bass amp, in this way you cud find out if your fault is coming from the headunit or the equaliser. cheers
Not finding what you are looking for?
MTX JackHammer JH600 Car Audio Amplifier Logo

Related Topics:

99 views

Ask a Question

Usually answered in minutes!

Top MTX Car Audio & Video Experts

Pierre Laplante

Level 3 Expert

2061 Answers

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1190 Answers

 Francisco Mauricio...
Francisco Mauricio...

Level 3 Expert

1551 Answers

Are you a MTX Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...