Question about Cobra 148 GTL 120-Channels Base CB Radio

5 Answers

Cobra 148gtl no tx audio receive ok,tx carrier on am no modulation though mic just stopped.replaced ics ta7222p and voltage reg mb3756.maybe its in the mic amp any help please.

Posted by Anonymous on

  • radio dude May 11, 2010

    I have a Cobra 148 that works fine on both USB and LSB but has no AM TX power.

×

Ad

5 Answers

Anonymous

Without having a look inside of radio. but sounds like the voltage req chip on the side of radio.i think off hand its mb3756 .yes just got out manuel this one .usually causes problems like your one.email back.cheers from new zealand..rick.

Posted on Feb 20, 2008

Ad

Anonymous

Tomcat 1 back ...i have found the fault no modulation on am/usb/lsb.tr -23 a bc458 transister .replaced this transister and wow modulation on all 3 modes thanks zeppfrog for telling me where to look .

Posted on Mar 01, 2007

Ad

Anonymous

Ok collector of tr-23 reads 1 volt with a dead key or without the dead key .the r-120 reads 6.5v with a dead key or without a dead key .i have replaced the capacitor 330uf to a 16v.replacing tr23 could be at fault.end of press for now i will get back..

Posted on Feb 25, 2007

Anonymous

Yes i remember some tec said sometimes people add a power mic and dont wire it right get modulation wire wrong and feedback .wrong wiring blows out the c18 electrolytic capacitor .thanks zeppfrog thanks for the help i will do some testing.i replaced the meter light and the tx light with the a cool blue led it looks smart.i will get back with the results.

Posted on Feb 23, 2007

Anonymous

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 4 Answers

I am having this trouble as well. The ics was my thought too, but I think it is in the modulation circuit somewhere. another article i read said to check this. "Look for the collector of TR-23, you should read about 4.5 V with a dead key. If you find that this voltage is not present, check on the opposite side of R-120 for 6.5V. Most likely this voltage will not be present; if this is the case, C18 has shorted and needs to be replaced. This is a 330uf, 10V electrolytic capacitor beside L31. To prevent "future" problems, replace with a 16V unit." As of yet, i havent gotten that far. note this is from the cobra 2000, but they are very much alike. you might cross check the resistor capacitor numbers though. btw, isnt the mb3756 the pll ic?

Posted on Feb 15, 2007

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

Good day I have an cobra 148 Gtl tx and rx a working but no out put

It might not seem obvious but on many, if not all, current CB radios have separate wires coming from the microphone for RX and TX. It seems like the mic wire for TRANSMIT may be open. It is a common failure.
0helpful
1answer

148 gtl cobra cb radio and the rx/tx light stay on

This sounds like a problem with the MB3756 Regulator IC. It controls voltage regulation and TX/RX Switching. It is a common failure in these radios. Check voltages with schematic that can be found at
CB Tricks Home Page
0helpful
2answers

Need Cobra 148GTL with Cobra HG M75 pin-out color code

1audio. 1red
2shield. 2shield
3receive. 3blue
4switching. 4white
5transmit. 5black

Hope this helps
0helpful
1answer

Radio quits after 15-30 seconds

without more detailed info, quick suggestion - thermal fault, if all TX audio works when in this fault condition, it may be fair to assume audio IC is ok and check electrolytic capacitors and dry joints.
1helpful
1answer

No modulation with strong carrier

sounds like your Audio Output went out......not audio chip....may be your voltage regulator also....your voltage regulator IC is heat sunk....do you have a schematic?
0helpful
1answer

Pro 640e

How are you testing the audio out?
Are you using another radio?
If so, are you REALLY sure the other radio is ok?
If the other radio is ok, how do you know the mic is ok? have you tested it with another radio?
If the mic is ok, id have a look at the mic socket to check that all the pins are still there. Then open the radio up and check the socket is still connected to the main board.

Let me know how you get on..
M3ODQ
0helpful
1answer

No receive cobra 29 ltd classic

Hi and welcome to FixYa,

Initially, pls confirm that there is modulation (transmit audio). The reason I asked is if IC4 (TA7222P) is blown, then the radio would have no audio amplifier which would explain no receive audio. Additionally, the final and pre-final (TR15 & 15) gets is modulated TX+12 through D8 from T1 which in turn is the output of IC4 through C48.

Perhaps a schematic diagram may be of further help.

Good luck and Thank you for using FixYa. Happy Holidays.
0helpful
2answers

No recieve on virgin cobra 142 gtl,

seems to me that the audio ic of the cobra 148gtl brokedue sudden change of voltage from power suplly or flactuation. ta7222p

0helpful
2answers

Not working

you have more than likely a dead audio output ic gone faulty.look into radio on its back you will see the audio ic on the upper righthand side of radio.the heatsink is bolted onto the case with a plastic screw . its in a single inline package type.
Not finding what you are looking for?
Cobra 148 GTL 120-Channels Base CB Radio Logo

Related Topics:

856 views

Ask a Question

Usually answered in minutes!

Top Cobra Radio Communications Experts

Brad Brown

Level 3 Expert

18723 Answers

Michael Thomas
Michael Thomas

Level 3 Expert

3056 Answers

eradiostore
eradiostore

Level 3 Expert

1664 Answers

Are you a Cobra Radio Communication Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...