Question about Air-O-Swiss 7133 Humidifier

1 Answer

The humidifier doesn't make enough vapor

I have loved my Air-O-Swiss for two years, but this season I took it from storage and noticed that the circle where the water is aerosolized was crusted with something, and I am worried that I cleaned it too roughly. Now when I turn on the humidifier, it goes on, but instead of a big cloud of mist, I get a dinky little cloud, and also some bigger drops. With the water tank in place, no mist makes it out of the nozzle. What can I do?

Posted by Zachary Demko on

  • 4 more comments 
  • pettigrew Jan 20, 2008

    I have the same problem that grey paint is chipping where the vapor comes out... is it broke? the vapor is almost non existent? I try the vinaigre but no change...
    thanks eric

  • makfix Jan 30, 2008

    while cleaning, i think i was little hard on the part where the mist comes out. now there is no mist except small bubble. what do we do this expensive humidifier.

  • Anonymous Feb 15, 2008

    My 7133 ultra -sonic device doesn't output vapor. I tried to clean the unit with no success.

  • JackyT Apr 08, 2008

    We have the same problem after 3 years. Very little vapor or none atall comes out at times. We tried using the ez cal cleaner but this did not help.

  • qclabrat Apr 10, 2008

    I have the same problems, one was the peeling plastic, which I hear is not a problem, but in my opinion a design flaw. Second is the misting. I was actually able to take apart the bottom, which was a bit difficult as they use special screws (not flathead, not phillips, not torx). The issue was a corroded rubber piece which holds the aerator disk which creates the mist. I was hoping to find a replacement rubber O-ring to make the repair, unfortunately the rubber piece is not something I could find at a hardware store. Also, be careful went handling the disk, it is fragile and cracks easily. I found out the hard way, and may the reason why some of you are not getting a mist. I just started looking for an online store which stocks replacement parts for air-o-swiss, but still no luck yet. I'll try to keep you posted on this....Walt

  • Anonymous Mar 23, 2014

    Today the mist stopped for some reason even though the tank was full of water and setting was on mist

×

Ad

1 Answer

Anonymous

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Soak it with vinegar for several hours then use a soft nylon bristled brush to scrape off the minerlized crust and rinse. You probably need to replace the silver stick & mineralization cartridge more often.

Posted on Feb 20, 2007

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

Air-o-swiss membrane coating coming off, is this a

no its not a problem if you dont mind how the system looks...otherwise just get some oil paint and re-coat it
1helpful
1answer

I need an online owners manual for AIR-O-SWISS 7135 Ultrasonic Humidifer. Thankyou

Here is the general download page for all AOS manuals and quick set-up guides.

Here is the direct link to the AOS 7135 manual in pdf format.
0helpful
1answer

Air o swiss 7135 turns on but no mist comes out...

would you describe your problem in a little more detail please?
17helpful
6answers

Air-o-swiss 7135 humidifier not misting

Ours has done the same thing after only 2 weeks. From article research, it appears that this occurs to everyone after cleaning it with the EZ Cal that is recommended. From looking at our unit and figuring out how it works, it appears as though the Ultrasonic Vibration membrane has stopped working. This particular piece is responsible for vibrating the water and making water mist particles which are blown out with the air. We will be calling the manufacturer on Monday to register a complaint and request a replacement unit.
6helpful
1answer

Air o swiss 7133 doesn't send out any vapor

Interestingly enough as soon as I posted here, I was able to find the source of the problem. It appears that during cleaning the water level sensor, a bobber which normally floats as the water level rises, became stuck the to bottom of the water base - see below for the picture. I was able to use a small wooden spoon to lightly apply pressure and release the bobber so that it could float, and instantly the vapor started flowing again.
15ef7b7.png
1helpful
1answer

How to clean air o swiss humidifier

Any bathtub cleaner will work so much as you do a good job cleaning then rinsing. Be careful not to get the humidifier wet anywhere other than the basin that the water goes through.
0helpful
1answer

Air-O-Swiss 7133

Okay, I just started getting this same deal with my 7133 on it's third season. I found in a blog that if you hold down the button that controls the heat while turning the mist knob on, it resets the machine. It worked. The red light went green and I turned off the heat button for cool air and the upper light still stayed green. Fingers crossed this continues to work. good luck!
0helpful
1answer

Air o swiss 7135

sounds like the filter is not allowing air flow.
0helpful
1answer

Noisy ultrasonic humidifire

The grey circle (diaphram) needs replacing. Try Maplin electronics.
Not finding what you are looking for?
Air-O-Swiss 7133 Humidifier Logo

596 views

Ask a Question

Usually answered in minutes!

Top Air-O-Swiss Humidifiers Experts

Tom Chichester

Level 3 Expert

62196 Answers

ray gallant

Level 3 Expert

73778 Answers

ADMIN Canada
ADMIN Canada

Level 3 Expert

41502 Answers

Are you an Air-O-Swiss Humidifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...