Lanzar HTG264 Car Audio Amplifier Logo

Related Topics:

Question about Lanzar HTG264 Car Audio Amplifier

1 Answer

Whats wrong with my lanzar amp

Ok, so my amps led light lights up but the power light doesn't turn on and today when i hooked it up it turned on for like 30 secs and then shut off and i can't get it to turn back on but the led light is always on... whats wrong with it?

Posted by jeff hagen on

  • j_r_dixon Mar 03, 2008

    my amp was working fine for a day, then i went and started my truck and it didnt come on. I checked all the wiring and fuses, and one was blown so i replaced it, but it still doesnt work anybody know wats wrong?

×

Ad

1 Answer

Anonymous

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 35 Answers

Check ur ground wire , it might not be good ground, secondly check ur fuses..

Posted on Jul 15, 2009

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
2answers

Dropped me a red flashlight.The problem is ?

Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. Time to get yourself an old school Lanzar Opti Drive amp .A thumbs up would be greatly appreciated if this answer is helpful to you. dropped-me-red-flashlight-problem-shonxoarcym4awy4zl1imx4o-2-0.jpg Lanzar
0helpful
2answers

I have a Lanzar Vibe 235 amp. the green power light is not coming on, but the red "protect" light is. how do i solve this problem??

Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. Time to purchase an old school Lanzar Opti Drive. Any of them. The 50 will kill some 12" subs .A thumbs up would be greatly appreciated if this answer is helpful to you. lanzar-vibe-235-amp-green-power-shonxoarcym4awy4zl1imx4o-2-0.jpg Lanzar
2helpful
2answers

Thermal light goes away when ground added

Doesn't sound like anything is wrong. If the thermal light is on before you have the ground hooked up then the amp is probably getting a small amount of electrical ground from the shielding on the RCAs or its mounting to the chassis of the vehicle allowing the amp to "barely turn on" (not enough ground). I can imagine this would make the amp think something is wrong (ie: thermal light) . May I suggest that you do not try to turn any amplifier on without ALL appropriate wires connected correctly.
0helpful
1answer

I have a 600watt vibe amp all wires are connected correctly but power light comes on and then goes straight off and repeats this constantly whats wrong??

most amp have a protection feature sounds like somthing is hooked up wrong or u have a short to ground id recheck using a multi meter if all test r good then ur amp needs to be serviced.
0helpful
2answers

I have a lanzar vibe 255 can u help me?

Double check your connections. Use volt meter to co firm proper voltage. A test light can still light up with low vol
.A thumbs up would be greatly appreciated if this answer is helpful to you.
1helpful
1answer

Not sure whats wrong with my LANZAR MXA242 AMPLIFER. Please help!

did you check the fuses on the side of the amp? put voltage meter on b+ should read 13v, take it to service center to have checked out, may have some prblems inside
0helpful
2answers

Protection light grief

Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. Vibe is mediocre. Time to invest in an old school Lanzar Opti Drive amp. .A thumbs up would be greatly appreciated if this answer is helpful to you. protection-light-grief-shonxoarcym4awy4zl1imx4o-2-0.jpg
0helpful
1answer

Dont know whats wrong

You can check the fuses if it has more than one. Or another thing that might be wrong is that you might have to big of a speaker hooked up. Or your power wire might be to small because if its two small then the amp cant get enough power to power a big speaker.
0helpful
2answers

Lanzar Vibe 1200D protection light

You will need to show it to a service technician as it seems the output section has blown so it remains in protect mode. One reason (could be) that the input to the amp was high and may have been clipping for some time before the amp decided it could take it no more
0helpful
1answer

LED power protection light not turning on

Check the fuse on the amplifier; if it's good, then you need a multimeter or voltmeter for further testing. With the meter's black probe on your amp's ground terminal and the radio turned on, both the power and the remote terminals should test at about 12 volts. If neither terminal shows voltage, you may have a problem with your ground connection; if both do, there's a problem with the amp.
Not finding what you are looking for?

Open Questions:

See all Lanzar HTG264 Car Audio Amplifier Questions

102 views

Ask a Question

Usually answered in minutes!

Top Lanzar Car Audio & Video Experts

 Francisco Mauricio...
Francisco Mauricio...

Level 3 Expert

1551 Answers

Morne Olivier
Morne Olivier

Level 2 Expert

264 Answers

Mike G

Level 2 Expert

100 Answers

Are you a Lanzar Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...