Question about Fujitsu Plasmavision PDS-4209 42 in. Television

2 Answers

Black screen after 5 minutes of use with Fujitsu PDS-420 plasma

I've had 5 trouble-free years with this display, but lately, the screen goes black after 5 minutes of use. Details: Screen powers-up fine and displays a great picture (with both component and vga inputs), but after 5-10 minutes of use (less if it's warmed up) the screen goes black. The power LED continues to show green, but the screen is black. Powering off for a while will restore the picture, but this will last only for a couple more minutes then blackness. Any help is greatly appreciated in advance. Thanks. ---Paul

Posted by Paul Friedman on

  • 2 more comments 
  • Paul Friedman Dec 15, 2006

    Thanks for the advice. Do you have experience with this particular model, or just generally speaking about plasmas? I ask because I have heard from other sources that it might not be the main board, but the "Drive Boards" (there are 2) for the plasma.

    ---Paul

  • nvme Nov 14, 2007

    I have the same problem with my prima cineplus. except when the screen goes black the green light goes red.

  • thedoc223 Apr 27, 2009

    Same here......this unit has worked fine for years but now after about 5 min's I lose video but tv stays on. Pulled the tv and the cover in the back and tried to vac any dust w no luck. I had originally got this tv through a american eagle outfitters well I did a service call for their corp office and they said they would replace this unit and send a new one. I ask what they wanted to do with the fujitsu and they said dispose of it. So I took it to my shop, got one of a ebay w a busted screen, replaced the vid board and it worked. Has worked great ever since until Fri night then went out. tried a power supply board out of the other unit and it blew the fuse.

    Any help would be appreciated.

  • Anonymous May 24, 2009

    The screen comes on for 5 minutes but goes black yet the fans and everything else works fine.

×

Ad

2 Answers

Anonymous

Most of the time, when the power light stay green, thr filter capacitors in the power supply have lost value, & need replacing.
When the power light turns red it indicates loss of signal. This could be the same problem except the input signal has been lost. Try replacing power supp;y caps , about 4 of them.
Works 90% of the time. Hobby of mine, Art

Posted on Dec 29, 2007

Ad

Anonymous

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 3,130 Answers

Sorry to inform you my freind, but the main board has to be replaced in this beast. Could get expensive. there are no schematics and or componets listed to repair this module. Its a board level repair only. Try going to ptscorp.com, find their phone number, and see if they repair these boards. if not you will need to contact the manufacturer for replacement boards. good Luck Please do not forget to rate this thread.,

Posted on Dec 15, 2006

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Open Questions:

0answers

Fujitsu Plasmavision pds-4208 Display randomly hey everyone =D any help would be greatly appreciated! this is my problem... i have this plasmavision it has been working fine since i got it, now all of a sudden the picture will just disappear, as its only a display unit and I'm running my audio thru my home cinema system. its an intermittent fault but its been progressively getting worse, sometimes a sudden display change will cause it to stop working, a total display loss with no osd... however green light continues and the psu still carries on operating with fans going... until a couple of minutes when it will shut itself down and display an orange light for no input signal. Ive had the psu out and tested all the connections as i have the service manual but no schematics. when the unit is fully operational all output voltages are correct but a few which maybe a volt lower or higher than stated. however when the unit stops displaying a picture, the x and y sustain outputs drops its tension... only one connection does this on the CN49 on the Ve pins for both x and y sustains the tension drops from nominal 16v to 4.2v i have removed the sustain connectors to power up the psu and funny enough... without the sustain boards connected the pin has only a 0.2v output this is really confusing me now. Its a bit of a bummer too as i have no schematics to follow *puh* am i right in thinking this is solely a psu problem?... or maybe a faulty digital board?.. seeing that the display shuts itself off due to no signal? or could it be a faulty sustain board? does anyone know whats going on or had this problem before? kindest regards to all... Jay jaydeeks(at)hotmail.co.uk

Fujitsu Plasmavision PDS-4209 42 in. Television Logo

643 views

Ask a Question

Usually answered in minutes!

Top Fujitsu Televison & Video Experts

The Knight
The Knight

Level 3 Expert

76698 Answers

Cindy Wells

Level 3 Expert

6301 Answers

ADMIN Canada
ADMIN Canada

Level 3 Expert

39168 Answers

Are you a Fujitsu Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...