Question about AudioBahn A1500HCT Car Audio Amplifier

2 Answers

Audiobahn A1500HCT in Protection Mode

I have an Audiobahn amp A1500HCT. I had the connected to two ALUM12Q?s and it work great. I have since sold that car and had the amp and speakers stored in the house until I put them in my Grand Cherokee. My problem is that the protection light stays on as soon as I power up the amp. I have a 1.5 Farad Capacitor connected, 4Ga wire from the battery approximately 15 foot, and a 4Ga ground directly to the body. If I connect a smaller amp in place of the A1500HCT it works fine, so all connections or working. I connected the A1500HCT to the battery with a 4ft 4Ga wire to the positive and negative and still had the protection light come on. I had the same configuration in the car I sold that I do now and cannot figure out why or what is happening. I also have removed the capacitor which made no difference.

Posted by Anonymous on

Ad

2 Answers

Anonymous

  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

  • Contributor
  • 1 Answer

I have the same problem with my audiobahn a1500hct it is not the wireing i have hooked other amps up that work fine. i have takeing my amp apart theres no visable damage im not really sure what the problem is if i could find a book or repair manual for the curcuits i might be able to fix mine then tell u what to do to yours

Posted on May 31, 2010

Ad

Anonymous

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 155 Answers

Try just hooking up a power wire and ground wire only. disconnect your subs from your amp along with the remote wire and RCA's. if you have some jumper wires or run a wire from the power terminal to the remote wire. YOUR amp should come on, if it still stay's in protection mode it might be shot... hope this was helpful, i couldn get my a2300hcx to come on and tryed this and it came on turns out it was my remote wire was bad of the head unit...

Posted on May 11, 2010

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Audiobahn a1502dp amp only one channel is working. I need both to bridge it and get its full 1ohm potential. Where can I get this fixed? Preferably near kc


Audiobahn A1502DP True Digital Series 2-Channel Amplifier

www.sonicelectronix.com > ... > Car Amplifiers > Class-D Amplifiers

Rating: 4.5 - ‎4 reviews
Audiobahn A1502DP • True Digital Series 2-Channel Amplifier 1 ohm stereo stable 2 ohms bridged • True Digital Circuitry • Dual Cooling Fans • HP/LP ...

new amp, only one channel working?? help! [Archive ...

www.caraudioforum.com > ... > Car Audio: Installation Help

Apr 24, 2006 - 16 posts - ‎5 authors
the next step would be to try reversing the rca cables on the amp. ... unplug one wire, the one sub that is working, gets quieter, although it is still working. as ... It'saudiobahn, of course this could happen straight from the factory.Missing: a1502dp

[PDF]True Digital Full-Range Series - Audiobahn

audiobahn.com/.../Amplifiers/A752DP-A1502DP-A2502DP-A1004DP-...
A752DP/A1502DP/A2502DP ... Audiobahn was established in 1997 with one long-term goal in mind, ... Great products and proper installation are only a small piece of the puzzle when it ... from the smallest terminal, to power wires up to 0 gauge, and 4channel RCA cables. .... exceed the total value of fuses in the amp. 1 1 .

one channel not working [Solved] - Speakers - Audio


Jan 15, 2016 | AudioBahn Car Audio & Video

2 Answers

Amp constantly blows fuses as soon as power wire is connected. anyway to fix?


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty .
.A thumbs up would be greatly appreciated if this answer is helpful to you

amp-constantly-blows-fuses-as-otfyjrky3pc2prtgltcdyqtn-3-0.jpg

May 22, 2011 | AudioBahn A2002T Car Audio Amplifier

2 Answers

I Have a audiobahn a1800dt its almost identical to this amp, i played it for a while with no problems, until i hooked up some crappy subs to it and it went into protection mode without comming out of it....


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty . Please check speakers impedance A thumbs up would be greatly appreciated if this answer is helpful to you

audiobahn-a1800dt-otfyjrky3pc2prtgltcdyqtn-3-0.jpg

Feb 03, 2011 | AudioBahn A18001DQ Car Audio Amplifier

1 Answer

My audiobahn amp 2000w serial number A1500HCT is not currently working when I plug it in turn on the car the blue light that usually indicates that it is working turns to red. it was working fine before...


Check all your connections and wires. You probably have an issue with a bad ground or your remote wire Make sure you have no bare spots on your wires. Also make sure there are no pinch points on the wires running to amp.

Nov 18, 2010 | Car Audio & Video

2 Answers

Audiobahn a8002t amplifier in protection mode


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. D .A thumbs up would be greatly appreciated if this answer is helpful to you. audiobahn-a8002t-amplifier-in-protection-lv2kkrmxrai4iihdvw4m3np2-2-0.jpg

Dec 21, 2009 | AudioBahn A8002T Car Audio Amplifier

2 Answers

No sound protection light on.


Either blown subs, or bad amp.. Disconnect the subs, and try turning the amp on, if the amp is still in protect then your amp is bad, if the protect light goes off, then your subs are bad, or possibly wired at to low of an impedance, but I don't think that will trigger the protect on an Audiobahn amp.

Aug 21, 2009 | AudioBahn A2002T Car Audio Amplifier

1 Answer

Blown speaker? Audiobahn AS65C


it sounds like you need to get a new set buddy... sorry :(

Apr 07, 2009 | AudioBahn AS65C Coaxial Car Speaker

1 Answer

My audiobahn a1500hct amp blew all the fuses so i unhooked the subs and put new fuses in and they didnt blow but then the amp kept switching from the blue to red led??


in the owners manual it will usually say that that means you have an incomming power problem it states that you should check your ground and battery cable
hope i could helped!

Apr 05, 2009 | AudioBahn A1500HCT Car Audio Amplifier

1 Answer

Wierd stopped working audiobahn a2300hct


Disconnect all speaker wires from the speaker terminals of the amp and disconnect signal cables from the amp. If it powers up normally, the wiring and speakers need to be checked. If it still shuts down, the amp likely has blown output transistors.

Apr 05, 2008 | AudioBahn A2300HCT Car Audio Amplifier

2 Answers

Protection Light On


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you didn't fry speakers as well. Please check speakers impedance. A thumbs up would be greatly appreciated if this answer is helpful to you

protection-light-otfyjrky3pc2prtgltcdyqtn-3-0.jpg

Nov 26, 2006 | AudioBahn A8000T Car Audio Amplifier

Not finding what you are looking for?
AudioBahn A1500HCT Car Audio Amplifier Logo

Related Topics:

454 views

Ask a Question

Usually answered in minutes!

Top AudioBahn Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

5023 Answers

ADMIN Canada
ADMIN Canada

Level 3 Expert

37879 Answers

ray gallant

Level 3 Expert

72055 Answers

Are you an AudioBahn Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...