Question about Hoover F7431-900 SteamVac Vacuum

3 Answers

No suction My Hoover Steam Cleaner does not have any suction. We have cleaned, checked belts and filter. Still does not work.

Posted by Yolanda... on

  • Anonymous Mar 27, 2014

    my panasonic hoover has lost all suction cleaned filters cant see any blockages

×

Ad

3 Answers

Anonymous

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I laid my cleaner down and checked it all out and actually vacumed the insides out (we have a lot of animals at our house) and then put the Recovery tank bank on and it worked fine.

Posted on Nov 02, 2007

Ad

Anonymous

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 3 Answers

I had a a low suction problem. Mine was easily fixed. Stand in front of the machine. When you remove the recovery tank there are the notches on the front of the tank that fit down into the machine. In the right hole in which the right notch fits, there should be a black rubber washer on the machine. Mine somehow came off and feel into the machine therefore there was practically no suction as the seal was not airtight. I only discovered this when I took apart the machine and found it floating around. Just something to check.

Posted on Aug 04, 2007

Ad

Anonymous

Hmmm...I have the same problem...if you remove the water tank and the water collection bucket and look at what is remaining. Now step on the lever to lean the upright part back and there is a hose there that goes from the hand held hose into this hose into the dirty water tank. MINE is broken at that center point between the handheld hose and the dirty water square thingy...It's probably fixable...maybe this helps you?

Posted on Jan 11, 2007

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1helpful
1answer

How do you get to the belt on a Hoover steam vac?

I hate to tell you, but there is no belt at all on the steam vac line. they have a suction driven turbine to turn the brushes, and a suction driven pump for the water flow. But definately no belts.

If something is not working on it, describe more in detail what is not working and we can narrow it down better for a proper solution.
2helpful
2answers

On hoover steam carpet cleaner, the brushes do not rotate on low or high settings.

Follow these steps if the Brushes Fail to Spin
•If the brushes on your Hoover carpet cleaner fail to spin, there may be a problem---some sort of blockage---with the suction or with the belt that turns the brushes.
Turn the Hoover carpet cleaner over, and inspect the brush area. Debris, strings, or pet hair may be tangled in the rollers, keeping them from turning. Use a pair of scissors to cut away any obstructions in this area. Flip the Hoover carpet cleaner back over, and turn it on to see if cleaning the rollers has solved the problem.
To check the belt, turn the Hoover carpet cleaner over, and remove the bottom plate screw with a Phillips head screwdriver. Investigate the belt area to see if it is broken or has somehow slipped off. If it is broken, you can order a part from Hoover.com or from many of the other online parts stores.
When the belt arrives, simply slide it on in place of the broken belt, reattach the bottom plate and turn the Hoover carpet cleaner right-side up. Turn it on to test your solution.
2helpful
1answer

Hello,We have an Hoover Mach 5 Cyclonic vacuum that has no suction. We have cleaned and checked all hoses, belts & filters. Please help us.

With this model, remove the dust tank, and turn it on, check for suction at the lower intake. If you have suction, install the tank and remove hose, and check for suction there. keep following until youn lose it. Then you problem will be between those 2 areas

I’m happy to assist further over the phone at https://www.6ya.com/expert/robert_b96ba3f038cf317c

1helpful
1answer

Hoover steam vac deluxe - no suction and the scrubbers aren't spinning uless you tilt off the floor.

I would suspect that your turbine assembly bearings need to be replaced. also check for debris inside the brush assembly. check the intake filter under the front clear cover. verify the recovery tank lid is on securely, as well as the foam filter on the tank lid is clean.

I’m happy to assist further over the phone at https://www.6ya.com/expert/robert_b96ba3f038cf317c

0helpful
1answer

Hoover steam vac model F5853-900 series 17.9

Make sure that the recovery tank is completely close.
0helpful
4answers
0helpful
1answer

My hoover steam vac

OKay! I've figured it out! After making sure I had the cleaning solution container connected properly, the "lint filter" thingy clear, the attachment plug thingy unplugged, the filter in it's proper position, (about a cm down from the seal), and the seal on the filter was all good, etc etc etc, the brushes in properly...I was about to drive over this steam cleaner with my car!

After taking a break and going back to it, I discovered that I didn't have the lid to my dirty water tank (or air tank, as I was starting to call it) properly closed. There are two lips that you have to make sure the lid "hinges" from, and THEN snap the lid shut. This made a seal that allowed this steam cleaner to **** up all kinds of gooey gunk from my carpets! The brushes work, the suction works, it's a FABULOUS machine! It doesn't get any louder when it's sucking up water, either.

All this AND I had the instructions! Go figure!
0helpful
1answer

Hoover Steam Vac Clean Surge

http://www.geeksquad.fixya.com/ThreadView.aspx?prdid=618767&thid=407245
Hoover Steam Vac Clean Surge
Posted by just a brat on Feb 22, 2008
I can not seem to get the attachment for the upholstery cleaner to operate what am i doing wrong????

Hello,
I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure.
The attachment works on the suction from the Hoover Steam Vac and it’s either a straight suction tool or a revolving brush, check the front of the machine to see if the is a switch to turn on and odd, also before you attach the upholstery tool check the end of the hose for suction, it may be that your upholstery tool may be clogged or the brushes are not spinning and a part may be broken. Feel free to check with you local vac dealer or a new or a good used part if you find out what is wrong. So if you need further assistance, please feel free to contact your local vacuum cleaner dealer in your area or in the yellow pages, or contact the factory phone number or website to further assist you with your questions.
http://www.hoover.com Telephone
Contact our Customer Service Department at 1.330.499.9499
Monday through Friday
8 a.m. - 7 p.m. EST

Don – The Vac Man
Go Ahead. Use Us.
0helpful
2answers

Problems with the Hoover Steam vac Heated carpet cleaner

The first thing to check is the filter on the inside of the lid to the recovery tank, if it is all of the way up to the top, it can cause variouys problems, it should have a 1/4 in gap from the top. The other thing is the turbine, that is what drives the brushes. If the brush block is ok, then most likely the turbine is bad and will ahve to be replaced. Part # for the turbine is 43191006 and sells for about $60.
1helpful
2answers

Problems with the Hoover Steam vac Heated carpet cleaner

This happens when the filter on the inside of the lid for the dirty water tank is pushed all of the way up. You need to leave a 1/4 in. gap from the top to the top of the filter.
Not finding what you are looking for?
Vacuums Logo

276 views

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Gerry Harvey
Gerry Harvey

Level 3 Expert

1482 Answers

Brad Brown

Level 3 Expert

18733 Answers

Mike

Level 3 Expert

4377 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...