Question about Televison & Video

1 Answer

My LCD tv screen becomes scrambled on half of the screen with input from a different source and has reddish colors.

I took the TV in for service 2 months ago because it wouldn't turn on, and they replaced the power source/cord. It was fine, then after a few weeks, the screen began to scramble or ghost with pictures of other sources on half the screen, or faded/scrambled with red/blue colors. It's almost out of warranty, what is the problem?

Posted by on

  • gambs_44
    gambs_44 Apr 01, 2012

    It comes and goes, usually after an hr of being on, but lately has come more often. I unplugged the TV for 10 minutes, and switched HDMI ports. That has put a band-aid on it for the last hr. Any techno-savvy person out there with an idea as to what it is or what path i should take would be greatly appreciated.

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Master
  • 14,553 Answers

Likely another board is bad--GET IT IN FOR REPAIR UNDER WARRANTY BEFORE NO WARRANTY SITUATION

Posted on Apr 02, 2012

Ad

3 Suggested Answers

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Anonymous

  • 3 Answers

SOURCE: Audiovox FPE3206 - Power Light is Blue/ON but Screen is BLACK

I had the same problem, except with a flashlight I could see AUDIOVOX when i turned it on and I could see the video when I put a DVD in. It is hard to see even with a flashlight so you have to look closely. Well, I researched and investigated what might be the problem because I was upset that I had the TV for less than two years. Everyone was saying the inverter was defective. Apparently the inverter is what gives the LCD screen the back light to see the video. So I called audiovox and found that thier part's selection was only a power board and a remote control for this TV. I asked them if they could get me an inverter and they did. With shipping cost it was approximately $150.00. They ensured that I know that there is no refund on this part (which is common for electical parts). So I took a chance on it not being the right part for the problem. I replaced the defective inverter myself and it worked. It solved my problem. The inverter is a circuit board that plugs in and has a few screws to hold it in place. I had to remove the back cover first and a couple of brackets inside the tv to get to the inverter and replace it. There is a quite a few screws so I recommend writing down where each came from for easier reassembly. I hope this helps!

Posted on Oct 21, 2008

LG help guy

  • 112 Answers

SOURCE: MY TV is LG 42 PG 60D , serial number :803KCBD35285

Have you tried using a different input on the main board? Like moving from HDMI 1 to HDMI 2, or moving from Componet 1, to Componet 2?

Posted on May 18, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Psp not detecting battery


Sounds like you might need a new power board. I know videogame911 does service PSP's your best bet might be to send it in to someone who can tell you exactly what the problem is, specially if you replaced the battery and still have the same issue.

Apr 23, 2013 | Sony PSP-3000 Black Console

1 Answer

AC/Heater Blower Fan in 1990 LS400 works intermittently


Due to the age of your vehicle, the brushes in the fan motor are worn out. you will have to replace the fan motor, it is not serviceable.

May 30, 2017 | 2001 Lexus RX 300

1 Answer

1985 Chevy El Camino 305ci. Turned over good but wouldn't fire. Replaced contrrol module and it started fine for about 2 months, then did the same thing. Replaced dist cap, rotor & coil. Start


Had an 84 silverado 305 that did the same thing. Try giving it a full tune up. Plugs, wires... Mine turned out to be fouled plugs. I didn't find that out till after i tore it down & put a timing set in it. Wasn't getting good enough spark.

Feb 16, 2013 | Cars & Trucks

1 Answer

Power loss


Likely bad caps in the units power supply--if a cheap unit just replace it considering effort to get out, apart and try to fix....

Apr 08, 2012 | Televison & Video

1 Answer

My brother Se 400 which is only a few months old just started running really slow. When I disconnect the foot petal and do the manual botton "the arrow button" it still runs slow. I don't...


have you checked to make sure the power cord is pushed in correctly?
if the power cord isn't the problem then it may need to be checked by a service tech, because it's not suppose to be running slow just a few months after you bought it.
I would call the people you bought it from & tell them what it's doing & see if they'll give you another one, I've been sewing for 30+ years & I wouldn't keep the machine.
good luck

Sep 22, 2011 | Brother Sewing Machines

1 Answer

A few months ago, the bulb wouldn't come on, so I


When you say 'bulb' ... I assume you mean the sewing light ? The Artista 180 does not have a conventional 'bulb' for the sewing light, but a fluorescent tube that's a 'C' shap and surrounds the bottom of the head unit by the needle. This is driven by a high-voltage converter that runs off a supply on the main processor board. If the machine is working normally but there's some intermittent on/off of the fluorescent light, it could be simply that the tube's had-it, in which case its off to the service man for a new one - it comes as a complete tube and converter replacement. But before you do that. TURN THE MACHINE OFF. unscrew the hex socket that holds the head cover on and remove the head cover (the cover over the needle end). If you look at the head mechanism, looking towards the foot pressure control (i.e. the 'end' of the sewing arm) you should see a small cirucit-board just above the fluorescent tube with a fairly large 2-pin connector on the top - this slides on to the circuit board. Try giving that a careful wiggle to re-seat the connections, but PLEASE BE AWARE THAT THIS IS A HIGH-VOLTAGE PART AND THEREFORE DANGEROUS, so you MUST NOT touch it with the machine switched-on. Hope that helps.

Sep 07, 2011 | Bernina Artista 180

1 Answer

I have a 1996 Chevy Blazer 6 cylinder 4.3 Vortex engine. The check engine light has been on for a few weeks but it was running just fine. Until all of a sudden it wouldn't start last night. I had...


My first thought would be: If you repaired an emissions hose, take the car back to Auto Zone (or another parts supplier) and let them tell you what code comes up now. You eliminated one problem, now you have to find another.
I wouldn't do a fuel pump without more information.
Gary

Jul 20, 2011 | 1998 Chevrolet Blazer

1 Answer

I have a 2006 Pontiac GT G6 Coup. When we first bought it back in Nov. 2010, it was fine. After a month or two, the clock would reset almost everytime the car was started, radio stations would NOT get...


sounds like a problem with the ignition barrel.the wiring is loose or the connectors are loose or the barrel is faulty,unless thse are all run from the onboard computer.

May 31, 2011 | 2006 Pontiac G6

5 Answers

Phone won't turn on, took battery out and put it back in, still won't turn on, it acts like it's about to turn on and then blinks back off. Battery is charged up, I've only had it for 4 months


When you power up first let it going into off chargeing mode, then hold the power button to turn it on, continue to hold it through this whole process, then after the sitck together box has been completed (which may take a few attempets) rapidly push the right soft key until your phone jump in and out of the t-zones area which should be your default right soft key buttong then you should be able to use your phobe normally, note that it did take me a good half an hour of doing this to make my phone through the whole process. :)

Nov 04, 2007 | Samsung SCH-u340 Cellular Phone

1 Answer

Light


My RCA 52 inch was doing the same thing.  TV guy had me use a regular hair blower blowing very hot on the power supply board ( bottom left in back). After a few minutes the tv would come on.  He replaced 2 capacitors, charged me $100.00, plus the $95.00 service call, and is working fine now.  This was a month ago.  So far so good.  He only took the board to the shop, not the entire tv.  Hope this helps. 

Oct 04, 2007 | RCA HD52W56 52" Rear Projection HDTV

Not finding what you are looking for?
Televison & Video Logo

Related Topics:

408 people viewed this question

Ask a Question

Usually answered in minutes!

Top Televison & Video Experts

The Knight
The Knight

Level 3 Expert

76204 Answers

Cindy Wells

Level 3 Expert

6068 Answers

Marvin
Marvin

Level 3 Expert

85223 Answers

Are you a Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...