Question about Visonik Dual Bass Box with Amplifier Car Audio Amplifier

1 Answer

Amp Power light will not go on. Protection light is lit- Thump sound in speakers

I just installed this amplifier Visonik VB212PKG RMS condition is 4ohm - 200 W per channel, 8 ohm - 100 W per channel CONNECTIONS MADE -10 GA power 30A fuse - no capacitor used - GND made & checked - control wire connected from stereo amp control - connected to Low input (from Rear Pre-amp out from stereo) - regular stereo speaker connections (8 ohm) per channel - 120 Watt speakers per channel Everything is connected correctly to me. 1. The Red "V" light is lit 2. The GREEN POWER light will not come on. 3. The RED PROTECTION light is lit constantly. 4. The speakers only thump like a heartbeat every one second - with no music sound. What is wrong? Thank you GW

Posted by Anonymous on

  • Craig Salcedo
    Craig Salcedo Apr 21, 2014

    my boss 3600 watts amplifier is doing this same thing help

×

Ad

1 Answer

Anonymous

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

It probably has shorted output transistors. To eliminate other possible causes, read through the following page.

Amplifier in Protect Mode - Troubleshooting

Let me know if you have any other questions.

Posted on Nov 02, 2008

Ad

1 Related Answer

Anonymous

  • 7 Answers

SOURCE: Thumping speakers - no power light is on - wired correctly

the amp is going into protect mode due to something wrong in the amp or some thing in the wiring to it ooh yea if you are getting 18v power to the amp that is way to high it should not be higher then 15v if the amp is in protect mode it will not play at all.

Posted on Nov 02, 2008

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

How do i hook up my amp. the ground wire and the v 12

well, basically... the 12v (+) power wire is fused and hooked to the battery and ran to the amplifier, then run an amp turn on wire from you radio its usually blue with a white stripe (if you have an after market radio) then run the rcas from the radio to the amp and finally tap the ground (usually and cleaned bare-metal on your car close to the amp).... if you give me some more info i can help u further... what is the make/model/yr of your car, what radio do you have, amp, sub, speakers, etc....?
0helpful
1answer

Amp wont turn on..Visonik vb212pkw

Well you have a high impedance path to your amp. If you have an inline fuse that should have blown. Car batteries don't have a current limiting feature HA The only explanation would be that the amount of current passing through the wire is causing a large voltage drop due to a large impedance. What gauge wire are you using? Here is an example.

18 ft of 8 gauge wire would have to be passing about 400 Amps of DC current to yield a voltage drop of that magnitude. The wire would melt and all hell would break loose. So there has to be a break in your wire somewhere.

0helpful
1answer

Installation Guide for Car Subwoofers

MOST OF THE TIME AMPLIFIED BOXES ARE EASYER THAN REG AMPS, ALL U HAVE TO DO IS RUN UR RCAS FROM THE BACK OF UR HEAD UNIT TO THE AMP, THAN UR POWER LEAD, FROM UR BATTERY TO THE AMP, THEN UR GROUND MOSTLY ON THE FRAM OF THE CAR OR ON THE BRACKETS ON UR SEATS, THATS MAINLY ALL U NEED TO NO.
0helpful
1answer

I think my amp is in protection mode how do i trouble shoot

disconnect speaker,turn gain down to about 10%.repower amp check and see if protection light comes on.if it does recheck power,remote,ground,if it doesent go into protection then kill power and rewire speakers
0helpful
1answer

Visonik amp problem... amp goes in and out of protection

Check for intermittent shorts on the speaker leads.

Turn down the volume control on your head unit while operating the amp, you could be over driving the amp.

Remove Speaker leads and reset the amplifier. IF the protection LED still comes on amplifier is faulty.

Below is the link to put in a help request with the manufacture for repair.
http://www.visonikcaraudio.com/category.jhtm?cid=27
0helpful
1answer

When the bass cut on the speakers cut off

220 watts RMS x 1 at 4 ohms (400 watts RMS x 1 at 2 ohms)
the amplifier may be over-driven. are there red protection lights coming on the front panel? Or a loose wire - power, ground, or speaker.
0helpful
1answer

Thumping speakers - no power light is on - wired correctly

the amp is going into protect mode due to something wrong in the amp or some thing in the wiring to it ooh yea if you are getting 18v power to the amp that is way to high it should not be higher then 15v if the amp is in protect mode it will not play at all.
0helpful
1answer

My amp is not working

For the visonik, you should check your speakers. You can use a D-cell battery. Remove the speaker wires from the amp and connect each speaker across the battery (for no longer than a few seconds). The speaker should pop each time the wires are touched to the battery. If they don't, the speaker is defective (assuming the battery isn't dead).

If the speakers are OK, you need to confirm that you have a good signal feeding the amp. You can use the RCA cables from another working amp in the vehicle. Do this with the amp that had the power light lit.

If you have signal going to the amp and the speakers are OK, the only two things left are the power supply feeding the amp (from the battery) and the amp. If you have B+ and remote voltage AND a good ground, the amp is defective.







For the pyramid, the amplifier probably has shorted output transistors. The amplifier will have to be repaired.
0helpful
2answers

VB101PK REV 13, AMP WITH SUBWOOFERS

was the amp hooked directly to the box? You probably rattled the power connections from the circuit board like I did on a PT 800 watt amp.but check amp fuses first.
0helpful
1answer

NEW AMPLIFIER WILL NOT LIGHT UP OR POWER UP

It sounds like your saying that you have two identical amp, that both are on the same power wires and remote wires and sam grounds? Well if thats the case then you did ok as One amp sounds like its blown. First tghing is check the main fuse. If its good and the unit still dosent resond then the power supply in the amp is blown as theres a switching supply that increases the 12 volts to get power to drive the Mosfet output devices. Was it ever working?? yes then the amp needs service. Do you know how to work on solid state elctronics down to componet level?? No?? Ok contact these folks at the addy im posting for you or take the amp to your local servicer. Good Luck. [email protected]
Not finding what you are looking for?
Visonik Dual Bass Box with Amplifier Car Audio Amplifier Logo

1,132 views

Ask a Question

Usually answered in minutes!

Top Visonik Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

5023 Answers

The Knight
The Knight

Level 3 Expert

76637 Answers

Brad Brown

Level 3 Expert

18693 Answers

Are you a Visonik Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...