Lanzar VIBE266 Car Audio Amplifier Logo

Related Topics:

Question about Lanzar VIBE266 Car Audio Amplifier

1 Answer

Power light doesn't stay on...

Hey, I recently, in fact just yesterday, purchased a Lanzar Vibe266 2000w Car Amp. I hooked it up, and got it running great and smoothly with no problems. Then after driving around for the day listening to the bass, it cut out. Gave it some time and then after a while it started playing again. I didn't think anything of it until I parked my car for probably an hour, came back to it and it was completly dead, and wouldn't start. I figured my battery just couldn't push enough power to keep the Amp running, so I would go buy a Capacitor today. Well the amp still worked for a bit, but again cut out. I thought my battery would just be too low t run it, but since then, and still now, When I turn my car on, the power light comes on, and then goes right over leaving the protection light on. Any ideas as to why it's doing this now, but before it got power fine, just used to much.

Posted by Trevor Spoor on

Ad

1 Answer

Anonymous

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 148 Answers

Caps are NEVER a solution to ANYTHING in a car audio system. If your car is lacking in power, you need a high output alt. All caps do is mask the problem until eventually your car's charging system is toast. Check this out: http://www.techlore.com/article/14696/

Posted on Aug 17, 2006

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

On a lanzar 535n 5 channel 3200 watt amp what is the best way to hook up 2 lanzar max 12 inch duel voice coil subwoofers

If your amp allows it hook the the sub's to the first two channels but bridge it and only run it on 2ohms so you don't blow your sub's
0helpful
1answer

Subs Won't work when wired

Hi,

Based on your post/description, pls try:
1. running the amp's power without the capacitor;
2. manually trigger the amp with the head unit off. Run it an determine if the backfiring still will occur (even with the head unit off);
3. temporarily interchange the left/right wiring;
4. temporarily interchange the + and - speaker wires;
5. run the amp normally trioggered by the headunit but remove the RCA connectors towards the amp.

If your concern has not been corrected or diagnosed which is at fault (wiring, amp, source) after completion of the above procedures, the amp may require an internal look and see.

Hope this be of initial help/idea. Pls post back how things turned up or should you need additional information.

Good luck and kind regards.

Thank you for using FIXYA.
0helpful
1answer

My lanzar mini max amp keeps loosing power at medium to high volume why is this

first off you need to find out if your subs are 2 ,4,6 ohm . then check what ohm your amp will run if it is cutting off it's pulling to much power or it's over heating it.there are certen ways to hook up your subs.
0helpful
1answer

The amp won't turn on

try hooking a wire from your mane hot to your remote and see if it comes on if so then your remote wire is bad from your radio
0helpful
2answers

I have a Lanzar Vibe 235 amp. the green power light is not coming on, but the red "protect" light is. how do i solve this problem??

Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. Time to purchase an old school Lanzar Opti Drive. Any of them. The 50 will kill some 12" subs .A thumbs up would be greatly appreciated if this answer is helpful to you. lanzar-vibe-235-amp-green-power-shonxoarcym4awy4zl1imx4o-2-0.jpg Lanzar
0helpful
2answers

Lanzar 800 watt amp protect mode stays on

protect mode usaully means that something has disrupted the power of feed lines to the subwoofer/speakers possibly fuse is blown in amp or amp is blown in which we hope not. see if you have a warrenty if blown and send back or bring it to where you purchased it from.
0helpful
2answers

Lanzar Vibe 1200D protection light

You will need to show it to a service technician as it seems the output section has blown so it remains in protect mode. One reason (could be) that the input to the amp was high and may have been clipping for some time before the amp decided it could take it no more
0helpful
1answer

Lanzar amp

If it keeps blowing fuses then #1 its internally damaged or "blown" .. Or #2 i would make sure you have the battery power hooked up to the + terminal and the ground wire running from the car body to the - terminal.. so if its hooked up correctly and keeps blowing fuses then it requires repair.. I wish i had better news but thats all it can be...
1helpful
1answer

PROTECT LIGHT COMES ON WITH 2 SPEAKERS HOOKED UP

Go to this website page and see if any of this applies to your problem. http://www.caraudiobook.com/car_audio_amplifiers/car_audio_amplifiers.htm
Not finding what you are looking for?

88 views

Ask a Question

Usually answered in minutes!

Top Lanzar Car Audio & Video Experts

Morne Olivier
Morne Olivier

Level 2 Expert

265 Answers

xxxxxx xxx

Level 3 Expert

5034 Answers

Mike G

Level 2 Expert

100 Answers

Are you a Lanzar Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...