Kenwood KAC-9152D Car Audio Amplifier Logo

Question about Kenwood KAC-9152D Car Audio Amplifier

1 Answer

I have a kenwood kac-9152d amplifer and it works just fine for about 10 minutes then just shuts off and subs dont work, about 30 seconds later my amp turns back on with the subs.

Posted by dalke1992 on

Ad

1 Answer

Pablo Gonzalez

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 733 Answers

Make sure it's well ventilated. If there's no air flow, then there is no way of cooling down and to protect itself it will shut off. Make sure the speakers are wired correctly as per amp specs. too many subs or subs connected improperly can draw too much current and shut the amp off, but you will notice this when you turn up the volume to a certain point and the amp shuts down.

Posted on Sep 26, 2011

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

Power amp wont power up

Check the fuses-should be a pair of 30 amps on the side. use a paper clip and jump power from the power+ to the remote+ and see if that lights it up-if it does than your remote lead isnt giving it juice-
0helpful
1answer

Deck, Sub and Amp Problems

check for any loose connections at the fuse block or a loose fuse
using an ohm meter would help
check the harness on the back of the radio for loose connection
bad igntion switch, again an ohm meter would help !
what type vehicle ?
0helpful
1answer

Kenwood KAC-8401 light goes from blue to red when turned on

Either the amp is ad or the sub got shorted? You can check itby disconnecting the Sub and seeing if the amp comes on blue then. If yes, then the sub is shorted. If no, then the amp is shorted. Also chck the voltage AT THE AMP. Make sure that it is above 12 Volts.

Larry T
Winona Lake, IN
http://www.cybersoundsaudio.com/cybersounds/vehiclepics.html
0helpful
1answer

I need help

Most of the time if the red light is on the amp is no blown but some times it does this cause the subs are hooked up in the wrong way. If the amp is only 2ohm stable and you hook the subs up to it at 1 ohm than the amp will not work so I would check this frist.
0helpful
2answers

Kenwood KAC-9152D monoblock

The amp says it's 1 ohm stable, so assuming the DVCs are dual 4 ohm, you should be able to connect all "+"'s together and all "-"s together, like the picture below:
0f1cebe.jpg

As for the amp shutting off for a few seconds, it sounds like it's either:
A) Not getting enough power at high volume.
OR
B) Overheating.

The cap on the +12V to the amp should help, but putting a meter on the +12V might tell you whether it's dropping too low (<11V).

When you first turn the volume up, how long does it work fine before shutting off? Is it with the vehicle running or not?
0helpful
3answers

Kenwood kac 9152D

Usually, protection mode is caused by one of these conditions:
  • Shorted speaker outputs.
  • Speaker output shorted to ground.
  • There is an internal issue, causing DC voltage to be present on the speaker outputs.
  • Amp overheats.
  • Ground connection is insufficient for amp or HU.
I'm not sure of the history or symptoms of your amp, but those are the reasons why the amp could go into protection mode.
0helpful
1answer

My kenwood amp

you need to check your wiring and check your rca wires to see if they are giving your amp a signal to put out
0helpful
2answers

Power on amp switch off when base is turned up

A: make sure that speakers size and watts.B: Type of speakers is used for base. C: Make sure the current (Amps)of the battery and your amplifier. D: Check audio from source and decrease the level of base. Thanks.
0helpful
2answers

Safety overheat fuse?

How hot is the amp when it shuts down?
0helpful
2answers

Kenwood kac-9152d

by jump do you mean all it does is thump and no sound besides thumping noise? if so put a better ground on your amp, double grounds work the best. please reply
Not finding what you are looking for?

209 views

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

5048 Answers

Marvin
Marvin

Level 3 Expert

85241 Answers

The Knight
The Knight

Level 3 Expert

76851 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...