20 Most Recent Pentair 1.0 Hp Whisperflo Pump Questions & Answers


if you have a sand filter or de filter turn system off then turn multiport to back wash turn back on let run until the backwash glass is clear turn off then turn to rinse turn back on for about 20 sec then turn off then turn multiport back to filter then turn back on

Pentair 1.0 Hp... | Answered on Jan 10, 2019


There are so many models of what may appear like the same motor, but the internals may vary????
If you can take off the cover & look at the capacitor itself, that is your best bet. You need to at least be at the equivalent of the same range of MFD!!!! Example 72 - 93 MFD!
You can go slightly higher, but not by much!
If you can't read what you currently have, then contact Pentair directly. They may be able to assist you with the right information.
Here is a link for your assistance...
Contact Pool Expert PENTAIR

Pentair 1.0 Hp... | Answered on Apr 28, 2015


sounds like a priming problem. look at the check valve in front of the pump in the suction line. sounds as if it is loosing its prime so you don't have enough water close enough to the pump to get it primed.

Pentair 1.0 Hp... | Answered on Apr 19, 2015


sounds as if pump has stuck start winding switch , try giving Motor not the pump a sharp knock with a rubber mallet when you 1st turn on , this might jar it loose if not a new motor might be needed , if motor was larger then say 2hp then id say get it fixed at a motor repair shop due to cost saving but smaller sizes it's not worth it most times

Pentair 1.0 Hp... | Answered on Dec 11, 2014


make sure basket is full and check the incomming union make sure tight also make sure top seal is ok

Pentair 1.0 Hp... | Answered on Sep 07, 2014


sounds like something is broken in the filter take off top shop vac out sand look to see if the laterals are broken if so replace and refill

Pentair 1.0 Hp... | Answered on Sep 07, 2014


You should be able to open an air relief valve at the top of your filter

Pentair 1.0 Hp... | Answered on Aug 25, 2014


Sounds like a thermal prolem. Is the fan plate on the motor? Are all the vanes free of obstruction, especially under the wiring box, once found a dead mouse under one on a pump that where the thermal cut out is usually located.

Pentair 1.0 Hp... | Answered on Jun 01, 2014


This is a air leak on your suction side between the skimmer and the pump. You will not see water in the yard on the suction side usually, only the return. It is usually just the fittings around your pump or the seal around the pump lid, check those first and make sure you do not have a loose clamp or a damaged or dry seal. If that is not it then call in your local service guy to determine where the leak is. They will most likely pressurize your suction line to find the leak. Hope that helps.
Time to Open the Swimming Pool

Pentair 1.0 Hp... | Answered on May 04, 2014


The side with the 1 1/4 inch (about) indention encircling the shaft hole faces toward the basket. That is where the seal is set. The other side of the seal sets into the impeller with the white side showing outward.

Pentair 1.0 Hp... | Answered on Jul 14, 2013

Not finding what you are looking for?
Pentair 1.0 Hp Whisperflo Pump Logo

47 questions posted

Ask a Question

Usually answered in minutes!

Top Pentair Pool & Spa Experts

Brad Brown

Level 3 Expert

18520 Answers

Marvin
Marvin

Level 3 Expert

85239 Answers

David Spradling
David Spradling

Level 3 Expert

11670 Answers

Are you a Pentair Pool and Spa Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

Pentair Pool & Spa

  • Pentair Pool & Spa

Most Popular Question

pump just begins start switches off

  • Pool & Spa
Loading...