20 Most Recent Sony Xplod 1200W Class AB Bridgeable 2-Ch. Amplifier w/Variable Low-Pass Crossover Questions & Answers

0helpful
1answer

Speakers buzz for a minute and then start to really hammer

sometimes cause by busted component, capacitor and amp chips. so you need to bring it to a expert
12/3/2017 11:10:58 AM • Sony Xplod 1200W... • Answered on Dec 03, 2017
0helpful
2answers

Guitar/amplifier 'buzz'

I have two amps .i need to know how to set the knobs on them. to get the best sound out of them .i have a crate and a drive elite.i am a beginner. they are both bass amps. so PLEASE HELP ME
3/5/2017 12:36:26 PM • Sony Xplod 1200W... • Answered on Mar 05, 2017
0helpful
2answers

My Sony XMGTR2022 goes into protect mode at

I discovered that there is a compatiblilty problem between the Bose receiver and the Sony amplifier. If I disconnect the receiver from the amp then the amp starts up normally. Apparently the receiver sends out a dc offset or a "thump" that the amplifier doesn't like and goes into protection mode. I solved the problem by putting a 1 second delay circuit between the receiver startup and the amplifier startup. A simple RC delay on the remote input to the amplifier solved the problem.
2/21/2015 4:15:48 AM • Sony Xplod 1200W... • Answered on Feb 21, 2015
0helpful
1answer

Amp going into protection

Is the amp bridged? If you only have one speaker connected to it, I sure hope so. How much power can that speaker safely handle and what is the impedance of the speaker? 2,4,8 ohm? A 1200 watt amp with only one speaker may be too much amp.
1/15/2014 3:34:01 AM • Sony Xplod 1200W... • Answered on Jan 15, 2014
0helpful
1answer
0answers
0helpful
1answer

I bought a new 1200

personally I would probaly contact the place where you bought the equipment, providing you have connected everything up correctly, it sounds like the amp is faulty
5/5/2011 6:26:34 PM • Sony Xplod 1200W... • Answered on May 05, 2011
0helpful
1answer

Settings for a Sony Xplod 1200 watt amp, with two 12 inch subs

What kind of subs are you running? Meaning what brand, what are the ohm, spl and wattage? I'll look up your amp while you get that info to me. Looking forward to helping you:) Thanks!
4/28/2011 3:20:22 PM • Sony Xplod 1200W... • Answered on Apr 28, 2011
0helpful
1answer

Need sitting for my amp

Hi,

Most fan cooled amplifiers would be fine on its side provided the flow of air is not impeded. Unless it's been modified the probability of a wire falling into the blades is pretty small. Where you may want to be concerned is if it's a convection cooled amplifier which would depend heat rising away from heat producing components and their heat sinks. Placing this type of amp on its side could reduce the efficiency of its cooling capabilities possibly causing it to thermally shut down and/or shorten its lifespan.

Please accept the solution if it's helpful. Do get back to us for any further query.

Thanks for contacting fixya.com

9/28/2010 1:28:15 AM • Sony Xplod 1200W... • Answered on Sep 28, 2010
0helpful
1answer

I have a 1200 w sony xplod amp, with 2 caps,

with no signal input the fuse should not blow ,if it blows then the amp has a short on it ,if it blows when the volume is turned up really high the try 60 amps .
6/25/2010 8:45:09 AM • Sony Xplod 1200W... • Answered on Jun 25, 2010
0helpful
1answer

Amp sounds good before i turn car on then it cuts

Not enough current/voltage getting to the amp

Check the battery with car running..should be 13.8 - 14.5 volts
4/19/2010 4:00:06 PM • Sony Xplod 1200W... • Answered on Apr 19, 2010
0helpful
1answer

How to bridge sony sm gtr2022 amp

Did you mean XM GTR2022. Heres the manual.
http://www.docs.sony.com/release/XMGTR2022.pdf
4/13/2010 4:45:33 AM • Sony Xplod 1200W... • Answered on Apr 13, 2010
0helpful
1answer

I have a 1200 watt sony xplod amp hooked up to a

this kind of problems usually happen when the amp is not getting enough current to power up the  
 amp. the moment a loud low frequency hits the amp it fails. cud be ur power unit not giving enough power to the amp or u have a loose connection somewhere on ur power line. besides 8gauge is a bit small. try using about 4gauge. should have good ground too. they draw large current so ur battery should be in top condition as well. 
4/9/2010 7:45:47 PM • Sony Xplod 1200W... • Answered on Apr 09, 2010
0helpful
1answer

I have 2 12'' subs 1300.watts and 2 1200watts amps

impedance mismatch cud be the culprit. make sure ur speakers are the right ohms for ur amp. most amps are designed to operate on a 4 ohms speaker load on bridge mode. some amps are never designed for bridge mode. so if u bridge these amps u will get less output. u have to be very careful when u make the connections. plus when u bridge two amps for 4 ohms load, the total impedance becomes 8 ohms. make sure ur speakers are 8 ohms. few ohms can make big difference on power amps.
4/8/2010 1:07:39 PM • Sony Xplod 1200W... • Answered on Apr 08, 2010
0helpful
2answers

I have 2 1300 watt 12inch subs connected to a 2

It's trying to tell you the impedance is too low when you bridge. Run the speakers in series, not parallel.
12/22/2009 5:20:47 AM • Sony Xplod 1200W... • Answered on Dec 22, 2009
0helpful
1answer

My amp is not getting enough power to turn on. I

Your first problem is buying a sony. Although their home audio is amazing their car audio needs a major overhaul. It sounds like you might have a bad capcitor on the board. If it was me i would just go purchase a real amp instead of sony.... sorry to burst your bubble but i know of an instance where all but 5 amps of sonys were bad on a pallet sent to a best buy... they are just cheaply thrown together.
10/14/2009 2:58:15 PM • Sony Xplod 1200W... • Answered on Oct 14, 2009
0helpful
1answer

I hooked this 1000 watt amp up.it turns on but it

Your amp needs to be serviced. Bad protection circuit. Take it to a local car audio shop and have them bench test it first to be sure. Hope this helps.
9/26/2009 2:10:43 AM • Sony Xplod 1200W... • Answered on Sep 26, 2009
0helpful
1answer

Distorted sound.

try to set up again may be cable instalation not properly to set
8/15/2009 6:17:10 AM • Sony Xplod 1200W... • Answered on Aug 15, 2009
Not finding what you are looking for?
Sony Xplod 1200W Class AB Bridgeable 2-Ch. Amplifier w/Variable Low-Pass Crossover Logo

25 questions posted

Ask a Question

Usually answered in minutes!

Top Sony Audio Players & Recorders Experts

The Knight
The Knight

Level 3 Expert

76851 Answers

Marvin
Marvin

Level 3 Expert

85241 Answers

Morne Olivier
Morne Olivier

Level 2 Expert

265 Answers

Are you a Sony Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

Sony Audio Players & Recorders

  • Sony Audio Players & Recorders

Most Popular Question

1200 w sony xplod amp 2 caps

  • Audio Players & Recorders
Loading...