20 Most Recent Sony DAV-S500 System Questions & Answers


the problem sounds like its with the s video connection, try using the composite video input

Sony DAV-S500... | Answered on Apr 28, 2020


Could be a bad solder joint inside the unit you have to tap.

Sony DAV-S500... | Answered on Aug 18, 2017


Not unless the record player has a 'pre-amp' installed to raise the signal level to one that the audio input can use. If the Sony does not have a phono input, it is likely that it won't work without the phono pre-amp.

Sony DAV-S500... | Answered on Apr 13, 2016


Does sound like the laser. Realitically, not worth repairing. I'd say you'd be worth connecting a cheap DVD player to the system - then the Sony can carry on providing the surround sound audio and the new DVD player can provide the video. Then, if the cheap DVD player is still going, it can move to a bedroom TV if and when you replace the surround system....

Otherwise, I would imaging the speaker set (and even the non-working DVD player) on its own might fetch a reasonable price on an auction site - anyone who has a stolen DVD unit will probably be desparate for the speakers as Sony don't sell them separately!

Sony DAV-S500... | Answered on Apr 02, 2015


What does it say? I assume this is on the screen? It could be a jack issue, depending on how it's wired, but I'd guess about 10% if that. There is a display microprocessor(one of the computers in your unit) IC that controls the headphone, display and about 20 other functions(most of which are seamless to you). It could be a solder connection issue, as when a microprocessor IC goes bad, they generally don't "heal" themselves.

If you are interested in a repair, please contact me at audioserviceclinic.com. Thank you.

Sony DAV-S500... | Answered on Aug 26, 2014


Sounds like it may have a cold solider joint or a loose connection on the board take the top off blow out all the dust and look for a loose connection or a burned trace on the board

Sony DAV-S500... | Answered on Jan 29, 2014


Does it work from the remote? If it's not that way either, most likely, you have a bad microprocessor(computer) IC in the unit. For more information, or should you have more question, please visit my website at audioserviceclinic.com. You may contact me directly through through the website. Thank you.

Sony DAV-S500... | Answered on Dec 20, 2013

Not finding what you are looking for?
Sony DAV-S500 System Logo

100 questions posted

Ask a Question

Usually answered in minutes!

Top Sony Audio Players & Recorders Experts

ThaMp3Doctor
ThaMp3Doctor

Level 3 Expert

8597 Answers

Muntejaya Ginting
Muntejaya Ginting

Level 3 Expert

10422 Answers

 Grubhead
Grubhead

Level 3 Expert

5700 Answers

Are you a Sony Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

Sony Audio Players & Recorders

  • Sony Audio Players & Recorders

Most Popular Question

want connect

  • Audio Players & Recorders
Loading...