20 Most Recent Hitachi i.mega HDC-401 Digital Camera Questions & Answers


There is a mode switch within the deck assembly that is probably dirty but not cleanable. I haven't repaired one of those for some years and am sure spares are no longer available for it. The 58 is V8 format and should be OK but may show similar symptoms due to age, in the future.

Hitachi i.mega... | Answered on May 24, 2017


It's bad/weak batteries. I had the same problem using Hyundai batteries, thought the camera had broken until I used Duracel instead and it worked as it should. Batteries don't last long in digital cameras full stop, but decent brands like Duracel will help.

Hitachi i.mega... | Answered on Sep 21, 2013


In most cases the flash bulb goes, however there is a mini circuit board that drives the flash and it does fail occassionly

Hitachi i.mega... | Answered on Apr 19, 2012


your card is probably locked take out the memory card and on the side is a lock tab slide the tab to unlock when you put it in your camera it may say format card when you do this it will format the card but will delete any pictures saved to the actual cameras memory so save them on your computer or print them.

Hitachi i.mega... | Answered on Mar 20, 2012


Try replacing the batteries, it is evident the camera is not getting enough power, especially when you run the flash, this should address the issue.

Hitachi i.mega... | Answered on Mar 18, 2012


Sounds like weak batteries. Possibly a bad battery. May look good till called on then voltage drops fast. Cam goes off, before saving image. Replace batteris.

Hitachi i.mega... | Answered on Jan 17, 2011


Hello

The problem is that the lens has become stuck in the barrel. There are some DIY solutions you could try, but the probability is that you will have to get it fixed by a professional.

Use these at own risk as it may further damage the camera.

Firstly , try connecting your ac adapter or usb cable.

Try holding the shutter button while switching on the camera.

Look at the lens , and if some of the lens 'circles' is misaligned or not concentric then try wiggling it (while holding camera lens down).

Try gently pushing or pulling the lens when it extends but this is risky as it may cause the lens barrel to slip out of its guidance system.

Another way to do this is to place the camera lens down on a hard surface and then power it up. Be sure to use a soft cloth or something similar as to not scratch your lens or casing. Let the lens push the camera up and down a few times and sometimes the little resistance provided by the camera is enough to get things going again.

Try hitting your camera near the lens on the body with the soft tissue on the palm of your hand.

Other than that , I would take the camera to a repair center for a evaluation to see if it would cost more to repair than to replace the camera.

If it is still under warranty I would suggest you take it in before trying any of these steps and remove any off-brand batteries or accessories as some stores are really fussy about warranty repairs on camera's with non-brand accessories.

You can also have a look at THIS link.

Hope the advise is useful. please do not hesitate to let me know if you need any further assistance. Also, please be so kind to let me know if you found this helpful.

Regards
Andrea

Hitachi i.mega... | Answered on Nov 14, 2010


GET A MANUAL AND LOOK IT UP YOURSELF

Hitachi i.mega... | Answered on Apr 04, 2010


Hello,
1.Remove your SD card from the camera.
2.Insert it to your laptop card hole
3.If a window opens opens automatically then just drag and drop your photos to where you can find easily.
4.If a window does not open then click to My Computer
5. Find your SD card there.
6. Do the instruction number 3.

That is all.

Hitachi i.mega... | Answered on Apr 02, 2010


If you use a memory card, then just get a card reader.

Hitachi i.mega... | Answered on Jan 22, 2010


I found the manual for free on another site.

Hitachi i.mega... | Answered on Oct 21, 2009


sry this is not a solution but i had the exact same problem with my fujifilm finepix a900 and all of a sudden about a year later mine worked again. i would remove any mem stick/ cards u have in the camera and try with a different set of batteries, u may possibly have to update or reinstall the firmware on your camera and if none odf these thing word i can only offer u my puzzleing solution leave the camera lying arroun without batteries for a prolonged period of time month at least and try to turn it on i have no explanation as to why it worked for me but it did

Hitachi i.mega... | Answered on Jul 10, 2009


ask here, they will get it

Hitachi i.mega... | Answered on Jun 28, 2009

Not finding what you are looking for?
Hitachi i.mega HDC-401 Digital Camera Logo

42 questions posted

Ask a Question

Usually answered in minutes!

Top Hitachi Cameras Experts

Ekse

Level 3 Expert

13434 Answers

Richard C Cohen
Richard C Cohen

Level 2 Expert

168 Answers

Marvin
Marvin

Level 3 Expert

85231 Answers

Are you a Hitachi Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

Hitachi Cameras

  • Hitachi Cameras

Most Popular Question

digital camera not flash hitachi hdc

  • Cameras
Loading...