20 Most Recent Alpine MRD-M501 Car Audio Amplifier Questions & Answers


turn off all the settings on the amp for (example, sub ,comp, lpf, etc put them all on the off position and then turn off your car remove your face plate and then try it agin it worked for me. but dont turn up the settings to loud the subs might nit be able to handle all the power thats y it does that 

Alpine MRD-M501... | Answered on May 17, 2013


Well it sounds like the safety switch is turning on. Which means it turns off. If you could clarify that would be awesome and i'm sure i or someone else could answer you better

Alpine MRD-M501... | Answered on Mar 06, 2010


THAT USEUALLY MEANS UR AMP IS WAY 2 POWERFUL FOR UR SUBS

Alpine MRD-M501... | Answered on Feb 28, 2010


Try a different input source. I have had this happen before and the easiest way to diagnose the root of the problem was to take a home CD player out to my car and use the outputs to power the amp. If the amp works, move upstream to the RCA wires (unplug them from the back of your head unit and plug them into the home CD player). If that works, you know the stereo isn't putting out a signal. Good luck!!

Alpine MRD-M501... | Answered on Jan 26, 2010


most likely when you paired your phone you did the standard discovery mode however on some model phones especially the Nokia you might have to force pair it and you can find that information on the menu settings on the bluetooth module, is it the BT-200,300,350,or 400?

Alpine MRD-M501... | Answered on Aug 08, 2009


Hello drmer17,

You do not say which Alpine head unit you are trying to use Imprint to adjust. If the receiver has the Ai-NET input and you are using Alpine's KTX-H100 tuning kit, make sure the Imprint crossover switch setting matches up with your speaker/subwoofer configuration. Also, I'd check the cables and remove and reseat them. Try switching the left/right channels and measure again. If the problem then switches to the right front speaker, you probably have a defective Imprint.

Hope this helps.

Alpine MRD-M501... | Answered on Jun 14, 2009


it may be the fuse

Alpine MRD-M501... | Answered on Jun 10, 2009


More info needed. It's like asking how to completely disassemble a car and expecting us to do everything for you. Please take some time to do a bit of research on your part so that we can better assist you and not have to work hours to answer your question.

Alpine MRD-M501... | Answered on Mar 17, 2009


Disconnect the speaker wires from the amp, then try it again. If the error message doesn't appear, try connecting the speaker wires back to the amp one by one.

The error message is due to some sort of overcurrent in the amp. If the error does not go away when the speaker wires are disconnected, the issue is most likely with the amp itself and will need professional repair.

Alpine MRD-M501... | Answered on Mar 17, 2009


Hi. If you shorted (touched) the speaker wires together, or let them touch the chassis of the car, then it may have locked out. Just turning the amp off and back on will fix this, so it sounds like you have done damage to it. Most amps have a speaker relay which gives a click sound when you turn on. If there is no click, then it may have a power supply failure.

Mark

Alpine MRD-M501... | Answered on Mar 16, 2009


OK, It looks like you may have an internal problem. I must say from the begining if you do not have a background in electronics take the unit to a qualified service center. Now it sounds like you could have a power supply problem if you have power coming in onpen the unit and with the use of a schematic find the main voltage rail and test from there each test point and make sure it matches the schematic value. Look for burnt circuit tarces nad if you find the remove them and jumper with re-trace wire.

Alpine MRD-M501... | Answered on Sep 16, 2007


One of the parts went bad, and you need to take it into the dealer. The way Alpine's error codes work are very vague. E-3 could mean the psu fried, a resistor went bad etc.

Alpine MRD-M501... | Answered on Aug 17, 2006

Not finding what you are looking for?
Alpine MRD-M501 Car Audio Amplifier Logo

20 questions posted

Ask a Question

Usually answered in minutes!

Top Alpine Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

5023 Answers

Marvin
Marvin

Level 3 Expert

85239 Answers

Muntejaya Ginting
Muntejaya Ginting

Level 3 Expert

10422 Answers

Are you an Alpine Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

Alpine Car Audio & Video

  • Alpine Car Audio & Video

Most Popular Question

error codes

  • Car Audio & Video
Loading...