20 Most Recent RTO AquaScape 4500 GPH Pump Questions & Answers


Maybe try to just buy a 20' extension cord cut off the connecting end and hardwire into the unit.... ?

RTO AquaScape... | Answered on Jul 19, 2014


The seal has failed allowing water into the sealed motor unit and it is now shorted to ground...in other words the unit is shot and needs to be replaced.

John

RTO AquaScape... | Answered on Apr 07, 2011


i have the wsame problem. A new pump will run me 550 I dont think I could replace the impeller shaft

RTO AquaScape... | Answered on Nov 13, 2010


You have checked that sure thing, but if you have that pump on a shared circuit that thing draws more amps than normal appliances or is competing with another appliance and popping the circuit. Try isolating the pump and also make sure the circuit can handle the amp load the pump is giving off. Hope this is helpful.. Good Luck!

RTO AquaScape... | Answered on Aug 21, 2010


Where the wire goes into the pump there is a o ring thatis probably leaking and any sort of water the motor might be getting is tripping the breaker. You probably have it plugged into a gfi and it sense very low amounts of water, and trips, You can determine by plugging it into a regular outlet and it should work. But definently fix the oring at the point of entry on the pump

RTO AquaScape... | Answered on Apr 17, 2010


Does it come back on after resting/cooling down. If does peobably kick out on heat overload and is resetting itself. If impeller is free spinning with NO roughness or side play in bearing probably too much head pressure,pumping too far or too small pipe wich will cause excessive pressure making pump work to hard

RTO AquaScape... | Answered on Apr 11, 2010


Typical with these pumps, pumps I have rebuilt that have done the same thing what happens is the bearings get loos and cocks the armature that is why it won't spin. I did serious research on these pumps and came up with a rebuild kit some parts bought some I make. I did mine 2 years ago and still working like a champ and have done over 20 locally with no problems. If your pump is noisy or the impeller has fallen off (typical) due to water getting in the unit and causing the bearings to fail email me and I can rebuild your pump. The process is simple send me the pump I will look at it and see if it can be rebuilt at NO CHARGE if it can be rebuilt you will save over 60% of a new one. Don't spend $349 - $599 on a new one let me look at it for free if I can rebuild it great if not you will have to buy a new one. I am not a dealer for any pumps so you will not have to worry about me selling you a pump and if you want the old one back pay the shipping and it it all yours.

RTO AquaScape... | Answered on Mar 09, 2010


water getting into pump.Thats what is triping it.

RTO AquaScape... | Answered on Aug 01, 2009


It's eithe your coil ha heat soak and needs replacing or your fuel circuit isn't venting properly and is creating a negative pressure

RTO Garden | Answered on Nov 22, 2013


Make sure your shut off valve is on positon not part way off,check for a screen plugged up in fuel tank or inline fuel filter, check for bad spark plug engine oil top up maybe saftety sensor when oil is low if you remove the fuel line from carb does gas flow straight out no problem?
Joe

RTO Garden | Answered on Oct 10, 2012

Not finding what you are looking for?
RTO AquaScape 4500 GPH Pump Logo

Popular Tags

13 questions posted

Ask a Question

Usually answered in minutes!

Top RTO Garden Experts

Dennis Key
Dennis Key

Level 3 Expert

2481 Answers

Bill Boyd

Level 3 Expert

53816 Answers

Tom Chichester

Level 3 Expert

60224 Answers

Are you a RTO Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

RTO Garden

  • RTO Garden

Most Popular Question

aquascape 4500 pump immediately trips

  • Garden
Loading...